This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Messages recommandés

Bonjour,
Je me permet d'ouvrir ce sujet car je rencontre quelques soucis depuis le passage de DSM en 5.0 (DSM 5.0-4458) concernant l'ajout de permissions aux bases PostgreSQL du NAS.
En effet j'ai plusieurs programmes maison installés sur mon PC qui ont besoin d'exécuter des requêtes SQL (seulement des select) sur 2 des bases pgsql.
Avant, à chaque mise à jour de DSM je modifiais le fichier pg_hba.conf qui se trouvait ici : /usr/syno/pgsql/etc/pg_hba.conf et j'ajoutais la ligne suivante :
host    all     all     192.168.1.1/24  trust

Tout roulait nickel jusque là.

Mais première chose bizarre, le fichier ne se trouve plus à cet endroit ! Il y a bien le dossier /usr/syno/pgsql/bin, mais aucune trace du dossier /usr/syno/pgsql/etc.
J'ai fouillé un peu partout et j'ai trouvé pg_hba.conf dans les dossiers ci-dessous :
- /etc/postgresql/pg_hba.conf
- /volume1/@database/pgsql/pg_hba.conf
Même après modification de ces fichiers (en ajoutant la permission pour que mon PC accède aux bases PostgreSQL), rien n'y fait.
J'ai redémarré plusieurs fois sans résultat.
Suis-je le seul à ne plus avoir le fichier pg_hba.conf à cet emplacement /usr/syno/pgsql/etc/pg_hba.conf ?
J'ai contacté le support Synology sans grands espoirs et comme je le pensais, étant donné que j'ai des 3rd party packages d'installé, ils me conseillent de tous les désinstaller puis de faire un hard reset pour réinstaller la version 5.0-4458 du DSM.
Malgré plusieurs relances, ils n'ont pas répondu à ma principale question : est-ce normal de ne plus avoir le fichier /usr/syno/pgsql/etc/pg_hba.conf.
Deuxième chose étrange : pas moyen de réinstaller phpPgAdmin.
Lorsque je veux le réinstaller, il me met le message suivant : "phpPgAdmin: Echec de l'opération.Please enable Web Station first."
Web Station est bien activé pourtant. J'ai essayé de le désactiver/réactiver sans succès.
Apparemment je ne suis pas le seul dans ce cas là.
Mais bon, ce qui m'importe aujourd'hui c'est surtout de pouvoir accéder aux base PostgreSQL depuis mon PC :)
Quelqu'un aurait une solution ?
Merci d'avance,
Maohi.
PS : damned ! j'ai fait une faute dans le titre ! je voulais dire via pg_hba.conf et non pg_bba.conf ! :unsure:
Modifié par Maohi
Lien à poster
Partager sur d’autres sites

Salut,

Je viens de trouver la réponse là : http://pronas.pl/jak-pod-czy-wewn-trznej-bazy-postgres-dsm-t6478.html

En gros le fichier pg_hba.conf est situé dans /etc/postgresql/ et il faut remplacer

listen_addresses = '127.0.0.1'

par

listen_addresses = '*'

dans le fichier /volume1/@database/pgsql/postgresql.conf qui contient d'ailleur en première ligne le nom du fichier pg_hba.conf valide.

Après tes modifications dans ces 2 fichiers, tu fais un beau

synoservicecfg --restart pgsql

Et c'est reparti !

A+

Michel

PS: Merci à fatboyx et à google translate :)

Lien à poster
Partager sur d’autres sites

Ca marche ! Merci encore !

Par contre au départ j'ai essayé de rajouter uniquement l'adresse local du PC comme ceci

listen_addresses = '127.0.0.1,192.168.1.1'

Mais ça n'a pas fonctionné.

C'est en mettant ceci que ça a marché

listen_addresses = '*'

Pas bien grave, je regarderais en détail plus tard.

Maohi

Lien à poster
Partager sur d’autres sites
  • 2 weeks later...

Hello,

Suite a l installation de openERP, j'ai besoin d'acceder a ma DB postgre

J'ai donc installé phppgadmin :)

Mais voilà lors que j'essaie de me logger sur l'application j'ai toujours un message d'erreur que ce soit avec admin ou root avec sou sans mdp

Sans mdp il indique connexion desactivée poiur raison de securité avec mdp il indique echec de connexion ....

J'ai modifié les fichiers comme tu l'as présenté j'ai redémarré les services

JE suis a distance donc je me connecte au nas via internet, est ce que c'est cela qui pose probleme ?

Merci d'avance pour votre aide

Lien à poster
Partager sur d’autres sites
  • 8 months later...

Hello,

Suite a l installation de openERP, j'ai besoin d'acceder a ma DB postgre

J'ai donc installé phppgadmin :)

Mais voilà lors que j'essaie de me logger sur l'application j'ai toujours un message d'erreur que ce soit avec admin ou root avec sou sans mdp

Sans mdp il indique connexion desactivée poiur raison de securité avec mdp il indique echec de connexion ....

J'ai modifié les fichiers comme tu l'as présenté j'ai redémarré les services

JE suis a distance donc je me connecte au nas via internet, est ce que c'est cela qui pose probleme ?

Merci d'avance pour votre aide

Bonjour,

J'ai le même souci en ayant modifié les deux fichiers.

Est ce vous avez une idée ?

Merci

Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai réussi a me connecter sur phppgadmin en utilisant le compte postgres en ayant mis a false l'option "$conf['extra_login_security'] = false;" dans le fichier "/usr/syno/synoman/phpsrc/phpPgAdmin/conf/config.inc.php".

Je ne suis pas satisfait de cette méthode car le compte est sans mot de passe. Mais je vais peut être pouvoir rajouter des droits au compte root pour y accéder en lecture seule ou créer un autres compte.

Lien à poster
Partager sur d’autres sites
  • 2 months later...

Bonjour à tous,

J'ai également le besoin d'accéder à ma base de données PostGresql, mais je n'y arrive pas (PgAdmin par exemple).

J'ai pourtant modifié le fichier suivant: /volume1/@database/pgsql/postgresql.conf, comme ceci:
listen_addresses = '*'

Une question, est ce normal qu'en faisant un ls -la, je vois le fichier de config comme ceci (tous les autres sont postgres:postgres) ?
lrwxrwxrwx 1 root root 31 Aug 4 2014 postgresql.conf -> /etc/postgresql/postgresql.conf

ensuite j'ai modifié mon fichier: pg_hba.conf, et j'ai ajouté la ligne suivante:

host all all 192.168.0.0/32 md5

Mais même après un restart, rien :/

Lien à poster
Partager sur d’autres sites
  • 7 months later...

bonjour,

 

je suis entrain de tester l'installation de noalyss sur un ds211, j'ai installé le module phppgadmin, sans soucis, créé un utilisateur sur postgresql avec entre autre les droits de création sans soucis 

 

j'ai modifié les 2  pg_hba.confepg_hba.conf, le postgresql.conf , mai toujours aucune connexion.

 

j'ai vérifié les logs (dans var/log) de postgresql et d'apache => rien concernant cette demande de connexion

 

j'ai vérifié si le firewall était bien désactivé, ....  tout devrait fonctionner, mais que nenni.

 

ayant un ds212+ j'ai essayé en suivant les mêmes procédures, idem => pas de connexion à la DB

 

j'ai essayé à partir d'une station linux avec un logiciel de gestion de db postresql distante => impossible de se connecter.

 

y aurait il une subtilité que je n'aie pas vu ?  Arrivez vous toujours à vous connecter à vos db dans les dernières version de dsm ?

 

Merci de m'avoir lu et de m'apporter la lumière :)

Lien à poster
Partager sur d’autres sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.