This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

slybreiz

Ds109 - [Hack Ds112J] Mise A Jour Dsm 5 U5 Plus D'acces

Messages recommandés

bonjour

en voulant mettre a jour mon Ds109 vers la version dsm 4.3 puis dsm 5 via la modification du fichier version par un ds112J

les mise a jour vers la version 4.3 et 5 se sont bine passé . il a tournée la journée avec la version dsm 5 a merveille ...

mais la mise a jour vers l'update 5 de dsm 5 je n'es plus d’accès

je ping bien mon nas mais rien d'autre ds assistant ne le vois plus .... briquage ou pas ?

une solution pour faire un hard reset ?

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

je re-viens vers ceux qui ont upgradé leur ds109 en dsm5.0 ... Confirmez vous que le gain en reactivité est appreciable par rapport à dsm4.2 ou bien comme c'est nouveau c'est mieux ... ;) J'utilise audio station & video station principalement.

J'ai aussi un ds210j en dsm5.0 mais il sert de stockage sans services activés donc difficile de comparer.

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je possede un ds109 que j'aimerais upgrader en ds112j

la derniere version du dsm 4.2 en 3252

voici les fichiers :

/etc.defaults/VERSION

majorversion="4"
minorversion="2"
buildphase="hotfix"
buildnumber="3252"
builddate="2014/09/04"

/etc.defaults/synoinfo.conf

unique="synology_88f6281_109"
company_title="Synology"

# system options
timezone="Pacific"
language="def"
maillang="enu"
codepage="enu"
defquota="5"
defshare="public"
defgroup="users"
defright="writeable"
eventsmtp=""
eventmail1=""
eventmail2=""
eventauth="no"
eventuser=""
eventpasscrypted=""
configured="no"
admin_port="5000"
secure_admin_port="5001"
pswdprotect="no"
supportweb="yes"
supportphoto="yes"
support_download="yes"
supportmysql="yes"
supportquota="yes"
supportitunes="yes"
supportddns="yes"
supportfilestation="yes"
supportssl="yes"
supportssh="yes"
supportHTTPS="yes"
supportNFS="yes"
supportrsrcmon="yes"
supportmemtest="yes"
supportmount="yes"
support_fw_security="yes"
support_directory_service="yes"
support_power_schedule="yes"
support_buzzer="yes"
support_poweroff="yes"

# service options
runsamba="yes"
runapple="yes"
runftpd="no"
ftpport="21"
syslogport="514"
ftp_trans_ext_ip="no"
ftpflowcontrol="no"
ftpmaxuploadrate="0"
ftpmaxdownloadrate="0"
ftpanonymouslogin="no"
diskcache="on"
standbytimer="20"
standby_force="yes"
enableguest="no"
usbbkp="yes"
usbcopy="yes"
netbkp="yes"
runnetbkp="no"
runmysql="no"
supportmediaservice="yes"
runmediaservice="no"
supportups="yes"
ddns_update="no"
ddns_select=""
ddns_reclaim_interval_mins="3"
portmap_admin="no"
portmap_ftp="no"
portmap_http="no"
portmap_http_add="no"
portmap_netbkp="no"
portmap_netbkp_encrypt="no"
php_openbasedir_customize="no"
ss_sync_event_player="yes"
ss_cms="yes"
ss_vs="yes"
run_bonjour_printer_service="yes"
tunnel_enable="no"
printer_driver_host="http://download.synology.com/airprint/DSM4.1"

# service limitations
maxaccounts="1024"
maxgroups="128"
maxshares="256"
maxservices="64"
maxdisks="1"
maxprinters="2"
maxlogsize="64"
maxvhost="30"

# UI options (limitations)
company="synology"
supplang="enu,cht,chs,krn,ger,fre,ita,spn,jpn,dan,nor,sve,nld,rus,plk,ptb,ptg,hun,trk,csy"
product="DiskStation"
manager="Synology DiskStation"
vender="Synology Inc."
mailfrom="Synology DiskStation"
updateurl="http://www.synology.com/"
win98autodisconnect="yes"

wins="none"
AppleTalk="eth0"
default_ip="dhcp"
default_mask=""
default_gateway=""

hostname="DiskStation"
ntpdate_period="daily"
ntpdate_server="pool.ntp.org"
ntpdate_server_backup=""
run_ntp_client="yes"
run_ntp_server="no"

sdkversion="no"
allowanonymous="yes"

httpport="80"
defaultfs="ext4"
addport="no"
supportuart2="yes"
runafp="yes"
oplock_disabled="no"


# SMS options
smsserver="clickatell"
smsport="80"
smstemplate="https://api.clickatell.com/http/sendmsg?user=@@USER@@&password=@@PASS@@&api_id=3148203&to=@@PHONE@@&text=@@TEXT@@"
smssepchar="+"
smsuser=""
smspass=""
smsphone1=""
smsphone2=""
smsssl="yes"
smstest="no"
smsneedinterval="no"
smsinterval="1"

# VS60 options
vs_version="1.1"

# DSM auto update default server
rss_server="http://update.synology.com/autoupdate/genRSS.php"

# Push Service Server address
pushservice_server_1="https://sns1.synology.com:8089/api/"
pushservice_server_2="https://sns2.synology.com:8089/api/"

# Redirect Server address
redirect_server="https://gofile.me/"

package_update_channel="stable"

update_server="http://update.synology.com/"

upnpmodelurl=""
upnpmodelname="DS109"
upnpmanufacturerurl="http://www.synology.com/"
runupnp="no"
upnpfriendlyname="DiskStation Device"
upnpdevicetype="DiskStation"
upnpmodeldescription="DiskStation UPnP Device"
support_s2s="yes"
supportESATA="yes"
supportldap="yes"
support_smb2="yes"
supportMFP="yes"
support_iscsi_target_block="yes"
timebkp_max_task="2"
showdisktemperature="yes"
sdcard_partition_warning_percent="0.01"
support_audio="yes"
showtempdesc="yes"
esata_partition_warning_percent="0.01"
supportphotopersonal="yes"
supportMTU="yes"
support_fan_adjust_dual_mode="yes"
support_synoacl="yes"
usb_disk_warning_percent="0.01"
disk_warning_percent="0.01"
php_cache_size="32"
supportsurveillance="yes"
support_wimax="yes"
esata_disk_warning_percent="0.01"
mfp_autotimer="60"
esataportcfg="0x2"
iscsi_target_type="lio"
synobios="ds109"
supportdcacheui="yes"
supportdomain="yes"
support_wireless="yes"
supportstartupd="yes"
vpn_conn_max="5"
supportext4="yes"
enableRCPower="no"
sfmaxworkercount="12"
support_auto_poweron="yes"
buzzeroffen="0x1f"
sdcard_warning_percent="0.01"
supportfileindex="yes"
mfp_manualtimer="300"
support_synopkg="yes"
internalportcfg="0x1"
supportrcpower="yes"
support_share_encryption="yes"
supportntfswrite="yes"
usbportcfg="0x70000"
max_iscsiluns="10"
support_mtd_serial="yes"
max_iscsitrgs="10"
surveillance_camera_max="8"
supportsnapshot="yes"
fantime="1"
s2s_task_max="2"
supportsmart="yes"
usb_partition_warning_percent="0.01"
support_iscsi_target="yes"
max_volumes="32"
fan_config_type_internal="high"
buzzeroffcfg="0x00"
max_lunbkp_srv="1"
support_iscsi_lunbkp="yes"
supportVLAN="yes"
sfmaxusercount="1"
supportTc="yes"
supportvideostation="yes"
eth0_mtu="1500"
support_timebkp_server="yes"
s2s_watches_max="102400"

Il me faudra modifier le parametre :

unique="synology_88f6281_109" en 112j

et je pense qu'il faut changer tous les ds109 en ds112j

Mais avant de faire la manipulation j'aimerai vous poser quelques questions :

- Le fichier synoinfo dans etc doit il etre aussi modifie

- Quels sont les autres parametres a modifier dans synoinfo que ce soit dans /etc ou /etc.defaults

- Dois je rebooter apres avoir modifie le fichier synoinfo et avant de proceder a la mise a jour ?

- Puis faire la mise a jour en procedant par etape : vers 4.3 puis 5.0 ou direct vers 5.0 ?

- Ce nas me sert de serveur dns/dhcp , pxe et openvpn (freedomip) je ne me suis pas servi des

packages synology mais ipkg , d'ou ma question ne vais je pas perdre ma config ipkg ?

Merci pour vos retour

Forezien

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je viens de récupérer mon DS109 modifié que j'avais prêté.

Je pense faire la mise à jour demain pour voir si tout se passe bien vu que ce n'est pas mon NAS principal.

Je vous tiens au courant.

Flixor

Partager ce message


Lien à poster
Partager sur d’autres sites

OK merci bien j attend le retour. .

Pour l instant je vais essayer de faire passer mon disque de 2To. Dessus .

Envoyé de mon A3-A20FHD en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Petit retour d'installation.
J'avais prêté ce NAS à un ami donc il est presque vierge : juste "Serveur multimédia" installé sur un disque de 500 Go Seagate.

L'installation se passe sans soucis en moins de 10 minutes.
Première constatation : l'écran d’accueil a changé mais rien de révolutionnaire.
Les packages installés par défaut sont : Text Editor, Hyper Backup et Hyper Backup Vault, Storage Analyzer et PHP 5.6.
J'ai installé "Download station" et plein d'hébergeurs de fichiers ont été ajoutés via le plugin Pyload.

Avec si peu de packages, le CPU est mini à 25 % et la mémoire est mini à 40 %.
Démarrage à froid en 170 secondes (comptées avec ma tête) et la mémoire est plus dans les 45-50 %.
Il ne faut pas s'attendre à un foudre de guerre mais cela fonctionne.
L'extinction est relativement rapide.

Si d'autres infos sont nécessaires, n'hésitez pas et bon courage pour ceux qui vont sauter le pas.

Flixor
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je viens de faire l'opération. Je suis passé de la version 4.2 (dernière version autorisée pour le DS109) à la 5.0-4528-2. Je ne cherche pas à aller plus loin pour l'instant car j'ai seulement besoin du DSM 5.0 pour installer un nouveau package qui était incompatible avec DSM 4.2.

Tout ne s'est pas bien passé la première fois parce que je n'ai pas appliqué exactement le protocole. Autant que d'autres profitent de mon erreur en la partageant.

L'idée consiste à faire croire au système que le DS109 est un DS112j (hardware le plus récent compatible avec le DS109.)

Depuis une connexion telnet vers le syno (login "root"), on édite le fichier /etc.defaults/synoinfo.conf et on modifie la première ligne. Pas besoin de modifier autre chose.

En détails :

telnet 192.168.0.10
Trying 192.168.0.10...
Connected to 192.168.0.10.
Escape character is '^]'.

rederon-nas login: admin
Password:

BusyBox v1.16.1 (2016-04-28 18:03:53 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

rederon-nas> cd /etc.defaults
rederon-nas> vi synoinfo.conf

La première ligne du fichier est la suivante :

unique="synology_88f6281_109"

Tu te déplaces avec la flèche droite du clavier jusque sur le 0 du 109.
Tu tapes ensuite la touche "escape" puis 2 fois "x" pour supprimer le 0 et le 9
Tu tapes ensuite "espace" puis "i" pour insérer tu texte, et tu tapes alors 12j

Ta première ligne doit alors ressembler à ça :

unique="synology_88f6281_112j"

Si tu penses avoir écrit une bêtise, le mieux est que tu sortes du fichier sans sauvegarder en tapant "escape" puis ":" puis "q" puis "!" puis "retour chariot"

Si au contraire tu es sûr de toi alors tu sauvegardes et tu quittes le fichier en faisant "escape" puis ":" puis "w" puis "q" puis "retour chariot"

Écrire ensuite exit pour sortir du telnet.

Je fais maintenant une parenthèse : après la modification du fichier, j'ai fait l'erreur de redémarrer le serveur Synology en pensant que la modification allait être prise en compte à l'issue du redémarrage : en fait, cela a complètement fait planter le système. Le NAS était inaccessible.
Pour m'en sortir j'ai dû faire un double reset (appui long sur le bouton reset jusqu'à entendre un bip, et ceci 2 fois de suite.)
Il faut ensuite se reconnecter avec l'assistant Synology (la dernière version pour DSM 6.0 c'est mieux) puis réinstaller la version 4.2.
J'avais des sauvegardes mais je n'ai perdu aucune donnée ni aucun fichier de configuration dans la manip. Les outils Synology sont vraiment bien faits.

Fin de la parenthèse. Revenons donc au moment où le fichier synoinfo.conf vient d'être modifié.

Depuis l'interface DSM, dans le panneau de contrôle, il suffit de vérifier les mises à jour.

L'outil ne m'a pas proposé la version 5 tout de suite. Il m'a d'abord proposé la version 4.3. J'aurais pu forcer la mise à jour directement en 5.0 en passant en manuel mais je me suis dit qu'il y avait peut-être un risque de perdre des données si l'écart entre les versions était trop grand ou inadapté.

Je l'ai donc fait en 2 fois. 4.2 -> 4.3 -> 5.0. C'est un peu plus long mais ça à bien fonctionné.

A noter que lors du passage en 4.3 je n'ai perdu aucune donnée et que tout était configuré comme avant, ce qui n'a pas été le cas du passage 4.3 vers 5.0.

Après le passage en 5.0, toutes mes données ont été conservées, mais certains paquets devaient absolument être mis à jour car il ne sont plus compatibles avec DSM 5.0. C'est notamment le cas de Photo Station que j'avais conservé en version 5.2-2413 (compatible DSM 4.2 et 4.3) car je le préférais à la version 6 de Photo Station. Depuis l'upgrade en DSM 5.0, je n'ai plus le choix.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir à tous,

Je déterre ce topic car ce sujet m'intéresse. J'ai en effet un DS109 et je souhaiterai le migrer vers un DSM au delà du 4.2.

Pour ceux qui sont passés en DSM5 ou DSM6, le NAS est-il complètement fonctionnel, et le bouton arrêt est-il bien opérationnel ? J'ai lu sur d'autres fils que cette migration pouvait poser problème à ce niveau.

Merci pour vos retours.

Bonne soirée.

Modifié par sitruc

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant