This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Maxime23

probleme lecture fichier php

Messages recommandés

Bonjour,

j'ai actuellement des soucis lors de la ' lecture ' de mon code PHP. J'ai installé PHPmyadmin, apache server, php version 7 etc..

Mon code se trouve dans le bon dossier et par exemple lorsque je lance la page ' test.php', le navigateur va m'afficher le HTML/CSS/JS de cette page MAIS ne va pas lire le PHP, ou ne pas comprendre je ne sais pas...

Alors j'aimerai savoir comment faire , si j'ai oublié d'activer des services ou autres ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Même problème..

Désolé double post mais c'était pour bien expliquer, par exemple voici mon code ( en fichier joint), lorsque j'ouvre la page, il n'y a juste le contenu HTML qui s'affiche ( donc test ). Pourtant en local avec wamp cela fonctionne parfaitement

 

test2.php

Modifié par Maxime23

Partager ce message


Lien à poster
Partager sur d’autres sites

Comme PHPMyAdmin est également dans le dossier /web, ça veut dire que PHP fonctionne normalement.

Crée un fichier index.php dans le dossier /web avec le contenu suivant :

<?php

phpinfo();

?>

Dis-moi si le résultat s'affiche correctement.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, PiwiLAbruti a dit :

Comme PHPMyAdmin est également dans le dossier /web, ça veut dire que PHP fonctionne normalement.

Crée un fichier index.php dans le dossier /web avec le contenu suivant :


<?php

phpinfo();

?>

Dis-moi si le résultat s'affiche correctement.

Voila ce qui s'affiche ( le code s'affiche sans s'executer )

affichage.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Vous parlez plus haut de wamp.

J'en déduis que vous développez sous Windows puis transférez les fichiers sur le NAS.

Vous devriez vérifier le type d'encodage de vos fichiers.

Si vous avez accès en ssh au NAS, essayez la commande dos2unix sur le fichier qui pose problème.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement