This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

rvga

2ème page introuvable

Messages recommandés

Bonjour le forum,

J'ai besoin de suggestions de recherche pour mon petit problème :

J'ai créé un site WP (http://c-serp.fr/) sans passer par le paquet. La 1ère page créée par défaut fonctionne bien, elle est accessible, modifiable via la console et bien visible.

Lorsque je créé une 2ème page, celle-ci ne l'est pas et une belle '404' s'affiche. L'article "hello-world" lui non plus n'est pas visible 😞

Je n'ai pas changé les permaliens, j'ai bien le module rewriting activé. Je ne comprends pas trop pour quoi cette 2ème page reste introuvable ?

Je commence à tourner en rond, si vous avez des pistes à me soumettre je suis preneur...

D'avance merci.

Modifié par rvga

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Là tout de suite, à première vue, je constate surtout que si tu parles des pages "test et blog", ces dernières au niveau de la redirection vont vers des dossiers "test et blog".

Met un dossier "test" et un dossier "blog" dans ton dossier web avec dans chacune un index.html (par exemple) et ça devrait fonctionner.

Si maintenant, ton but est d'avoir une redirection sur une page créée sous WP, je suppose qu'il faut que tu revois la configuration de WP car à mon avis, c'est là que ça ne va pas. Après, je suis pas un expert en WP...

 

EDIT : Autant pour moi, je viens d'installer rapidement un WP pour tester et les pages sont considérer comme des dossiers. Je veux dire par là qu'il n'y a pas d'extension de fichier comme .html, .php etc...

Il doit y avoir un soucis dans ta config WP je suppose.

Modifié par Zeus

Partager ce message


Lien à poster
Partager sur d’autres sites
Citation

"Soucis dans ta config"

Je suis d'accord mais lequel ? J'ai peut-être une piste...

Je me suis rendu compte que si je change le permalien en "simple" (genre " http://c-serp.fr/?p=123 " la 1ère option des Réglages/Permaliens) alors les pages redeviennent accessibles.

Si je change en n'importe quelle autre option dont la 5ème celle qui m'intéresse : "Titre de la publication" (http://c-serp.fr/exemple-article/) toute me renvoie une 404.

Puis mon regard a été attiré par une petite phrase que je ne connaissais pas à cet endroit de la page des réglages permaliens, juste en dessous du bouton de validation des modifications, il est inscrit :

"Documentation sur la configuration de Nginx (en)." Le lien m'emmène sur cette page où il est rapidement stipulé :

  • With Nginx there is no directory-level configuration file like Apache's .htaccess or IIS's web.config files. All configuration has to be done at the server level by an administrator, and WordPress cannot modify the configuration, like it can with Apache or IIS.
  • Pretty Permalinks functionality is slightly different when running Nginx.
  • Since Nginx does not have .htaccess-type capability and WordPress cannot automatically modify the server configuration for you, it cannot generate the rewrite rules for you.
  • Without modifications to your install, "index.php" will be added to your Permalinks. (There are ways to mitigate this with plugins (see below) and/or adding custom code to your child theme's functions.php.)

Je suis pas un spécialiste de Nginx mais je crois comprendre que, le fait que mon site soit basé sur Nginx ça fonctionne pas aussi bien qu'avec Apache, du coup ça chatouillerait les permalinks... (?)

J'essaierai de changer de serveur (si je peux) pour voir s'il y a une différence dans le fonctionnement.

Est-ce que ça inspire certains d'entre vous ?

Je pense que mon problème c'est celui décrit juste au-dessus, càd que les permaliens ne sont pas gérés de la même façon entre Apache et Nginx et qu'il semble falloir bidouiller qq part dans Nginx pour que ça fonctionne.

C'est ce que semble dire cette vidéo

Partager ce message


Lien à poster
Partager sur d’autres sites

Perso, je tourne sous Apache. Trop de soucis avec Nginx qui viennent peut-être de moi car je suis pas grand connaisseur. Mais en restant sur Apache, je maitrise plus et je rencontre aucun soucis avec mes sites persos.

Partager ce message


Lien à poster
Partager sur d’autres sites

Résolu 🙂

Le problème de cette 2ème page (et d'autres) qui générait une 404, venait tout simplement de la non configuration du serveur Nginx.

Pour éviter d'aller modifier Nginx (pas du tout expert) j'ai préféré basculer au niveau du paramétrage du Virtual Host, le serveur principal en Apache au lieu de Nginx.

Je peux à nouveau choisir le Permalink voulu et les pages s'affichent sans générer de 404.

 image.png.89dd0a55273f942364b0ba1ac87211d1.png 

Modifié par rvga
Correction de coquilles ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant