This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

benprod

DDNS non pris en compte et Let's Encrypt

Messages recommandés

Bonjour à chacun,

J'espère que la communauté va bien,

Je viens vers vous car j'ai une question concernant le DDNS sur mon NAS DS1817. Pour l'instant lors que j'essaye de me connecter avec un lien partagé, il me renvoie Désolé, la page que vous recherchez est introuvable alors que si je rentre l'adresse IP directement, là tout fonctionne.

J'ai également une autre question : J'avais un certificat Let's Encrypt qui a parfaitement fonctionné pendant 3 mois. Puis il est arrivé à expiration. Et là, impossible de le renouveler. Je pense que c'est lié au changement de FAI entre temps qui ne doit pas fournir toutes les redirections nécessaire à Let's Encrypt. (Su ma Box j'ai juste 80 vers 5000 et 443 vers 5001)

Si l'un d'entre vous pouvais m'aider ce serai fantastique.

Je suis là pour tout renseignements complémentaire. (J'ai déjà fait pas mal de recherches et testé pas mal de trucs, j'ai suivis pas mal de tutos aussi mais le problème persiste).

Belle soirée à chacun

Partager ce message


Lien à poster
Partager sur d’autres sites

Qu'est-ce que vous appelez un lien partagé ?

Houla la non ! On ne dirige pas le 443 vers le 5001 et encore moins le 80 vers le 5000. Ils doivent être tous les deux dirigés vers les 80 et 443 du NAS sans translation de port. Raison pour laquelle vous ne pouvez pas avoir de renouvellement de votre certificat puisqu'il faut avoir le 80 ouvert sur le NAS. Vous pouvez très bien laisser ce port ouvert en permanence en créant deux règles dans le parefeu pour les 2 IP de Let's Encrypt

Autre chose, on ne fait pas sortir les ports http du NAS (5000, 7000 et consorts) vers l'extérieur (sinon à quoi servirait le certificat).

Mais au vu des réglages que vous avez fait, je vous suggère de d'abord mettre en pratique l'excellent tuto de Fenrir sur la sécurité de nos NAS avant de penser à ouvrir votre NAS vers l'extérieur. Vous le trouverez dans la section Tutoriels.

Enfin, si votre NAS fonctionne en RAID ou SHR je vous recommande de l'alimenter avec un onduleur compatible pour vous prémunir des coupures de courants non contrôlées qui sont souvent la cause de pertes de données, voire de volume.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

L'accès externe via un DDNS est possible et reconnu pour les parage si le NDD est paramétré dans le NAS.

  1. Panneau de configuration du NAS
  2. connecté en tant qu'utilisateur du groupe admin
  3. section Accès externe
  4. Onglet avancé
  5. rubrique nom d'hôte ou ip statique

Des lors en se connectant directement au NAS via cette adresse NDD:5001 lors d'un partage  par fileStation l'adresse proposée sera bien celle souhaitée.

Par ailleurs pour le renouvellement du certificat Let's encrypt ça se fait via le 443 vers le 443 et le 80 vers le 80.

Oups moins rapide que @Mic13710....😁

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Et oui @daffy, j'ai encore de bons réflexes malgré mon grand âge 👴.

Mais bon, tu as répondu pour le DDNS. J'ai préféré orienter @benprod vers le tuto sur la sécurité car il me semble qu'il y a d'abord du grain à moudre de ce côté là.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Merci pour vos réponses rapides et de qualité,

J'ai commencé à faire les modifications demandées et je vais regarder le tutoriel en détail pour qu'il n'y ai pas de problèmes. Et du coup je pense qu'avec vos réponses il ne devrait pas y avoir de problèmes concernant Lets encrypt maintenant.

Cependant je n'arrive pas à comprendre pourquoi en DDNS je n'arrive pas à voir mes partages.

En appliquant les modifications proposés par daffy je passe d'une page généré par Synology à la page d'erreur par défaut de chrome : ce site est inaccessible. Si vous pouviez m'apporter votre lumière ce serai génial.

Partager ce message


Lien à poster
Partager sur d’autres sites

A mon avis mieux vaut d'abord commencer par :

il y a 28 minutes, benprod a dit :

regarder le tutoriel en détail pour qu'il n'y ai pas de problèmes

Et ensuite seulement :

il y a 28 minutes, benprod a dit :

faire les modifications demandées

 

il y a 31 minutes, benprod a dit :

Cependant je n'arrive pas à comprendre pourquoi en DDNS je n'arrive pas à voir mes partages.

Encore une fois, qu'est-ce que vous appelez des partages ?

Et pour mieux comprendre votre soucis, des copies d'écran des ports de votre routeur ainsi que du parefeu du NAS nous permettraient d'y voir un peu plus clair.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, daffy a dit :

Par ailleurs pour le renouvellement du certificat Let's encrypt ça se fait via le 443 vers le 443 et le 80 vers le 80. 

Tu es sûr de ça Daffy ?

A ma connaissance, Let's Encrypt sur un NAS Synology ne prend en compte que l'ouverture du port 80 pour une création ou renouvellement de certificat.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

J'ai bien regardé le tutoriel en détail. Et j'ai réussit à régler le problème lié à mes liens partagés. Il sont maintenant de nouveau accessible depuis Internet. Le seul problème qu'il me reste c'est d'ajouter un certificat Let's Encrypt. Je vous donne plus de détail :

  1. J'ai un nom de domaine qui pointe avec des champ A vers un serveur
  2. J'ai un sous domain server.mondomaine.com avec un champ A qui pointe vers ma box Internet.
  3. J'ai un DDNS Ovh sur server.mondomaine.com
  4. Ma box est configurée avec ce DDNS
  5. Ce DDNS est également paramétré dans DSM.
  6. Lets Encrypt fonctionne parfaitement sur mondomaine.com

Il y a juste un petit truc qui me manque je pense pour pouvoir régénérer un certificat. Pour l'instant j'ai juste désactivé le Par-feu car je veut simplement que mon certificat puis être généré.

Je vous remercie encore pour votre aide,

Modifié par benprod

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant