This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

[TUTO] Pourquoi et comment utiliser un nom de domaine ?


Messages recommandés

Il y a 1 heure, Thierry94 a dit :

@Majormax comme tu as le reverse proxy c'est cette url qu'il faut taper en extérieur pour atteindre Photo Station https://photo.nomdomaine.xx/photo et pour DSphoto c'est photo.nomdomaine.xx

 

Je sais pas comment tu fais j'ai une page d'erreur......j'y arrive effectivement en http mais pas en https !!

Il y a 1 heure, Thierry94 a dit :

Les autres accès du reverse proxy fonctionnent ils ? (exemple file.nomdomaine.xx, ...

Dans les lignes du reverse proxy tu as bien la case HSTS décochée et la case HTTP/2 cochée ?

Et dans les paramètres de Photo Station tu as bien décoché la case "Rediriger automatiquement les connexions http vers https" ?

 

Oui pour les trois questions

 

Il y a 1 heure, Thierry94 a dit :

@Majormax

Tu as un problème de sécurité sur Photo Station (désolé mais comme tu as mis ton nom de domaine j'ai essayé de voir le problème d'accès)
- Photo Station est accessible en http (http://nomdomain.xxx/photo) -> à bannir (tu as fait un routage du port 80 sur ta box … à retirer pour ne laisser que le port 443 du reverse proxy)
- Tous tes albums sont publics donc accessibles sans connexion à Photo Station … je n'ai pas poussé jusqu'à intervenir sur les photos pour voir si les maj étaient autorisées 😉

A corriger d'urgence !

Pour le port 80, je le ferais ce soir, je n'ai pas accès à ma box du bureau ;)))

J'ai mis les albums en privés, normalement on ne les voit plus.

Merci aussi à @Zeus pour le tuto, je pense que le problème est réglé.

J'ai les mains plein de cambouis 😀

 

Modifié par Marjomax
Correction de quelques fautes d'orthographes
Lien à poster
Partager sur d’autres sites
  • Réponses 332
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Bonjour, Je vois encore trop de personnes cherchant de l'aide sur l'utilisation de leurs adresses IP pour se connecter à leurs serveurs à distance ou pour partager des données. Je vais donc

ma "remarque" était justement pour ne pas trop s'y attarder, et ne surtout pas reprendre qqn qui se donne bcp de mal pour faire vivre ce forum et faire des autos sympas

Et pour finir de répondre après Daffy, oui tu peux supprimer les entrées qui te sont inutiles comme par exemple celles concernant la partie mail d'OVH si tu n'utilises pas ce service 😉  

Posted Images

il y a 3 minutes, Thierry94 a dit :

Dans photo station il y a un paramétrage pour définir si les nouveaux albums sont publics ou privés  ... par défaut le paramètre est sur public 

Oui c’est fait ça !

merci

Mais le soucis est toujours là ....

Lien à poster
Partager sur d’autres sites
Citation

Mais le soucis est toujours là ....

Non, ton domaine photo est bien en privé maintenant. Je veux dire par là qu'un visiteur non logué ne peut voir tes photos 😉

 

Lien à poster
Partager sur d’autres sites
il y a 16 minutes, Thierry94 a dit :

Du coup ton photo station fonctionne bien depuis l'exterieur !

En http uniquement..... pas en https.... c'est moins sécurisé, c'est pas le but.

Et quand je suis sur le DSM, si je clique sur l'icone de Photo Station, ca ne marche pas....car il part en :5001

Et pareil sur mon Iphone, j'enlève l'option https

Modifié par Marjomax
Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Zeus a dit :

Il te faudra passer par SSH je crois.

Oulaaaaaa hors mes petites compétences.....

 

Par contre j'ai désactivé ca ! Je sais pas si c'est bon en fait.... moi j'ai mon nom de domaine chez Gandi, et il n'y est pas dans le menu déroulant...

Capture.JPG.4a02abd48438d9c624a59d76c5cdc08f.JPG

Lien à poster
Partager sur d’autres sites

@Marjomax il faut regarder dans les paramètres de Photo Station.
Pour ça il faut te connecter à Photo Station avec un compte administrateur et aller dans "paramètres", "Général".
Tu y trouveras la redirection http vers https (mais je crois qu'il ne faut pas l'activer avec le reverse proxy qui fait du https vers du http)

La redirection http vers https dans DSM est faite pour les applis autres que web station et Photo Station

Modifié par Thierry94
Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Thierry94 a dit :

@Zeus Il existe un paramètre de redirection automatique qui est géré dans les réglages de Photo Station mais il est inutile puisqu'il ne laisse passer que les connexion HTTPS sur sa box

Option qu'il ne faut pas cocher. Voir tuto de Fenrir sur la sécurité...

à l’instant, Marjomax a dit :

Oulaaaaaa hors mes petites compétences....

Par contre j'ai désactivé ca ! Je sais pas si c'est bon en fait.... moi j'ai mon nom de domaine chez Gandi, et il n'y est pas dans le menu déroulant...

Pas de rapport avec ton soucis normalement.

Lien à poster
Partager sur d’autres sites

Effectivement le routage était mal fait.

Il faut éviter d'exposer DSM directement sur internet donc pas de routage 5000 ni de 5001 du Wan vers le Lan. Pour accéder au DSM depuis l'extérieur il est plus sécurisant de le faire via VPN Serveur.

Je ne comprend pas bien le 2eme routage de ta box Wan 5000 -> 5001, LAN 5000 -> 5001 … cela veut dire que tu as 2 routage 5000 vers 5000 et 5001 vers 5001 ? (edit : c'est une redirection automatique !)
 

Je viens de tester tu as bien accès au DSM en https 

Modifié par Thierry94
Lien à poster
Partager sur d’autres sites

C'est pourtant évident : avec cette adresse, vous passiez par le port 443 que votre routeur redirigeait vers le 5001, donc DSM.

Maintenant que votre 443 va vers le 443, il est normal de ne plus atteindre DSM.

La deuxième ligne de votre routeur n'est pas très claire et je suis d'accord avec Thierry94 sur l'accès à DSM de l'extérieur. Si toutefois vous souhaitez le faire de manière traditionnelle (sans VPN), je vous conseille vivement de supprimer l'accès par le 5000 (port HTTP)

Lien à poster
Partager sur d’autres sites

@Majormax C'est parce que ton entreprise n'accepte pas les sortie sur le port 5001 …
La plupart des entreprises font de même et ne laissent sortir que les requêtes sur les ports 80 et 443.

Moi je suis chez moi donc pas de blocage pour sortir 😉

Tu pourras respecter les règles de sécurité de ton entreprise en mettant en place le reverse proxy avec https://dsm.nomdedomaine.xx -> port 5000 de ton NAS (dsm. est un exemple)

Mais comme je l'ai déjà indiqué, ouvrir DSM sur Internet ce n'est pas terrible !

Modifié par Thierry94
Lien à poster
Partager sur d’autres sites
  • 3 weeks later...

Bonsoir !

Voilà j'ai suivi le tuto et pourtant ça ne fonctionne pas ... Lorsque je tape mon ip fixe j'arrive bien sur mon DSM mais lorsque je tape mon nom de domaine j'arrive à une page d'ovh qui me dit que mon nom de domaine a bien été enregistré ... J'ai surement loupé quelque chose mais j'ai lu et relu plusieurs fois et je ne vois rien ...

Si quelqu'un pouvait venir éclairer ma lanterne !

Merci par avance !

Modifié par maxmad62
Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.