This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

StephB

[RESOLU] Ajouter un "alias" pour un admin ?

Messages recommandés

Bonjour à tous,

Est-il possible d'ajouter un (ou des)  "Alias" pour un utilisateur "admin" (mais pas "root") pour l'utilisation lors des sessions en SSH ?

Je sèche sur quel est le fichier à éditer et comment l'éditer (doit-on être "root") pour q'il soit actif au prochain login de mon utilisateur "admin" ?

Auriez-vous des idées ?

Merci pour vos conseils 😀

 

Modifié par StephB

Partager ce message


Lien à poster
Partager sur d’autres sites

Je me réponds, voilà ce qu'il faut faire

Une fois la connexion en SSH établie sur son NAS :

1. Editer le bon fichier (!) :

sudo vi /etc.defaults/.bashrc_profile

2. Ajouter son "alias" ... dans mon cas présent, pour faire du WOL, donc allumer mon PC en passant par mon NAS. Connexion depuis mon téléphone, sous Android, en SSH + VPN sur mon NAS, avec https://juicessh.com (en version gratuite).

alias wol="perl /volume1/xxxxxxxx/wakeonlan.pl -i 192.xxx.xxx.xxx -p 9 xx:xx:xx:xx:xx:xx"

(mon IP et ma MAC sont bien entendu fictives) 😉

3. pour relancer le "profile" et ainsi avoir les changements visibles, faire

source /etc.defaults/.bashrc_profile

4. le fichier "wakeonlan.pl" est trouvable ici https://plone.unige.ch/EULER/t4-euler-telescope/administration-systeme/configuration-du-synology-cluster/installtion-du-nas/source-perl-de-wake-on-lan/view

Une fois connecté, je tape juste "wol" et le paquet magique est bien envoyé et mon PC allumé, cela fonctionne parfaitement !😁

Modifié par StephB

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement