This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

SirOch

[DS415+] Probleme reverse proxy

Messages recommandés

Bonjour,

Bonjour,

J'ai un problème de proxy qui semble etre apparu depuis la mise a jour DSM 6.2.2-24922 Update 4 étant donné que c'est la seule chose qui a changée.
Je vous expose mon soucis.
J'utilise le reverse proxy pour accéder a mes sites web sur le NAS mais aussi pour me connecter sur ma box depuis internet.
Pour cela j'ai une règle qui redirige un nom de domaine vers l'ip de ma box., et cela fonctionnait très bien.
Cependant depuis la MAJ 6.2.2-24922 Update 4 quand je me connecte je n'arrive plus sur ma box mais sur la page suivante: 

 image.png.604ead80ec61d482969ebfad793d6f12.png

Je n'arrive pas a trouver d'où vient le problème, c'est comme si NAS n'arrivait pas a renvoyer le flux vers ma box.

 Je preneur de toutes les idées pour résoudre le problème.

David

 

Modifié par SirOch

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour shadowking,

Non je n'utilise pas de serveur DNS local.

Le problème est clairement apparu avec l'update 4 car ça fonctionnait avant.

la configuration est simple: 

image.png.d62ba18e4116309c4a508f83905c2a16.png

J'ai fait des tests en faisant pointer sur une autre page web et même résultat.

Par contre les redirection vers les serveurs locaux du NAS fonctionnent sans problème.

 

J'ai l'impression que c'est lié a ce correctif Fixed multiple security vulnerabilities regarding Nginx (Synology-SA-19:33).

Est ce qu'il est possible de revenir en arriere a la version Update 3 ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne pense pas que ce soit réellement lié à l'update, beaucoup de monde ici l'a faite, tout autant utilise le proxy inversé de Synology, et personne n'est venu se plaindre d'un quelconque problème à ma connaissance.
Donc c'est soit l'implémentation de ton proxy inversé, soit un problème autre qui doit être la cause de tes ennuis.
Et il se peut que la mise à jour ait mis en lumière un défaut dans ta configuration.

Quand tu dis les redirections vers les serveurs locaux du NAS, tu veux dire que depuis l'extérieur, les entrées du proxy inversé qui pointent sur le NAS fonctionnent, mais pas sur ta box ?
Si c'est le cas, assure-toi que ta box a toujours la même IP locale.

Tu peux également te connecter en ssh et vérifier l'IP renvoyée par la commande nslookup sur ton nom de domaine.

nslookup domain.example

et notamment sur le CNAME pointant vers ta box.

Modifié par shadowking

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour shadowking,

Merci pour ton retour.

J'ai tout vérifié et les DNS sont bons sur le syno.

J'ai refait des tests en utilisant un autre serveur web externe au syno et ça fonctionne (alors que ça ne fonctionnait vendredi).

j'ai réussi a trouver les logs d'erreurs du nginx sur le syno et il y a ça:

2019/12/01 22:13:27 [error] 31998#31998: *12195 upstream prematurely closed connection while reading response header from upstream, client: @IP_PUBLIQUE, server: PUBLIC_NAME, request: "GET /index.html HTTP/1.1", upstream: "http://@IP_LOCALE:80/index.html", host: "PUBLIC_NAME", referrer: "http://PUBLIC_NAME/"

Est ce que tu serais où se trouve le fichier de conf nginx reverse proxy par hasard ?


 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, SirOch a dit :

Est ce que tu serais où se trouve le fichier de conf nginx reverse proxy par hasard ?

 

Dans /etc/nginx/nginx.conf

Attention cependant que le fichier est écrasé à chaque réinitialisation de nginx.
Si tu comptes modifier le fichier, tu peux t'inspirer de l'ancien tutoriel sur la mise en place d'un reverse proxy (avant que Synology n'inclut la fonctionnalité dans le portail des applications).

 

Partager ce message


Lien à poster
Partager sur d’autres sites

salut shadowking,

 

J'avais déjà monté le HA proxy avant DSM 6 😉

Sinon j'ai trouvé l'emplacement de la conf des backend et c'est dans /var/tmp/nginx/

j'ai essayer de faire une modif sur les timeouts mais sans succès., donc je comprends pas.

Je vais me pencher sur la box car je ne vois plus que ça comme cause du problème.

Je vous tiens au courant.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai déjà rencontré un problème qui ressemble au tien. Mon reverse proxy est porté par mon DS413 et le problème (avec la même page "Synology - Désolé ...") apparait parfois quand je me connecte par le reverse proxy à mon DS411J de l’extérieur de mon réseau.

Je pense que ça peut être lié à un timeout du fait de la faible puissance du proc du DS411J. En fait, quand ça se produit et que j'obtiens la page "Synology - Désolé ..." je fais une actualisation de la page (j'utilise firefox) et la plupart du temps, ça décoince, sinon je recommence et j'arrive à me connecter au bout de quelques fois.

Est-ce la même chose pour toi?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut dd5992

Dans mon cas, ça ne le fait que sur 1 redirection car cela fonctionne vers une autre.

J'avais ouvert un ticket chez Synology et ils ont pas réussi a reproduire le problème.

Donc c'est peut être lié a ma box je ne sais pas.

Sinon côté puissance j'ai un DS415+ et je n'ai jamais eu de soucis 

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement