This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Aerrow

RAID SHR - VOLUME PLANTE !

Messages recommandés

 Bonjour à tous !

Je poste ma contribution pour ceux qui auraient eu les mêmes problèmes que moi :

Situation : Suite à une coupure de courant, le volume de mon NAS était planté. Le RAID --> OK, Les Disques Durs --> OK
Je me retrouve donc avec un NAS fonctionnel, mais avec un volume planté sans d'autre symptômes.... 
😪 

Je décide donc de chercher une solution car je suis sûr que mon volume doit toujours exister qqpart et mes données aussi ! (un peu plus de 3To ... une grande partie de ma vie numérique !)

La solution qui a fonctionné pour moi ne nécessite pas d'enlever les disques du NAS, tout se fait via la console SSH du NAS SYNOLOGY.
Et les commandes sont relativement simples. J'espère que que ça marchera pour ceux qui sont dans le même cas que moi c'est à dire "Volume Planté" sans d'autres soucis de RAID ou de Disque Durs

1 - Accès au NAS en SSH via Putty

image.png.26d34674a402ad2e5526b4eccc70d1e4.png

On met l'@Ip du NAS, on clique sur open et une fenêtre s'ouvre.
Si vous ne l'avez jamais fait auparavant il faut accepter le certificat.

Si ça ne fonctionne pas ,vérifiez d'avoir activer le SSH dans Synology :

image.png.e84f08abe8a9dd362417c79cc14c76cb.png

login : admin et password = "celui que vous avez mis dans votre installation"
Vous vous retrouvez avec ce prompt :
admin@NAS:/$

2 - Passer en root :

admin@NAS:/$ sudo -i
Password : "le même que admin"
root@NAS:/#
 

3 - Check des  "Physical Volume", "Virtual Volume" et "Logical Volume" :

Ci-dessous les différents PV de mon NAS en RAID SHR
(partitions en /dev/mdx correspond à un raid) 

image.png.9a7a04f8a3f034a9f03b1406a10ccd51.png
 

Et ci-dessous LE VOLUME_1 celui qui est l'objet de toutes mes attentions !

image.png.1f74606b707b9ea2bfc1231fdfc828d1.png

=> mon volume existe bien... 😲 

Ci-dessous les différents LV de mon Volume1 (vg1) en RAID SHR
Celui qui m'intéresse plus particulièrement est /dev/vg1/volume_1 qui contient mes données !

image.png.3f6811e6517a88aba4b3f6b7b10811fe.png

 

4 - Check des partitions montées:

image.png.221d67d9dffd16b323af53de1677376d.png

ici la partition de mon volume1 qui s'appelle /dev/vg1/volume_1 n'est pas montée, et lorsque j'essaie de la monter j'obtiens une erreur :

root@NAS:/#  mount /dev/vg1/volume_1 volume1/
mount: wrong fs type, bad option, bad superblock on /dev/vg1/volume_1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

 

root@NAS:/# dmesg  #lecture des logs voir ce que ça raconte un peu...
[...]
[10326.262985] EXT4-fs (dm-1): barriers disabled
[10326.692626] JBD2: journal transaction 8136159 on dm-1-8 is corrupt.
[10326.699377] EXT4-fs (dm-1): error loading journal

Après avoir fait quelques recherches, des erreurs existent sur le système de fichier de mon volume,
il convient d'essayer de le réparer...

 

5 - J'ai trouver cette commande qui a sauvée mon volume : 
root@NAS:/# fsck.ext4 -f /dev/vg1/volume_1
e2fsck 1.42.6 (21-Sep-2012)
1.42.6-5644: recovering journal
Journal transaction 8136159 was corrupt, replay was aborted.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong (583993748, counted=583994298). #erreurs trouvées sur le système de fichier, propose de réparer...#
Fix<y>? yes #je dis ''yes '' bien évidemment !#
Free inodes count wrong (303818467, counted=303818628).
Fix<y>? yes #je dis ''yes '' bien évidemment !#
1.42.6-5644: ***** FILE SYSTEM WAS MODIFIED *****
1.42.6-5644: 202876/304021504 files (1.1% non-contiguous), 632091718/1216086016 blocks
 

6 - Vérification finie, j'essaie de monter mon volume...
root@NAS:/# mount /dev/vg1/volume_1 volume1/
 => et là magie !! mon volume se monte et je peux accéder à ce dernier via les lecteurs réseaux que j'avais sous windows 
😁 

=> pour le moment les partages sont invisibles sous le FileStation depuis l'interface Web de Synology, je décide donc de tout sauvegarder avant de redémarrer le NAS pour voir s'il reboot avec toutes les applications et partages correctement actif...)

 

image.png.43367ccdf7f93465888046998f8f7209.png

Ci-dessus mon volume apparaît bien dans la table de montage... 
/dev/mapper/vg1-volume_1 est une redirection de /dev/vg1/volume_1 (en gros c'est la même chose, mais nous utilisons la deuxième écriture pour nos commandes...)

Maintenant j'attends deux heures le temps de copier toutes les données de mon NAS que je souhaite ABSOLUMENT conserver avant de tenter un reboot !

 

  edit : ... deux heures plus tard ...

je lance le redémarrage de mon NAS ....

...

...

Tout fonctionne de façon nominal !

(OpenVPN, PLEX, PARTAGE SMB, DOWNLOAD MANAGER, ANTIVIRUS...)

/!\ Ne pas réinstaller d'application avant le reboot (genre plex) sinon la conf des bibliothèque sera vierge et il faudra bidouiller pour la retrouver !

 

 

 

Voilà j'espère ne pas vous avoir perdu dans mes explications et que ça vous aidera à résoudre vos soucis !

#--|Aerrow|--#
 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, maxou56 a dit :

Bonjour, @Aerrow

Un onduleur t'aurais permis d'évité d'avoir des sueurs froides 😅. Ainsi qu'une sauvegarde.

Tous ce termine bien 😀.

Merci pour ce conseil ! en fait c'était plus pour partager mon retour ! 🤪

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour le retour, mais inutile de le répéter sur tous les sujets de volume planté du forum. Je déplace dans la section tutoriels et je supprime dans les sujets concernés.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement