This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Jeff777

Docker bloqué sur "arrêt en cours"

Messages recommandés

Bonjour à tous,

J'ai installé Docker puis bitwarden mais cela a créé des soucis de réseau lors d'une sauvegarde effectuée par Active Backup for Business qui tournait normalement jusque là.

Les leds de NAS se sont mises à clignoter et j'ai perdu internet sur tous les PC du réseau. J'ai pu rétablir la situation après avoir changé de DNS (je suis sur DNS serveur) puis repris ma config initiale mais le problème s'est reproduit. 

J'ai arrêté Docker (en fait j'ai cru l'arrêter) puis repris à zéro l'installation d'ABB. Toutes les sauvegardes initiales ont été refaites, je voudrais maintenant redémarrer Docker mais je m'aperçois qu'il est en cours d'arrêt et cela depuis sans doute plus de 24h.

Je n'ai plus accès aux onglets de docker et dans le centre des paquets je ne peux ni le désinstaller ni le lancer, il est en cours d'arrêt. Un redémarrage du NAS ne change rien.

Je suppose que je peux maîtriser la situation en SSH mais avec quelle commande ?

Autre question lors de l'installation de docker que faut-il privilégier dans l'onglet réseau ? J'ai mis celui du DSM mais mon soucis ne vient-il pas de là??

Merci à vous

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Oulalala, beaucoup d'informations... On va décortiquer tout ça :

Citation

Les leds de NAS se sont mises à clignoter et j'ai perdu internet sur tous les PC du réseau. J'ai pu rétablir la situation après avoir changé de DNS (je suis sur DNS serveur) puis repris ma config initiale mais le problème s'est reproduit. 

Ton NAS n'est pas ton modem ou ton routeur. J'ai du mal à voir pourquoi tes PC perdraient internet.

Pour ton histoire de DNS, il te suffit de mettre le NAS en premier DNS et d'en mettre un second comme le DNS de FDN par exemple. Si le premier tombe, alors c'est le second qui prend le relais.

C'est d'ailleurs dans le tuto de Fenir si je me trompe pas.

Citation

J'ai arrêté Docker (en fait j'ai cru l'arrêter) puis repris à zéro l'installation d'ABB. Toutes les sauvegardes initiales ont été refaites, je voudrais maintenant redémarrer Docker mais je m'aperçois qu'il est en cours d'arrêt et cela depuis sans doute plus de 24h.

Je n'ai plus accès aux onglets de docker et dans le centre des paquets je ne peux ni le désinstaller ni le lancer, il est en cours d'arrêt. Un redémarrage du NAS ne change rien.

Je suppose que je peux maîtriser la situation en SSH mais avec quelle commande ?

Tu peux éventuellement essayer un

killall docker

Sinon, tu fais htop pour voir tous les processus et tu fais F9 sur celui de Docker pour le tuer.

Je viens de voir ça en ssh :

LKZoYHP.png

Citation

Autre question lors de l'installation de docker que faut-il privilégier dans l'onglet réseau ? J'ai mis celui du DSM mais mon soucis ne vient-il pas de là??

J'ai pas compris. Tu parles de quelle installation ? Docker s'installe en mode silencieux comme n'importe quel paquet Synology. Non ?!

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ton aide,

il y a 48 minutes, Zeus a dit :

Ton NAS n'est pas ton modem ou ton routeur. J'ai du mal à voir pourquoi tes PC perdraient internet.

Non bien sûr mais c'était mon DNS et comme il était occupé je suppose qu'il ne répondait plus au requêtes. Autre chose que je n'ai pas dit j'ai eu beaucoup de mal après avoir pris un DNS FDN a récupérer le réseau, mon IP avait changé en une adresse APIPA 169 254 XXX XXX. 

il y a 48 minutes, Zeus a dit :

Pour ton histoire de DNS, il te suffit de mettre le NAS en premier DNS et d'en mettre un second comme le DNS de FDN par exemple. Si le premier tombe, alors c'est le second qui prend le relais.

Oui c'est ce que je ferai maintenant.

La raison pour laquelle je n'avais qu'un seul DNS celui de mon NAS est là :https://www.nas-forum.com/forum/topic/59573-nas-connecté-à-la-box-ou-directement-au-pc/

Bon je vais essayer ce que tu m'as indiqué et te tiens au courant.

Concernant l'onglet réseau, je ne me souviens plus mais il me semblait qu'il y avait plusieurs options, ce n'était peut-être pas demandé pendant l'installation. Qu'est-ce qu'il faut mettre ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Citation

j'ai eu beaucoup de mal après avoir pris un DNS FDN a récupérer le réseau, mon IP avait changé en une adresse APIPA 169 254 XXX XXX. 

Il faut que tu sois un peu plus clair dans tes écrits stp.

Tu parles de quelle adresse IP ?! Celle du NAS, du routeur, de ton adresse IP publique ?

Citation

Concernant l'onglet réseau, je ne me souviens plus mais il me semblait qu'il y avait plusieurs options, ce n'était peut-être pas demandé pendant l'installation. Qu'est-ce qu'il faut mettre ?

Encore une fois, je ne vois pas de quoi tu parles. Ça fait bien longtemps que je n'ai pas eu à installer Docker donc je ne sais plus comment il se comporte lors de son installation mais je me souviens pas d'une quelconque demande de configuration sur le réseau.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, Zeus a dit :

Tu parles de quelle adresse IP ?! Celle du NAS, du routeur, de ton adresse IP publique ?

De mon adresse IP publique

Pour l'onglet réseau, je ne me souviens plus si c'était demandé pendant l'installation mais c'est là :

Capture.JPG.ddc2410175146cc31d48b31e60a3517a.JPG

Je vais réinstaller docker et je te dis plus précisément.

Partager ce message


Lien à poster
Partager sur d’autres sites
Citation

De mon adresse IP publique

J'ai du mal à comprendre.

Je viens de faire des recherches et une adresse APIPA 169 254 XXX XXX  est lié à un réseau privé et non une adresse publique.

Si ça peut t'aider pour Docker, voici ma config réseau :

EdSgbC2.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Il n'a pas été nécessaire de réinstaller docker. Avec ta première méthode il s'est enfin arrêté et je l'ai relancé.

Je reste comme cela un moment pour voir si tout fonctionne bien.

 

Concernant l'onglet réseau j'ai compris une chose :

Pour installer Bitwarden j'ai suivi le Tuto de Balooforever/Zeus qui suppose l'installation préalable de Docker.

Et effectivement, pendant l'installation de Docker, je ne crois pas avoir été questionné sur le type de réseau et par défaut j'ai les 9 containers dans docker_default :

Capture.JPG.0a319a910dbc966a754fba30bd1b44fb.JPG

 

Mais j'ai oublié de dire (encore une fois 🤢) que juste avant mon problème de réseau j'avais installé Plex selon le tuto de Einsteinium. Et pour l'onglet réseau il y est dit :

"Ici vous n’avez qu’une case à cocher : « Utiliser le même réseau que Docker Host », les onglets « Paramètres des ports » et « Liens » seront donc ignorés, Plex se lance en host, sinon cela cause pas mal de soucis... (réclame du serveur, tunneling, etc...)"

Donc j'ai mis la troisième option.

Après mon soucis de réseau j'ai désinstallé PLEX puis essayé d'arrêter Docker.

Je ne comprends pas trop ces trois options et c'est peut-être la cause de mon souci.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Avec le détail :

Capture.JPG.5c24cc20ae795c041a1fbd0c27b5db92.JPG

Je n'avais pas vu ta réponse mais cela a l'air semblable pour Bitwarden et confirme que l'on peut avoir des containers connectés à d'autres réseaux.

Décidément je ne comprends pas ce que cela signifie.

Je vais tenter un peu plus tard de réinstaller PLEX.

Merci et bonne soirée

Partager ce message


Lien à poster
Partager sur d’autres sites
Citation

Pour installer Bitwarden j'ai suivi le Tuto de Balooforever/Zeus qui suppose l'installation préalable de Docker.

En effet, pour installer Bitwarden, il faut Docker 😂

Passe en Emby 🤣

Au moins il y a pas de soucis de réseau et ton serveur est 100% à toi.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu sais quoi, j'essaie de faire un tuto pour ce soir maximum 🙂

Ça sera plus simple car ça arrive de temps en temps qu'on me le demande ici ou ailleurs.

Au moins, je n'aurai plus à l'expliquer mais juste à indiquer le lien du tuto 😂

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement