This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

[Résolu] NAS pour serveur DNS et DHCP


Messages recommandés

Bonjour à toutes et à tous,

 

D'habitude je me débrouille très bien pour la configuration du NAS mais là mais en ayant épluché ce forum et ses tutos (surtout celui-ci) je sèche complètement. 

J'ai un nom de domaine (ndd.fr) et plusieurs sous domaine: 

  • ndd.fr que je n'utilise pas
  • nas.ndd.fr qui renvoi sur le DSM
  • home.ndd.fr qui renvoi sur l'interface d'Home Assistant, une solution de domotique

Ces ndd et sous domaines pointent sur l'IP de ma Livebox, sur laquelle j'ai une redirection de ports (80 et 443) vers mon NAS, qui, avec un reverse proxy, me renvois sur mes équipements locaux.

Jusqu'à maintenant, en local comme depuis l'extérieur j'avais accès à mes équipements via nas.ndd.fr ou home.ndd.fr

Depuis qu'Orange à supprimé le loopback sur la Livebox, j'ai décidé de tout gérer via le NAS pour ne plus dépendre de ces MAJ foireuses. 

J'ai donc configuré le NAS pour qu'il fasse serveur DHCP: OK, mes équipements locaux récupèrent bien l'IP du NAS comme serveur DHCP et se voient une IP attribuée.

Reste ensuite à configurer le serveur DNS. J'ai avancé jusqu'au point ou, depuis un équipement local, j'ai ceci: 

Citation

 

nslookup home.ndd.fr
Serveur :   UnKnown
Address:  [IP du NAS]

Réponse ne faisant pas autorité :
Nom :    home.ndd.fr
Address:  [IP publique]

 

Mais en local ça ne fonctionne toujours pas (NET::ERR_CERT_AUTHORITY_INVALID avec certificat émis par Orange...etc). 

J'ai créé une zone master ndd.fr avec les enregistrements suivants:

Citation

 

ndd.fr NS ns.ndd.fr

ns.ndd.fr A [IP du NAS]

nas.ndd.fr CNAME ns.ndd.fr.

home.ndd.fr A [IP Domotique]

 

Dans la configuration générale > réseau du NAS j'ai bien l'IP du NAS comme serveur DNS

J'ai créée une vue LAN avec une limite d'IP source, la zone master ndd.fr cochée et sans redirecteur. 

 

J'ai vraiment aucune idée de ou se situe le problème. Si quelqu'un peut me filer un coup de main... 🙂

Merci !

 

Benjamin

Modifié par Profil404
Lien à poster
Partager sur d’autres sites

@Profil404

Bonjour,

  1. Comme sur tout forum, il est d'usage que les nouveaux membres passent par la rubrique [PRESENTATION] pour faire la leur. Certains ici, y sont sensibles et de plus cela facilite les réponses en fonction du niveau de compétences du membre et de ses équipements. Cela dit rassures-toi il n'est pas trop tard pour bien faire ...

  2. Je te propose ces quelques manipulations, si tu le veux bien :


    Box : DHCP actif : Attribuer un bail statique au NAS.


    NAT/PAT : Rediriger les ports 80, 443 et 5000 vers les respectivement les mêmes ports sur le NAS.


    Si une DMZ est définie, supprimer tout dans la DMZ.


    Pour la suite, on suppose de @IP de la Box est 192.168.1.1
    Rebooter la Box.

    Sur le PC :


    Dans une fenêtre de CMD en mode admin taper "ipconfig /flushdns" pour vider le cache.


    Dans l'adaptateur réseau (propriétés protocole IPv4) : en DNS préféré --> forcer le DNS Serveur sur l'@IP du NAS, dans DNS auxiliaire --> mettre 80.67.169.12 ou 1.1.1.1, créer un 3ème DNS avec 192.168.1.1 (Livebox) pour le cas où aucun des deux serveurs DNS précédents ne répondraient pas.
    NOTA : cette configuration est à faire sur tous tes périphériques de ton réseau local (càd forcer le serveur DNS - le 1er - à utiliser sur l'@IP du NAS).

    NAS partie DSM :
    Désactiver le serveur DHCP du NAS.


    Désactiver provisoirement le pare-feu du NAS.


    Depuis l'extérieur, dans un navigateur Web avec cache vidé : taper l'URL http://<@IP Externe>:5000 --> tu dois atteindre le NAS.


  3. Tu as une Livebox, donc ton @IP externe est dynamique (préférentielle).
    As-tu défini un DynDNS chez ton registar sur ton ndd.tld ou sur quelque chose comme ddns.ndd.tld ? Attention selon ta réponse cela va influer sur le paramétrage ci-après, notamment pour le DNS Server.
    Ce DynDNS pointe-t-il bien vers ton @IP externe (celle de la Livebox) ? Que donne nslookup ndd.tld OU selon nslookup ddns.ndd.tld ? Si ce n'est par ton @IP externe (celle de la Livebox) ne vas pas plus loin et revérifies tout.
    Ce DynDNS est-il bien défini dans DSM : "Accès externe / DDNS" ? sur Normal
    Dans la zone DNS de ton domaine chez ton registar as-tu bien un enregistrement tel que :  "*.ndd.tld CNAME 86400 ndd.tld. " (OU selon ta réponse à ma question précédente  " *.ddns.ndd.tld CNAME 86400 ddns.ndd.tld. " ?

    On vérifie que ton DDNS pointe bien chez toi, en passant la commande "ping ndd.tld" OU selon "ping ddns.ndd.tld" depuis ton PC . La réponse doit être ton @IP Externe. Depuis l'extérieur, dans un navigateur Web : taper l'URL http://ddns.ndd.tld:5000 --> tu dois atteindre le NAS.

     
  4. Si tout est OK alors tu peux réactiver le pare-feu du NAS et au passage ouvrir/autoriser les ports 80, 443, 5000 et 5001 dans le pare-feu du NAS. Pour les ports 5000 et 5001 je suppose qu'ils n'ont pas été modifiés dans Accès externe/Avancé et ton nom d'hôte est bien "ndd.tld" OU selon "ddns.ndd.tld".
    Tu peux aussi supprimer la redirection du port 5000 dans le NAT/PAT de la Box (ce n'est plus utile !).
     
  5. Réseau/général :

    • Vérifier que la passerelle par défaut est bien l’@IP locale de la Box 192.168.1.1 (LAN1)

    • Cocher configurer manuellement le serveur DNS préféré et saisir l'@IP du NAS, pour le serveur DNS de remplacement tu peux mettre 80.67.169.12 ou 1.1.1.1. Dans "Paramètres avancés" tu coches les 3 cases.

  6. Réseau/Interface réseau : pour LAN1 configurer avec DHCP automatique. Mais si tu mets en configuration manuelle, alors : @IPlocaleNAS, passerelle=@IPlocaleBox, Serveur DNS= @IPlocaleNAS, cocher Définir comme valeur par défaut.

  7. Réseau/Paramètres de DSM : Décocher "Rediriger automatiquement les connexions HTTP vers HTTPS sur le bureau DSM" sinon cela casse le processus de reverse proxy.



  8. Dans ton DNS Serveur :
    1. les ressources devraient être a minima telles que (pareil à adapter selon ta réponse précédente avec ddns.ndd.tld à la place de ndd.tld dans les lignes suivantes) :
      ns.ndd.tld A 86400 @IPduNAS
      ndd.tld NS 86400 ns.ndd.tld
      nas.ndd.tld A 86400 @IPduNAS ---> pour accéder directement au NAS (DSM)
      *.ndd.tld CNAME 86400 nas.ndd.tld ---> pour accéder directement aux applications du NAS
      home.ndd.tld  86400 @IP_Domotique
    2. les redirecteurs devraient être : par exemple FND et Cloudfare (80.67.169.12 et 1.1.1.1)
    3. Pour la zone master et la vue associée limiter les IP sources tel que :
      image.png.ea7d14d788c9880e488d5ab982d2cc44.png
      avec éventuellement le sous-réseau 10.0.0.0/255.0.0.0 si tu comptes faire du VPN.
       

Voilà il y a pas mal de manipulations mais je pense que tu pourras les suivre sans problèmes.

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites

Salut @oracle7 et merci pour ta réponse !

1. C'est fait 😉 Etant moi même admin d'un forum je ne sais pour quelle raison j'ai zapper ce "rituel"...

2. "Depuis l'extérieur, dans un navigateur Web avec cache vidé : taper l'URL http://<@IP Externe>:5000 --> tu dois atteindre le NAS." Oui

3. J'utilise le service Dynamic DNS avec mon nom de domaine enregistré chez Ionos. La commande nslookup me retourne bien mon IP publique (voir mon 1er message).Dans accès externe > général je n'ai pas de configuration DDNS (pas utile). 

4. Les ports 5000 et 5001 ont été personnalisé par sécurité dès l'installation du NAS. C'est OK pour accès externe > avancé. 

5. La passerelle est bonne. Les serveurs DNS également.

6. Serveur DHCP correctement configuré et fonctionnel (si je fais un ipconfig /all c'est bien le NAS qui gère l'attribution d'une IP). 

7. La redirection HTTP vers HTTPS est cochés et reverse proxy fonctionne très bien, je ne l'ai pas décoché, je tiens à conserver ce paramètre actif. Dans sécurité > certificat j'ai bien mon certificat SSL activé pour ndd.fr et tous mes autres sous domaine. 

8. Déjà essayer (je l'avais lu quelque part) et ça ne fonctionne toujours pas. 

Pour résumer:

  • Accès extérieur OK via nas.ndd.fr et reverse proxy + sur la Livebox redirection des requêtes sur les ports 80, 443, 1194 et 6690 vers le NAS.
  • Le serveur DHCP du NAS fonctionne parfaitement (il est reconnu par les équipements et une IP est bien attribuée)
  • Le serveur DNS est reconnu par mes équipements 
  • un nslookup de nas.ndd.fr me renvoi bien l'IP publique de ma Livebox
  • Côté configuration de ndd.fr tout est OK chez mon registar. 

J'essai "simplement" de me passer du loopback de la box en voulait faire en sorte que depuis le réseau local, si nas.ndd.fr est demandé, alors je suis redirigé vers l'IP correspondante. Idem pour home.ndd.fr, qui devrait redirigé sur une autre IP locale. Ca à l'air si simple, quelque chose m'échappe 🤔

Benjamin

Lien à poster
Partager sur d’autres sites

@Profil404

Bonjour,

il y a 25 minutes, Profil404 a dit :

7. La redirection HTTP vers HTTPS est cochés et reverse proxy fonctionne très bien, je ne l'ai pas décoché, je tiens à conserver ce paramètre actif.

Justement c'est peut-être là ton erreur, je ne l'invente pas c'est clairement expliqué dans le TUTO reverse proxy. Maintenant, si tu installé le package WebStation et mis en place le fameux fichier .htacces tel que décrit dans ce TUTO alors c'est lui qui se charge de la conversion http--> https et ce sans générer de problèmes avec le reverse proxy. C'est toi qui vois ...

Je vois aussi que tu as une Livebox, comme je viens de le dire à un autre membre, si c'est une LB4, saches alors que si tu as le firmware 3.103.16 alors celui-ci est buggé suite à une récente mise à jour par Orange et qu'il bloque le NAT des port 80 et 443 ainsi que le loopback. Solution de contournement en attendant une mise à jour du firmware : installer une zone DNS locale avec le package DNS Server sur le NAS et indiquer au NAS que son serveur DNS préféré est lui même (sa propre @IPlocale).

EDIT :

il y a 25 minutes, Profil404 a dit :

Dans accès externe > général je n'ai pas de configuration DDNS (pas utile).

Si tu as une Livebox alors tu as forcément une @IP externe dynamique, donc OUI c'est utile car sinon lors que ton NAS détectera le changement d'@IP externe il ne pourra pas contacter ton DynDNS pour que celui-ci prenne en compte ta nouvelle @IP afin qu'il fasse que ton domaine pointe toujours sur la bonne @IPexterne. Après ne t'étonnes pas que tes redirections ne fonctionnent as. C'est toi encore qui vois ...

Cordialement

oracle7😉

Modifié par oracle7
Lien à poster
Partager sur d’autres sites

Salut @oracle7

Comme je l'ai dit dans mon 2nd message la partie SSL (donc HTTPS) est gérée via un certificat lié à mon nom de domaine sur le NAS. C'est pourquoi je n'ai ni besoin d'activer cette option, ni besoin d'avoir le paquet webstation 🙂  Et le reverse proxy fonctionnait parfaitement, en interne ou en externe, et toujours en HTTPS. 

Au sujet de la LB4 j'étais au courant (voir mon 1er message) et ce que tu dis:

Citation

installer une zone DNS locale avec le package DNS Server sur le NAS et indiquer au NAS que son serveur DNS préféré est lui même (sa propre @IPlocale).

 c'est exactement ce que j'essai de faire, mais je n'arrive pas du tout à configurer ça. Le serveur DNS est bien reconnu (si je fais un ipconfig /all sur un PC du réseau il me sort bien l'IP du NAS en serveur DHCP ET DNS). Je pense que ce sont les enregistrements que je fais mal, ou une histoire de cache DNS...

 

Pour DDNS comme je le disais dans mon 2nd message je passe par ceci: Dynamic DNS . Ce service, installé sur mon serveur de domotique, actualise mes enregistrements DNS chez mon registar directement en cas de changement d'IP publique (le service vérifie ça toutes les 5min). Je n'ai donc pas besoin de DynDNS. 

Benjamin

Modifié par Profil404
Lien à poster
Partager sur d’autres sites

@Profil404

Bonjour,

il y a 16 minutes, Profil404 a dit :

la partie SSL (donc HTTPS) est gérée via un certificat lié à mon nom de domaine sur le NAS. C'est pourquoi je n'ai ni besoin d'activer cette option, ni besoin d'avoir le paquet webstation

Désolé mais je crains que tu ne mélanges les notions. Un certificat n'a jamais fait de conversion HTTP vers HTTPS que je saches, ou alors je n'ai rien compris. Un certificat comme son nom l'indique, est "une preuve" que tu maîtrises le domaine concerné, il est en quelque sorte, l’équivalent d’une carte d’identité numérique. Il est délivré par une autorité de certification auprès de la quelle tu auras fourni une clé publique (liée à ta clé privée) qui permet d'authentifier explicitement ton domaine et donc son propriétaire, en l'occurrence toi. Cela dit, il n'est pas nécessaire d'avoir un certificat pour qu'un navigateur accède à un serveur web en https... Simplement, le navigateur te signalera qu'il ne peut pas te garantir que le serveur web qui répond à une requête passée au serveur toto.fr est bien le serveur "officiel" qui gère le domaine toto.fr. Mais ton navigateur te proposera d’accéder quand même au site, sous ta responsabilité.

Maintenant, je maintiens aussi que garder la case cochée pour la redirection HTTP vers HTTPS est une erreur de ta part.

Si tu ne veux pas de Web Station et de son fichier .htaccess pour faire les conversions HTTP vers HTTPS comme c'est préconisé dans le TUTO reverse proxy, OK pas de soucis, tu peux à la place installer un fichier simple fichier "index.php" dans le dossier WEB du NAS tel que :

<?php
// 307 Temporary Redirect
$http_host=$_SERVER['HTTP_HOST'];
switch ($http_host) {
  case "photo.ndd.fr":
         header("Location: https://$http_host/photo",TRUE,307);
         break;
  default:
         header("Location: https://$http_host:5001",TRUE,307);
  }      
exit;
?>

En plus celui que je te donne ici, corrige au passage un problème avec l'application PhotoStation ...

Une chose est sûre, c'est que sans cette conversion automatique, cela ne marchera  pas.

Voilà, je t'aurais informé, et tu restes seul maître de tes décisions ...

il y a 24 minutes, Profil404 a dit :

Dynamic DNS . Ce service, installé sur mon serveur de domotique, actualise mes enregistrements DNS chez mon registar directement en cas de changement d'IP publique (le service vérifie ça toutes les 5min). Je n'ai donc pas besoin de DynDNS. 

OK pour le serveur domotique, mais je reste septique sur comment le NAS est au courant du changement d'@IP externe. Car quand il constate le changement @IPexterne, du coup avec aucun DDNS de renseigné, il ne sait à qui s'adresser pour obtenir la bonne @IP qui est en regard du domaine enregistré dans le NAS, j'ai dû raté un truc ... si tu peux m'expliquer ....

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites

Salut @oracle7,

Pour la partie HTTP / HTTPS aucune confusion, je suis dév web 😉 Je te confirme que cette option n'a jamais impacté le fonctionnement du reverse proxy (puisqu'avant la MAJ d'Orange j'avais accès sans soucis à tous mes services en local et en externe). J'ai acheté un certificat SSL pour me permettre d'accéder à mes services en HTTPS. Ce certificat, configuré pour mon nom de domaine, je l'ai installé sur le NAS, pour mon nom de domaine et tous les sous-domaines: 

image.png.d400366d32f9f0bec0f0b6f6184f7e06.png

Ainsi, même en ayant l'option redirection des connexions HTTP vers HTTPS cochée, tout fonctionne, puisque le certificat HTTPS est installé directement au niveau du NAS. Et en faisant ça, j'évite cette situation:

Citation

Simplement, le navigateur te signalera qu'il ne peut pas te garantir que le serveur web qui répond à une requête passée au serveur toto.fr est bien le serveur "officiel" qui gère le domaine toto.fr. Mais ton navigateur te proposera d’accéder quand même au site, sous ta responsabilité.

Je n'ai pas ce message de mon navigateur, je passe direct en HTTPS, sans avertissement ni rien.

Pour la partie IP dynamique c'est très simple: Mon serveur de domotique vérifie toutes les 5 minutes quelle est mon IP publique. Si elle change il met à jour les paramètres DNS de mon domaine + mes sous domaines pour qu'ils pointent vers la nouvelle IP. 

Citation

mais je reste septique sur comment le NAS est au courant du changement d'@IP externe

A aucun moment le NAS à besoin de connaitre l'IP publique de ma Livebox. Le seul qui doit la connaitre c'est mon nom de domaine, pour savoir ou pointer lorsque je l'appelle dans un navigateur web ou autre. Du coup quand j'appelle mon nom de domaine en HTTPS, la requête arrive sur la Livebox, vu qu'il s'agit d'un trafic qui arrive sur le port 443 une règle NAT renvoi la requête sur le NAS, qui lui, avec le reverse proxy renvoi sur le bon équipement local (ET en HTTPS puisque le certificat est installé localement). 

J'espère être un peu plus clair dans mes explications, difficile de correctement tout expliquer à l'écrit sur des configurations particulières comme celle-ci 🙂 

De toute façon avant la MAJ de la Livebox TOUT fonctionnait parfaitement, en local / externe, en HTTPS, sans avertissement du navigateur...etc. Je cherche juste à bien configurer DNS Server pour l'accès local. 

Benjamin

Modifié par Profil404
Lien à poster
Partager sur d’autres sites

une zone ndd.fr:

ndd.fr NS ns.ndd.fr

ns.ndd.fr A IP_du_NAS

nas.ndd.fr A IP_du_NAS

home.ndd.fr A IP_Domotique

image.thumb.png.30b343a3f2beb81a51205f78e71b73f6.png

pour essayer

 

ou alors tu fais deux zones :

home.ndd.fr A IP_Domotique

nas.ndd.fr  A IP_Du_Nas

 

 

 

 

Modifié par Brunchto
Lien à poster
Partager sur d’autres sites

Merci pour ta réponse, j'ai essayer les 2 méthodes, mais même en ayant vidé le cache du navigateur et le cache DNS de mon PC sur le réseau local je n'arrive pas à accéder à mes équipements, ça bloque à la délivrance du certificat SSL émis par Orange (conséquence de la désactivation du loopback).

 

Lien à poster
Partager sur d’autres sites

@Profil404

Bonjour,

  1. Sur ton PC, fais d'abord un ipconfig /flushdns pour vider le cache DNS et ensuite refais un ipconfig /all. Le résultat est-il toujours le même ?
  2. As-tu repris ta zone DNS locale comme je te l'avait suggéré au point 8 initialement et d'ailleurs comme te l'as aussi suggéré plus récemment @Brunchto ?
    Tu peux STP nous faire une copie d'écran des ressources de celle-ci ?

Cordialement

oracle7😉

Modifié par oracle7
Lien à poster
Partager sur d’autres sites
Il y a 22 heures, Profil404 a dit :

sur le réseau local je n'arrive pas à accéder à mes équipements, ça bloque à la délivrance du certificat SSL émis par Orange

Bonjour,

Ce n'est pas normal, si tu utilises bien ton serveur DNS. La livebox n'a plus rien à voir.

 

Le 09/01/2021 à 18:47, Profil404 a dit :

un nslookup de nas.ndd.fr me renvoi bien l'IP publique de ma Livebox

En local? si oui ce n'est pas normal, ça devrait être l'IP du NAS.

 

La partie Vue n'est pas nécessaire si tu souhaites utiliser ton server DNS en local (il faut juste Zone et Résolution).

Modifié par maxou56
Lien à poster
Partager sur d’autres sites

 

Trouvé ! J'utilise Adguard sur mon PC, qui propose un filtrage via ses propres DNS pour les publicités, trackers...etc. En désactivant le filtrage via DNS j'ai de nouveau accès à mon domaine et ses sous domaines gérés par le NAS en local 🙂 

Merci à tous pour votre temps, finalement le problème était tout autre et côté NAS tout était donc bien configuré. 

J'espère que ce sujet servira à d'autres !

 

il y a 17 minutes, maxou56 a dit :
Le 09/01/2021 à 18:47, Profil404 a dit :

un nslookup de nas.ndd.fr me renvoi bien l'IP publique de ma Livebox

En local? si oui ce n'est pas normal, ça devrait être l'IP du NAS.

 

C'est exactement ce qui m'a mis sur la bonne piste, désormais c'est bien l'IP du NAS

BenjaminEDIT: ça fonctionne pour l'accès au NAS via dsm.ndd.fr, pour home.ndd.fr et les autres j'ai une connexion refusée, mais ça doit être un mauvais paramétrage de ma part sur l'équipement cible ou autre... Je vais fouiller un peu 😉 

Modifié par Profil404
Lien à poster
Partager sur d’autres sites

@Profil404

Bonjour,

Indépendamment du problème de Adguard qui masquait tout, content pour toi de voir que la configuration de ta zone locale DNS (telle que préconisée initialement) fonctionne nettement mieux que le "patacaisse inital" où tu avais notamment 3 enregistrements "NS" par exemple.

Juste pour les redirecteurs de résolution, si j'étais toi, j'utiliserai ceux de FND et Cloudfare (pour pas mettre tous tes œufs dans le même panier) soit 80.67.169.12 et 1.1.1.1 qui sont bien plus respectueux de la vie privée que ne le sont ceux de google. Mais ce n'est que mon avis ...

Il y a 3 heures, Profil404 a dit :

pour home.ndd.fr et les autres j'ai une connexion refusée

Vérifies à tout hasard, ton reverse proxy à ce niveau.

Enfin, tu dis avoir acheté un certificat SSL (c'est tout à fait ton droit) pour ton domaine, mais saches que tu aurais pu en obtenir un GRATUITEMENT avec Let'sEncrypt et de surcroit illimité en domaines de second niveau grâce au wilcard "*". A toi de voir ...

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites

Salut @oracle7,

 

Oui je vais vérifier du côté du reverse proxy, car là seul les noms de domaine lié au NAS directement fonctionnent. Dès qu'il faut aller sur un autre équipement c'est refusé. 

Exact pour les DNS, ça sera mieux en effet 🙂

Pour le certificat SSL étant développeur Web j'ai un contrat avec certificat SSL illimité pour mes clients, j'en ai profité 😉

Je vais continuer les tests pour les autres équipements demain. 

Benjamin 

Lien à poster
Partager sur d’autres sites
  • 2 weeks later...

Salut !

Bon et bien je n'ai absolument rien trouvé 😞 Tout ce qui est sur le NAS fonctionne bien (DSM, Drive...etc) mais dès qu'il s'agit d'un sous domaine qui doit pointer sur un autre équipement (Serveur de domotique par exemple) là c'est connexion refusée.

Voici la configuration actuelle du proxy inversé:

image.png.0f23feeab09aef217b0bcbc891d8caee.png

image.png.1cb461959bfba2ee3ec8df1035954594.png

J'ai l'impression que le soucis vient de l'équipement cible, car depuis un PC sur le réseau local j'ai bien l'IP si je fais un nslookup du sous domaine:

image.png.0a025108b1daed26036a5ca9efdb8db0.png

Qu'en pensez vous ?

Benjamin

Lien à poster
Partager sur d’autres sites

L'enregistrement home.domain.fr doit pointer vers le NAS pour pouvoir utiliser le reverse proxy.

Pour plus de clarté, tu devrais créer un enregistrement reverseproxy.domain.fr de type A qui pointe vers l'adresse IP locale du NAS. Ainsi tu fais pointer home.domain.fr de type CNAME vers reverseproxy.domain.tld.

Ça limitera les risques d'erreur.

Lien à poster
Partager sur d’autres sites

Salut @PiwiLAbruti

Du côté de mon fournisseur de nom de domaine je te confirme que home.domain.fr pointe vers l'IP publique de ma Livebox, qui renvoi tout le trafic sur le NAS. D'ailleurs le nslookup montre bien que le cheminement est bon puisque l'IP finale donnée est bien celle de mon serveur de domotique.

home.domain.fr > Livebox > NAS et Reverse Proxy > IP locale cible

Dans les DNS actuellement j'ai un enregistrement du type home.domain.fr A IP_DOMOTIQUE (j'ai suivi ce qu'à dit @Brunchto dans son message du 13/01). J'ai essayé avec ce que tu as dis, à savoir home.domain.fr A NAS mais ça ne change rien. 

Idem pour la solution avec reverseproxy.domain.fr

 

Lien à poster
Partager sur d’autres sites

@Profil404

Bonjour,

A la vue de ta redirection, quel intérêt de faire du HTTPS sur du HTTPS via le HSTS (qui force le HTTPS et interdit donc tout HTTP) et en mettant HTTPS au lieu de HTTP en destination ? Cela me paraît contre productif. Une fois sur le réseau local, il n'y a plus besoin de chiffrage HTTPS, non ?

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites

@oracle7

Le paramétrage actuel redirige une requête HTTPS provenant de home.ndd.fr vers une IP locale, en HTTPS. Le HSTS est actif uniquement si la source n'est pas HTTPS, la requête sera alors redirigée sur du HTTPS. Ainsi si je demande http://dsm.ndd.fr j'arrive bien sur le DSM du NAS, en HTTPS. Sans ce paramètre actif il ne se passerait rien (puisque la source est HTTP). Le reste du temps, si tout est déjà en HTTPS, HSTS n'est pas actif et ne fait donc pas "du HTTPS sur du HTTPS" (heureusement !).

Et en local comme depuis l'extérieur je souhaite rester en HTTPS, hors de question d'être en HTTP à un quelconque moment 🙂 

Benjamin

Il y a 5 heures, PiwiLAbruti a dit :

L'enregistrement home.domain.fr doit pointer vers le NAS pour pouvoir utiliser le reverse proxy.

 

@PiwiLAbruti: Je suis un boulet, j'avais zappé de vider le cache DNS de mon PC....

En effet, en mettant un home.ndd.fr A IP_NAS ça fonctionne ! Il ne faut donc pas mettre l'IP de l'équipement cible, et en effet ça parait logique puisque c'est reverse proxy qui gère ça. 

Du coup:

  • Le NAS fait désormais office de serveur DHCP et DNS
  • Le certificat SSL étant installé sur le NAS tout est accessible en HTTPS
  • Tout est accessible via mon domaine et ses sous domaine, que ça soit en LAN ou depuis l'extérieur

Bref tout est parfait et la Livebox fait simplement office de source Internet désormais. Enfin indépendant des mises à jours !

Un grand merci à tous pour votre aide, et en espérant que ce sujet puisse servir à d'autres utilisateurs 🙂 

Benjamin

Lien à poster
Partager sur d’autres sites
  • Profil404 changed the title to [Résolu] NAS pour serveur DNS et DHCP

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.