This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Certificat


Menjac

Messages recommandés

Bonjour à vous tous

je possede un NAS de synology depuis un an et je vient d'acheter un nom de domaine chez OVH

J'ai ajouté à mon domaine un certificat en utilisant le "panneau de configuration>securité>certificat " et tout fonctionne bien

Lorsque je vais sur "panneau de configuration>essai externe>DDNS", mon nom de domaine est bien la mais en faisant un test de connection, je recois "echec d'authentification

J'ai un DSM920 sur DSM 6.2 il y a uen redirection de port sur mon NAS dans mes parametre d'OVH

J'apprécierais beaucoup d'avoir un peu d'aide

Jacques

 

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

  1. Comme sur tout forum, il est d'usage que les nouveaux membres passent par la rubrique [PRESENTATION] pour faire la leur. Certains ici, y sont sensibles et de plus cela facilite les réponses en fonction du niveau de compétences du membre et de ses équipements. Cela dit, rassures-toi il n'est pas trop tard pour bien faire ...

  2. il y a 26 minutes, Menjac a dit :

    Lorsque je vais sur "panneau de configuration>essai externe>DDNS", mon nom de domaine est bien la mais en faisant un test de connection, je recois "echec d'authentification

    As-tu bien défini ton DynDNS chez OVH ? Sinon je t'invite à suivre ce TUTO --> https://aradaff.com/relier-une-ip-dynamique-a-un-nom-de-domaine-fixe/.
    Surtout à l'étape 3, saisis bien une " * " pour le subdomain. Si tu saisis autre chose (par ex : "xxxxx") ton DynDNS sera en "xxxxx.tonDomaine.tld" au lieu d'être "tonDomaine.tld" tout cours, ce qui est nettement moins bien ...
    Ne pas confondre le "subdomain" saisi à l'étape 2 avec celui saisi à l'étape 3. Ce n'est pas du tout la même chose même s'ils sont nommés tous les deux "subdomain".

  3. il y a 26 minutes, Menjac a dit :

    J'ai un DSM920 sur DSM 6.2 il y a uen redirection de port sur mon NAS dans mes parametre d'OVH

    Quel(s) port(s) as-tu redirigé(s), car normalement ce n'est pas utile de faire cela chez OVH ?
    C'est plutôt sur la box que l'on redirige les ports vers le NAS pour les applications qui en ont besoin.

Cordialement

oracle7😉

Modifié par oracle7
Lien vers le commentaire
Partager sur d’autres sites

Il y a 8 heures, oracle7 a dit :

@Menjac

Bonjour,

  1. Comme sur tout forum, il est d'usage que les nouveaux membres passent par la rubrique [PRESENTATION] pour faire la leur. Certains ici, y sont sensibles et de plus cela facilite les réponses en fonction du niveau de compétences du membre et de ses équipements. Cela dit, rassures-toi il n'est pas trop tard pour bien faire ...

  2. As-tu bien défini ton DynDNS chez OVH ? Sinon je t'invite à suivre ce TUTO --> https://aradaff.com/relier-une-ip-dynamique-a-un-nom-de-domaine-fixe/.
    Surtout à l'étape 3, saisis bien une " * " pour le subdomain. Si tu saisis autre chose (par ex : "xxxxx") ton DynDNS sera en "xxxxx.tonDomaine.tld" au lieu d'être "tonDomaine.tld" tout cours, ce qui est nettement moins bien ...
    Ne pas confondre le "subdomain" saisi à l'étape 2 avec celui saisi à l'étape 3. Ce n'est pas du tout la même chose même s'ils sont nommés tous les deux "subdomain".

  3. Quel(s) port(s) as-tu redirigé(s), car normalement ce n'est pas utile de faire cela chez OVH ?
    C'est plutôt sur la box que l'on redirige les ports vers le NAS pour les applications qui en ont besoin.

Cordialement

oracle7😉

Bonoir Oracle7

Merci beaucoup pour ta réponse, je ne pensais pas en avoir une aussi rapidement

1- je viens de compléter ma présentation comme demandé

2- j'ai suivi le tuto    https://aradaff.com/relier-une-ip-dynamique-a-un-nom-de-domaine-fixe/. et fait le changement sur mon NAS (le  nom.de.domaine.extnom.d.utilisateur) ont été modifiés tel que spécifié

    J' ai aussi ajouter un * pour le subDomain

3- Une erreur de ma part, ce n'est pas une redirection de port mais bien mon addresse IP que j'ai donné 

Malheureusement. je nai pas d'amélioration. je crois qu'il est préférable d'attendre jusqu'à demain pour faire d'autres tests dû au changement de SubDomain (selon OVH)

Merci encore

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

Il y a 7 heures, Menjac a dit :

mais bien mon addresse IP que j'ai donné 

  • Si ton @IP externe est FIXE, dans la zone DNS de ton domaine chez OVH, tu dois avoir un en registrement de type "A" qui fait pointer ton domaine sur ton @IP tel que :
  • monDomaine.tld.  A 84600   11.22.33.44
  • Si ton @IP externe est dynamique alors cet enregistrement ne doit pas être présent. Le seul fait d'avoir indiquée ton @IP externe dans la définition de ton DynDNS est suffisant.

Oui, il faut attendre normalement 24h00 pour que ton domaine soit diffusé sur tous les serveurs DNS du monde mais en pratique cela souvent un peu plus vite. Tu peux vérifier en allant sur : https://www.whatsmydns.net

Juste pour ta gouverne, dans tes réponses, il n'est pas nécessaire de re citer le post précédant dans sa totalité, ce serait bien que tu ne cites que la partie à la quelle tu réponds, cela surcharge moins les posts et ils sont plus faciles à lire. Merci.

Astuce : Pour avertir un membre de ta réponse, tu tapes dans ton message "@" + les premiers caractères de son pseudo. Dans le popup qui apparaît tu cliques alors sur le pseudo recherché et il s'affiche sur fond bleu dans ton texte. Ainsi ton interlocuteur est informé/notifié de ta réponse sinon il ne voit rien sauf à rebalayer en arrière tous les messages (ce que peu de monde fait).

Cordialement

oracle7😉

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

Désolé, mais tu m'as lu en diagonale au lieu de à l'horizontale et tu as perdu de l'information en route 🤣 et du coup c'est normal que cela ne fonctionne plus, une fois les bails arrivés à échéance.

Comme je te l'ai déjà dit précédemment tu as une @IP (adresse IP) dynamique et vu que tu as créé un DynDNS, alors dans la zone DNS chez OVH tu ne dois pas avoir d'enregistrement de type "A" qui fasse pointer ton domaine sur ton @IP externe.

Or à la vue de ta copie d'écran, cet enregistrement "A" est bien présent (" tondomaine.ca.  0   A   23.233.230.240 "). Donc supprimes-le et cela ira toute de suite mieux.

A noter que dans l'état, ton domaine n'est pas visible sur Internet. Pour preuve sur ton PC dans une fenêtre de CMD Windows en mode admin, tapes " nslookup tondomaine.tld 8.8.8.8 " et tu verras que Google ne le trouve pas. Après avoir supprimer l'enregistrement "A" refais le nslookup ... et là Google le trouvera.

Au passage, par sécurité, dans tes copies d'écran masques tondomaine.tld et ton @IP. Du coup remplaces ta copie d'écran précédente.

Nota : je te conseillerai aussi de créer un enregistrement "wilcard" dans ta zone DNS OVH " *.tomdomaine.ca. 84600 CNAME tomdomaine.ca. " afin de couvrir tous tes sous-domaines existants et à venir. Cela simplifie largement la gestion et t'évitera d'avoir à créer de nombreux enregistrements de type CNAME pour ces sous-domaines. Maintenant ce que j'en dit, c'est toi qui voit ...

Cordialement

oracle7😉

 

Modifié par oracle7
Lien vers le commentaire
Partager sur d’autres sites

il y a 55 minutes, oracle7 a dit :

@Menjac

 

Or à la vue de ta copie d'écran, cet enregistrement "A" est bien présent (" tondomaine.ca.  0   A   23.233.230.240 "). Donc supprimes-le et cela ira toute de suite mieux.

 Après avoir supprimer l'enregistrement "A" refais le nslookup ... et là Google le trouvera.

 Du coup remplaces ta copie d'écran précédente.

 un enregistrement "wilcard" dans ta zone DNS OVH " *.tomdomaine.ca. 84600 CNAME tomdomaine.ca. "

@oracle7

1- J'ai supprimé l'enregistrement "A"

2- Après avoir supprimer l'enregistrement "A" j'ai refais le nslookup ... et malheureusement, ça ne marche pas

3- Comment faire pour remplacer la copie d'écran précédente?

4- J'ai ajouté un enregistrement "wilcard"

ENcore une fois, merci pour ton aide

 

il y a 55 minutes, oracle7 a dit :

 

 

il y a 7 minutes, Menjac a dit :

 

 

@oracle7

J'ai refait le "nslookup.." et ça marche. Voici ce que j'ai reçu.

Comment se fait-il que @IP est différente de la mienne?

Non-authoritative answer:
Name:    jacquesmenard.ca
Address:  213.186.33.5

PS C:\Windows\system32>

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

Il y a 2 heures, Menjac a dit :

Comment se fait-il que @IP est différente de la mienne?

Je pense qu'entre le moment où tu as défini ton DynDNS avec ton @IP de l'instant et maintenant, ton @IP a changée (normal vu qu'elle est dynamique).

Q3 : pour remplacer ta copie d'écran tu édites ton post en cliquant sur les " ... " en haut à droite et tu supprimes l'image en supprimant la vignette en bas du post.

Cordialement

oracle7😉

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

Pourrais-tu STP faire tes réponses en dehors des citations, c'est vraiment pas facile à lire. Merci.

Il y a 14 heures, Menjac a dit :

mom@IP n'a pas changé.

Il m'avait semblé pourtant lors de tes tests :

Il y a 19 heures, Menjac a dit :

Comment se fait-il que @IP est différente de la mienne?

mais ce n'est pas grave, tu as sûrement raison ...

Du coup, tout fonctionne maintenant ?

Cordialement

oracle7😉

Lien vers le commentaire
Partager sur d’autres sites

@oracle7

( **  Tu n'arrives pas à atteindre ton NAS depuis l'extérieur avec ton nom de domaine ? ** )

En partie vrai et faux

Je peux atteindre mon NAS depuis l'extérieur avec mon nom de domaine en utilisant  "HTTP"

mais je peux atteindre mon NAS en utilisant "HTTPS", car je reçois ce message d'erreur:  "votre connection a ce site n'est pas privée" même sans mon firewall

@Menjac

Lien vers le commentaire
Partager sur d’autres sites

il y a 53 minutes, Menjac a dit :

Je peux atteindre mon NAS depuis l'extérieur avec mon nom de domaine en utilisant  "HTTP"

mais je peux atteindre mon NAS en utilisant "HTTPS", car je reçois ce message d'erreur:  "votre connection a ce site n'est pas privée" même sans mon firewall

Bonsoir,

Donc ça fonctionne en HTTP et en HTTPS.

Mais pour l'HTTPS il y a un problème de certificat. Soit tu utilises l'auto signé de synology, alors le message est normal, soit tu a un let's enscrypt dans ce cas la il y a un problème de configuration. C'est juste un avertissement.

 

Par contre je ne comprend pas pourquoi tu a désactivé le pare feu, puisque l'HTTPS fonctionne, si ce n'était pas le cas il y aurait un message d'erreur.

Modifié par maxou56
Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour, suite à la remarque de @maxou56 ,vérifies que tu as bien configuré ton certificat en l'affectant aux services/applications qui l'utilisent.

A savoir dans "Sécurité > Certificat" tu sélectionnes ton certificat et tu cliques sur le bouton "Configurer" et là pour chaque service tu sélectionnes ton certificat dans le popup en regard.

Cordialement

oracle7😉

Lien vers le commentaire
Partager sur d’autres sites

@oracle7

@maxou56

@Menjac

Désolé, j'ai fait une petite erreur de frappe.

mais je ne peux pas atteindre mon NAS en utilisant "HTTPS", car je reçois ce message d'erreur:  "votre connection a ce site n'est pas privée"

 

(   A savoir dans "Sécurité > Certificat" tu sélectionnes ton certificat et tu cliques sur le bouton "Configurer" et là pour chaque service tu sélectionnes ton certificat dans le popup en regard  )

Les services sont déjà configurés pour ce certificat

Je ne comprend vraiment âs ce qui se passe ....

@Menjac

Lien vers le commentaire
Partager sur d’autres sites

il y a 19 minutes, Menjac a dit :

mais je ne peux pas atteindre mon NAS en utilisant "HTTPS", car je reçois ce message d'erreur:  "votre connection a ce site n'est pas privée"

Oui j’avais compris, c’est juste un avertissement concernant le certificat (auto signé, ou ne correspond pas au nom de domaine, ou si tu accèdes via l’IP…), mais tu accèdes bien en HTTPS (le port est ouvert, et la connexion est chiffré) sinon tu aurais une erreur (page not found, erreur 404…).

Avec safari ou Firefox on peut forcer, et passer outre cette avertissement. Mais ça ne résout pas le problème.

Modifié par maxou56
Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

Donc comme promis je te propose de suivre cette procédure afin de configurer correctement ton accès externe au NAS :

Dans tout ce qui suit "ndd.tld" correspond à ton domaine "j......d.ca".

Citation

Sur le PC :

  • Dans une fenêtre de CMD en mode admin taper "ipconfig /flushdns" pour vider le cache.

NAS partie DSM :

  • Désactiver le serveur DHCP du NAS.

  • Désactiver provisoirement le pare-feu du NAS.

  • Entrer dans le champ "nom d'hôte" dans DSM "Accès externe / Avancé" ton domaine "monhote.ndd.tld". ("monhote" peut être le nom de ton NAS).

  • Depuis l'extérieur, dans un navigateur Web avec cache vidé : taper l'URL " http://<@IP Externe>:5000 " --> tu dois atteindre le NAS.

  • Accès externe :

    • On est bien d'accord que ton DDNS est défini sur ce domaine : " ndd.tld " et qu'il pointe bien vers ton @IP Externe (i.e. @IP Box). Je pars sur cette hypothèse pour la suite.

    • On vérifie que ton DDNS pointe bien chez toi, en passant la commande " ping ndd.tld " depuis ton PC . La réponse doit être ton @IP Externe.

    • On vérifie aussi dans un terminal SSH via PuTTY ou WinSCP, sous user root que " nslookup monhote.ndd.tld 8.8.8.8 ", ça doit aussi te faire tomber sur ton @IP Externe.

    • Depuis l'extérieur (tél 4G par ex), dans un navigateur Web : taper l'URL " http://ndd.tld:5000 " --> tu dois atteindre le NAS.

  • Si tout est OK alors tu peux réactiver le pare-feu du NAS et au passage ouvrir/autoriser les ports 80, 443, 5000 et 5001 dans le pare-feu du NAS. Pour les ports 5000 et 5001 je suppose qu'ils n'ont pas été modifiés dans "Accès externe/Avancé" et ton nom d'hôte est bien " monhote.ndd.tld ".
    Tu peux aussi supprimer la redirection du port 5000 dans le NAT/PAT de la Box (ce n'est plus utile ! c'était juste pour les tests).

  • "Réseau/général" :

    • Vérifier que la passerelle par défaut est bien l’@IP locale de la Box 192.168.1.1 (LAN1) -- @IP à adapter selon ton sous-réseau local !

    • Cocher configurer manuellement le serveur DNS préféré et saisir l'@IP du NAS, pour le serveur DNS de remplacement tu peux mettre 80.67.169.12 ou 1.1.1.1 (Serveurs FND et Cloudfare). Dans "Paramètres avancés" tu coches les 3 cases.

  • "Réseau/Interface réseau" : pour LAN1 configurer avec DHCP automatique. Mais si tu le mets en configuration manuelle, alors : @IPlocaleNAS, passerelle=@IPlocaleBox, Serveur DNS= @IPlocaleNAS, cocher Définir comme valeur par défaut.

  • "Réseau/Paramètres de DSM" : Décocher "Rediriger automatiquement les connexions HTTP vers HTTPS sur le bureau DSM" sinon cela casse le processus de reverse proxy.

  • "Portails des applications/Applications" : Pour les applications, je te conseille de renseigner uniquement les ports HTTP standards.

  • "Portails des applications/Reverse proxy" : (si besoin suivre ce TUTO : Reverse Proxy pour comprendre les tenants et aboutissants de ce qui suit, ne pas oublier de créer le fichier ".htaccess") : Définir les redirections à l'image de celle-ci : https://aliasApplication.ndd.tld:443 --> localhost:portStandardHttpApplication (ne pas oublier de cocher HTTP/2). Soit par exemple dans ton cas : https://nas.ndd.tld + HTTP/2 coché  --> htttp://localhost:5000  pour le NAS (l'alias "nas" ne doit pas être le nom de ton NAS sinon cela ne marchera pas !) et par exemple https://file.ndd.tld + HTTP/2 coché  --> htttp://localhost:7000 pour FileStation (attention, c'est trompeur dans le reverse proxy certains champs sont apparemment déjà renseignés, mais il n'en est rien, il faut quand même les renseigner/saisir sinon rien n'est pris en compte !).
    La case HSTS ci-dessus n'est pas à cocher si tu n'as pas opté pour le preloading.

Seulement si tu as installé le package DNS Serveur (zone locale uniquement) tu fais ce qui suit. Cela permet d'utiliser en local des URL avec ton nom de domaine plutôt que de saisir à chaque fois une @IP pour atteindre un périphérique, ce qui est plus facile à retenir et plus simple à l'usage. De plus cela permet de contourner le problème des box qui n’autorisent pas le loopback.

NAS Partie DNS Serveur :

  • Se référer si besoin à ce TUTO : DNS Server pour la mise en place (Zone, Résolution, Vue).

  • Définir les ressources telles que :

    • ns.ndd.tld. A 86400 @IPduNAS

    • ndd.tld NS 86400 ns.ndd.tld.

    • nas.ndd.tld A 86400 @IPduNAS ---> pour accéder directement au NAS (DSM) avec "nas" <> "NomduNAS"

    • *.ndd.tld CNAME 86400 nas.ndd.tld. ---> pour accéder directement aux applications/services du NAS

  • Définir les Redirecteurs 1 et 2 sur respectivement 80.67.169.12 et 1.1.1.1

  • Pour la zone master et la vue associée limiter les IP sources tel que :
    P5dS39D.png
    Ajouter éventuellement le sous-réseau 10.0.0.0/255.0.0.0 si tu comptes faire du VPN.

Enfin et pour mémoire :

  • Dans ta Zone DNS chez OVH : tu devrais avoir une ligne du type : " *.ndd.tld CNAME 86400 ndd.tld ".

  • Comme tu as une @IP externe dynamique, tu ne dois pas avoir d'enregistrement de type " ndd.tld 0 A @IPexterneBox " chez OVH.

Dans cette procédure il y a des choses que l'on a déjà vu ensemble mais refais les pour être certain !

Si cela bloque à une étape, ne vas pas plus loin et reviens ici poser ta question à propos de ce qui bloque.

Il n'y a rien de compliqué en soit, il te faut juste être rigoureux et attentif à ce que tu fais et tout se passera bien.

Cordialement

oracle7😉

 

Lien vers le commentaire
Partager sur d’autres sites

@oracle7

Merci beaucoup. La procédure semble très complète. Cependant, je ne connais pas tous les abbréviations et je dois exécuter la procédure en étant sûr de bien faire chacune des étapes.

_____________________________________

  • Désactiver le serveur DHCP du NAS.

                 Complété

  • Désactiver provisoirement le pare-feu du NAS.

                 Complété

  • Entrer dans le champ "nom d'hôte" dans DSM "Accès externe / Avancé" ton domaine "monhote.ndd.tld". ("monhote" peut être le nom de ton NAS).

                Complété. Cependant , si j'ai bien compris  "monhote.ndd.tld"  =Nom de mon Nas tel qu'inscrit chez Synology (Mxxxxxer,@IP)

  • Depuis l'extérieur, dans un navigateur Web avec cache vidé : taper l'URL " http://<@IP Externe>:5000 " --> tu dois atteindre le NAS.

                Complété et ca marche

  • Accès externe :

     

  • On est bien d'accord que ton DDNS est défini sur ce domaine : " ndd.tld " et qu'il pointe bien vers ton @IP Externe (i.e. @IP Box). Je pars sur cette hypothèse pour la suite.

          Dans mon panneau de configuration -> DDNS  -> j'ai 2 domaine, soit celui de synology où le Status est normal et l'autre d'OVH avec un statut "échec d'autentification  ????? ( mais il pointe bien a @IP externe

  • On vérifie que ton DDNS pointe bien chez toi, en passant la commande " ping ndd.tld " depuis ton PC . La réponse doit être ton @IP Externe.

           Ping fonctionne bien et me donne mon @IP externe

  • On vérifie aussi dans un terminal SSH via PuTTY ou WinSCP, sous user root que " nslookup monhote.ndd.tld 8.8.8.8 ", ça doit aussi te faire tomber sur ton @IP Externe
    •      Ici ça se corse. voici ce que je recois
      • Server:         8.8.8.8
        Address:        8.8.8.8#53

        Non-authoritative answer:
        Name:  ndd.tld
        Address: 213.186.33.5   <-   Je ne reconnais pas cette addresse. Donc j'arrete ici pour avoir tes commentaires

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

Il y a 14 heures, Menjac a dit :

Address: 213.186.33.5   <-   Je ne reconnais pas cette addresse. Donc j'arrete ici pour avoir tes commentaires

C'est pourtant l'@IP que renvoie https://www.whatsmydns.net

3rRHKTD.png

J'obtiens la même chose avec le nslookup sur ton domaine.

Tu vérifies donc ton @IP externe par ex en te connectant à : https://www.whatsmyip.org ou https://ip.lafibre.info.

Donc, j'en déduit que cela devrait être ton @IP externe (celle de ta box) mais je peux me tromper. Donc et si 213.186.33.5 n'est pas ton @IP externe alors il te faut vérifier ta zone DNS chez OVH (pas d'enregistrement de type "A" qui fasse pointer ton domaine sur une @IP) ainsi que vérifier que tu as bien défini ton DynDNS avec ton @IP externe.

Si tout est OK de ce coté là, ensuite tu supprimes le DDNS OVH que tu avais créé sur le NAS et tu le recrées en indiquant bien la MÊME @IP que celle que tu as donnée pour le DynDNS chez OVH.

6XwMxT9.png

Dans tous les cas, que ce soit chez OVH pour le DynDNS ou sur le NAS pour le DDNS, il faut utiliser la MÊME @IP qui doit être ton @IP externe (celle de ta box).

Je ne peux te dire mieux à ce stade.

Cordialement

oracle7😉

 

 

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

Désolé pour la réponse tardive.

Manifestement, le processus DynHost ne serait pas valable au Canada contrairement à ce qui ce fait en France notamment. Je ne suis pas surpris de cet état de fait.

J'en déduit alors que tu dois avoir une @IP externe fixe. C'est à vérifier avec ton fournisseur d'accès Internet (FAI).

Si c'est bien le cas, il faut reprendre ce que je t'ai dit à propos de la configuration du DynDNS chez OVH et le supprimer au profit d'un enregistrement "A" qui fait pointer ton domaine vers ton @IP externe dans ta zone DNS chez OVH.

Sur le NAS tu n'aurais plus besoin non plus de déclarer de DDNS. Le reste est sans changement.

Cordialement

oracle7😉

 

 

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

@oracle7

  • "Portails des applications/Reverse proxy" : (si besoin suivre ce TUTO : Reverse Proxy pour comprendre les tenants et aboutissants de ce qui suit, ne pas oublier de créer le fichier ".htaccess") : Définir les redirections à l'image de celle-ci : https://aliasApplication.ndd.tld:443 --> localhost:portStandardHttpApplication (ne pas oublier de cocher HTTP/2). Soit par exemple dans ton cas : https://nas.ndd.tld + HTTP/2 coché  --> htttp://localhost:5000  pour le NAS (l'alias "nas" ne doit pas être le nom de ton NAS sinon cela ne marchera pas !) et par exemple https://file.ndd.tld + HTTP/2 coché  --> htttp://localhost:7000 pour FileStation (attention, c'est trompeur dans le reverse proxy certains champs sont apparemment déjà renseignés, mais il n'en est rien, il faut quand même les renseigner/saisir sinon rien n'est pris en compte !).
    La case HSTS ci-dessus n'est pas à cocher si tu n'as pas opté pour le preloading.

Bon dimanche. Encore une fois merci beaucoup

La dernière partie (celle-ci haut) me semble un peu plus complexe pour moi et j'aurai encore besoin d'aide, si tu me le permets.

A commencer par un exemple d'un fichier ".htaccess". Peux-tu me transmettre un fichier qui pourrait me servir de départ?

@Menjac

 

Lien vers le commentaire
Partager sur d’autres sites

@Menjac

Bonjour,

Pas de soucis pour t'aider (dans la mesure de mes connaissances), c'est un plaisir 😀

Tu as un exemple de fichier ".htaccess" dans le TUTO Reverse Proxy mais voici le mien, il est tout simple :

RewriteEngine On 
RewriteCond %{HTTPS} off 
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Cordialement

oracle7😉

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.