This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

toutnickel

Demande info sur https et certificat

Messages recommandés

A mon avis, ça ne peut pas fonctionner. Il faut aussi dire à DSM quel certificat est applicable pour tel ou tel service. Pour cela, il faut configurer pour chaque ligne le certificat à utiliser. Ca ne se voit pas de prime abord, mais si vous cliquez sur la case de la colonne "Certificat" d'un service, vous verrez la liste des certificats. Il suffit de choisir celui qui sera appliqué.

Partager ce message


Lien à poster
Partager sur d’autres sites

Suite :

En externe
je testerai demain de chez un copain --> testé et ok tout fonctionne pour accès http (redirigé vers https) et https direct sur le DSM

Donc si je comprends bien je supprime l'ancien certificat pour que tous mes services s'orientent vers le seul certificat présent celui que j'ai créer.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai essayé de suivre le sujet et je dois dire que cela m'a bien aidé :)

J'ai ajouté un DDNS en synology.me, créé un certificat Let's Encrypt, défini le certificat par défaut et pour les services, supprimé l'accès QuickConnect.

Tout fonctionne à merveille et je n'ai plus ce message rouge sur le navigateur !

Par contre, j'utilise également le redirection http vers https du NAS, il y a un moyen plus sécurisé ?

Partager ce message


Lien à poster
Partager sur d’autres sites

La redirection ne pose pas de problème de sécurité en soit (mais elle peut poser d'autres pb)

Perso je contrôle la redirection avec un script PHP (pour rediriger vers le bon port et/ou la bonne url en fonction de différents critères)

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ton retour @Fenrir.

La seule chose qui m'embête de mon côté c'est que lorsque je tape dans l'url mon-nas.synology.me je tombe sur ce message:

Web Station has been enabled. To finish setting up your website, please see the "Web Service" section of DSM Help.

J'aurai peut-être souhaité que cela me redirige directement vers le port du NAS et non vers mon site web (que je n'ai pas encore implémenté !)

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est parce que WebStation est activé.

Place simplement un petit fichier index.php à la racine du dossier web avec, par exemple, ça dedans :

<?php
$http_host=$_SERVER['HTTP_HOST'];
// 307 Temporary Redirect
header("Location: https://$http_host",TRUE,307);
exit;
?>

À adapter en fonction de tes besoins.

Si par exemple tu utilise webstation pour autre chose ou si tu n'utilises pas le reverse proxy, il faudra ajouter un test (if ($_SERVER['HTTP_HOST'] .... ou avec le port ou ...)

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 16 heures, Oliver-05 a dit :

J'ai essayé de suivre le sujet et je dois dire que cela m'a bien aidé :)

J'ai ajouté un DDNS en synology.me, créé un certificat Let's Encrypt, défini le certificat par défaut et pour les services, supprimé l'accès QuickConnect.

Tout fonctionne à merveille et je n'ai plus ce message rouge sur le navigateur !

Par contre, j'utilise également le redirection http vers https du NAS, il y a un moyen plus sécurisé ?

Bonjour

Si ton accès en https fonctionne, l’accès quickconnect est redirigé sur l'alias monas.synology.me et donc en https 

Il y a 16 heures, Oliver-05 a dit :

Merci pour ton retour @Fenrir.

La seule chose qui m'embête de mon côté c'est que lorsque je tape dans l'url mon-nas.synology.me je tombe sur ce message:

Web Station has been enabled. To finish setting up your website, please see the "Web Service" section of DSM Help.

J'aurai peut-être souhaité que cela me redirige directement vers le port du NAS et non vers mon site web (que je n'ai pas encore implémenté !)

si tu ajoute a ton alias monas.synology.me:5000 tu n'auras pas ce problème et tu seras redirigé en https 5001 par défaut

Il y a 15 heures, Fenrir a dit :

C'est parce que WebStation est activé.

Place simplement un petit fichier index.php à la racine du dossier web avec, par exemple, ça dedans :


<?php
$http_host=$_SERVER['HTTP_HOST'];
// 307 Temporary Redirect
header("Location: https://$http_host",TRUE,307);
exit;
?>

À adapter en fonction de tes besoins.

Si par exemple tu utilise webstation pour autre chose ou si tu n'utilises pas le reverse proxy, il faudra ajouter un test (if ($_SERVER['HTTP_HOST'] .... ou avec le port ou ...)

Bonjour

j'utilise aussi le site web par le lien monas.synology.me avec le port 80 et redirigé dans ma box vers le nas
 

que fait ce script, je décrypte mal le PHP, peux tu décrire ce que fait les lignes de commande, 

merci

 

 

Modifié par toutnickel

Partager ce message


Lien à poster
Partager sur d’autres sites

@Fenrir Merci pour ta solution, je l'ai mise en place, j'ai juste rajouté le numéro de port dans le script car la redirection se faisait bien sur le https mais sans numéro de port la page n'abouti pas.

@toutnickel J'ai préféré désactiver quickconnect pour ne pas laisser trop de portes ouvertes ! Par contre je ne comprends pas où je dois faire la manip que tu expliques ci-dessous

si tu ajoute a ton alias monas.synology.me:5000 tu n'auras pas ce problème et tu seras redirigé en https 5001 par défaut

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, Fenrir a dit :

Il redirige simplement le trafic http vers https

Dans mon cas  j’utilise le site web avec le lien : monas.synology.me (par défaut port 80) et je tombe sur la page web de mon NAS.
si je mets monas.synology.me:5000 (redirection du port 5000 sur ma box et là je tombe sur DSM

Quel serait le contenu de ton script a insérer a la racine de web ? 
 

Il y a 1 heure, Oliver-05 a dit :

 

@toutnickel J'ai préféré désactiver quickconnect pour ne pas laisser trop de portes ouvertes ! Par contre je ne comprends pas où je dois faire la manip que tu expliques ci-dessous

si tu ajoute a ton alias monas.synology.me:5000 tu n'auras pas ce problème et tu seras redirigé en https 5001 par défaut

si tu mets le port 5000 sur ton alias tu seras dirigé sur DSM

en 5001 en securisé

valabe pour http et pour quicconnect

si tu vas dans DSM/réseau/parametre dsm
tu peux cocher la case : rediriger automatiquementles connexions http vers https

dans ce cas si tu tapes l'url : http:/ totoquicconnect... celle-ci est redirigé automatiquement sur https://monas.synology.me:5001

a effectué en externe car en local suivant ton provider ça ne fonctionne pas de la même façon

.

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, toutnickel a dit :

tu peux cocher la case : rediriger automatiquementles connexions http vers https

attention, cette case a une interaction négative sur le fonctionnement du reverse proxy

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci des conseils pour la mise en place du certificat.

J'avais essayé mais sans succès.

Je peux désormais me servir de la Chromecast, qui auparavant me bloquait car la connexion n'était pas sécurisée.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant