This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

bobtaz

DS212J HS ?

Messages recommandés

Bonjour,

Tout d'abord, je suis newsbie dans le monde des NAS mais j'ai des connaissances électroniques et informatiques.

Je viens de récupérer un NAS DS212J et ces 2 HDD qui ne fonctionne plus. Symptôme : Leds bleues clignotantes et pas de bip après un reset long.

Le problème est survenu lors d'une mise à jour (coupure de courant et donc interruption).

Après avoir lu quelques tuto et par curiosité de ne trouver un moyen de communiquer avec le nas, j'ai fini par communiquer par le terminal port série directement depuis la carte mère (connecteur 6 pins).

Je ne vois que uBoot qui se lance (couche basse il me semble) et m'affiche un "Bad magic number" au moment de lancer la partie linux (normal je pense vu que la mise à jour à été interrompue). J'ai téléchargé le .pat correspondant au DS212J chez Syno et extrait les fichiers pour enfin flasher le .img à l'aide de la commande tftpboot -> OK

Question : cette commande écrit le code en flash de façon durable (ok après un reset ou une remise sous tension) si non, comment le faire ?

J'ai ensuite lancé la commande "bootm" qui lance le système linux mais plante après quelques secondes si les disques sont non présents et plante après prés de 30s si les anciens disques sont présents (kernel panic).

Je cherche à savoir si mon système est récupérable. Ce qui est sûr c'est que je n'arrive jamais à écrire de façon durable en mémoire (même un changement de l'adresse ip sous uboot n'est pas gardée après un reset.

Merci à tous de m'éclairer sur l'ordre de démarrage des systèmes et où sont stockés ces systèmes.

Modifié par bobtaz

Partager ce message


Lien à poster
Partager sur d’autres sites

Effectivement test KO même sans les disques...

Ce procédure permet de juste tester le hard ? (donc serait OK même si la partie Linux est KO, ce qui est sûr dans mon cas vu que la mise à jour n'a pas été effectuée complètement : donc état indéfini).

Quelqu'un à une définition de ce que cet autotest inclus ? Vu que le bouton reset n'a pas l'air d'être utilisé dans mon cas (donc géré par le µC Marvell / linux), je pense que c'est un test global (partie uboot et linux + hardware) qui est effectué. Comme je penche pour un défaut Linux, il me semble cohérent que l'autotest ne fonctionne pas et m'obstine à croire que le problème est récupérable.

Merci pour vos conseils.

Partager ce message


Lien à poster
Partager sur d’autres sites

Le test en question est global. Compte tenu de l'origine de la panne, il est très probable que votre nas n'ait qu'un pb de boot. Mais là s'arrête mon intervention, je n'ai aucune connaissances au niveau hard ou soft pour vous aider.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement