This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

[TUTO] VPN Server


Messages recommandés

@Jeff777

Bonjour,

il y a 10 minutes, Jeff777 a dit :

Donc si ceux-ci ne sont pas 5000 et 5001 cela ne peut pas marcher !

Oui c'est fort possible qu'il ait changer ces ports. Toutefois, si ce n'était pas le cas, alors il y aurait un sérieux problème 🥴

Pas facile à trouver ...

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites
  • Réponses 1,2k
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Préambule Le but de ce tutoriel est de vous aider à mettre en place un réseau privé virtuel (VPN) entre vous et votre NAS depuis Internet. nb : il ne s'agit pas ici de "masquer" votre adress

Je confirme la réponse de @Litsip (surtout l'aspect sécurité illusoire que vendent les fournisseurs de vpn) : exemple : http://www.numerama.com/tech/298268-la-collaboration-decriee-de-purevpn-a

@.Shad. Un énorme merci à toi pour les réglages que tu as effectué sur mon NAS. Tout fonctionne à merveille maintenant !!!! Juste à régler le synology drive comme il faut. Je vais regarder s

Posted Images

@Jeff777

Bonjour,

Une réflexion peut-être idiote, mais ne serait-ce pas aussi la définition de son DNS serveur qui mettrait la pagaille ?

Je m'avance sur ce point car @Fenrir dit bien dans son TUTO (en rouge dans la partie zone locale) qu'il déconseillait fortement de configurer un DNS serveur avec un domaine que l'on ne maitrise pas en tant que propriétaire : en l'occurrence xxxxx.synology.me. Ton avis STP ?

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites

Sa zone locale est limitée aux adresses locales donc ce que tu dis ne suffit pas à expliquer ceci :

Il y a 15 heures, lordatao a dit :

Smartphone 4G non http://XXXX.synology.me/ Accès DSM OK

Smartphone 4G non https://XXXX.synology.me/ Accès DSM OK

Attendons ce que dit @lordataosur le paramétrage du DSM dans la config/réseau. 

 

 

 

Modifié par Jeff777
Lien à poster
Partager sur d’autres sites

@oracle7 @Jeff777 @Thierry94

Messieurs bonsoir et encore merci pour votre aide.

Je viens de reprendre à zéro la configuration en étant le plus basique (juste le réglage pour l'accès au VPN, le reste, je verrais plus tard lorsque le VPN fonctionnera). Le résultat est toujours le même. La connexion du VPN se fait, le tunnel à l'air établi mais aucune connexion sur l'explorateur W10.

Voici les réglages de ma freebox V6

480248395_Capturedcran2020-11-06182224.thumb.png.65a00581b4d8fbc71cf916c9315567f6.png

Je n'ai ouvert que les 2 ports.

1629846947_Capturedcran2020-11-06182248.png.425bd46b3cb4bda27d9c95cd0547cf29.png

L'UPN est désactivé.

1544934706_Capturedcran2020-11-06182325.png.9ff033e1b914989e397fcce89f36d825.png

Mes adresses sont réglées comme tel.

1818842171_Capturedcran2020-11-06183250.thumb.png.a92542765fda4bffecd447979e128b30.png

Voici ce que j'ai en réseau local et que je veux obtenir via le vpn.

Voici maintenant les réglages de mon NAS

1763567641_Capturedcran2020-11-06182457.thumb.png.417c9d3335c88a08e841b1bce43b8bc5.png

1462768180_Capturedcran2020-11-06182531.thumb.png.866c69908c3f37c1b545261c1116551c.png

1392760274_Capturedcran2020-11-06182603_LI.thumb.jpg.4c6a7f4b954b3428ca2a3f5f4df0ad9c.jpg

1606762845_Capturedcran2020-11-06182804.thumb.png.bd88a60d4820d46153038d2adf8087f8.png

1513904534_Capturedcran2020-11-06182824_LI.thumb.jpg.f51c68d8107a41416b54597f5dde74af.jpg

1149917004_Capturedcran2020-11-06182845.thumb.png.7ec4741dd77510d1fd1eed108378423d.png

Voici le fichier de configuration du VPN

317715093_Capturedcran2020-11-06182943.thumb.png.b1fe2656f899b03b298bf20641b07321.png

Une fois connecté, voici ce que j'obtiens lorsque je tente de me connecter au nas

789951513_connectionnas.thumb.png.2d908f35255abb8a3c990bfc308c9f44.png

Voilà l'ensemble de mes réglages. Je ne vois pas ce qui bloque (je pense avoir fait les bons réglages mais je ne suis absolument pas un expert...)

Si ces éléments peuvent éclairer votre expertise, je suis preneur des différents réglages à réaliser avant de penser aux autres connexions (DS file sur mon mobile, Plex..., je verrais cela plus tard).

Lien à poster
Partager sur d’autres sites

Euh... je n'ai pas tout lu car je vais devoir m'absenter. Mais je reviens sur la question ci-dessus. 

As-tu ceci dans ton paramétrage :

 

Capture.thumb.JPG.10e6d309b97b827aa0883fb1a10c1a37.JPG

Modifié par Jeff777
Lien à poster
Partager sur d’autres sites

@lordatao

Bonjour,

Si tu définis une plage DHCP dans ton routeur allant de 192.168.1.2 à 50, tu ne peux pas alors définir l'@IP 192.168.1.36 pour ton NAS.

Ce dernier doit avoir une @IP fixée par un bail statique EN DEHORS de la plage d'attribution automatique du DHCP sinon tu risque qu'un périphérique se connectant se voit attribuer cette même @IP d'où conflit et c'est pas bon pour le réseau.

Dans ton fichier de config .ovpn l'instruction "dhcp-option DNS" doit être "dhcp-option DNS 10.8.0.1" (@IP du NAS en VPN) et non pas "dhcp-option DNS 192.168.1.254".

Sinon mis à part la bonne remarque de @Jeff777, cela me semble bon a priori.

EDIT : Oui il faut cocher la case "Activer l'en-tête "server" dans les réponses HTTP"

Cordialement

oracle7😉

Modifié par oracle7
Lien à poster
Partager sur d’autres sites

@lordatao

Peux-tu s'il-te-plaît re-commenter les options dhcp-option et redirect-gateway def1 ?
Ces options ne sont pas nécessaires pour qu'un serveur OpenVPN fonctionne, le temps de debugger la situation au moins.

On va faire un petit test tout bête, tu vas éditer le fichier hosts de Windows 10 (C:\Windows\ System32\drivers\etc\hosts) en ajoutant :

192.168.1.36          nas.test
10.8.0.1              nas.test

Tu te déconnectes du VPN, puis tu mappes le lecteur réseau video en entrant l'adresse :

\\nas.test\video

Tu tentes d'y accéder. Si ça fonctionne, tu te connectes au VPN et tu essaies de nouveau de parcourir le dossier partagé. As-tu toujours une erreur ?

Lien à poster
Partager sur d’autres sites

@.Shad.

il y a 26 minutes, .Shad. a dit :

@lordatao

Peux-tu s'il-te-plaît re-commenter les options dhcp-option et redirect-gateway def1 ?
Ces options ne sont pas nécessaires pour qu'un serveur OpenVPN fonctionne, le temps de debugger la situation au moins.

On va faire un petit test tout bête, tu vas éditer le fichier hosts de Windows 10 (C:\Windows\ System32\drivers\etc\hosts) en ajoutant :


192.168.1.36          nas.test
10.8.0.1              nas.test

Tu te déconnectes du VPN, puis tu mappes le lecteur réseau video en entrant l'adresse :


\\nas.test\video

Tu tentes d'y accéder. Si ça fonctionne, tu te connectes au VPN et tu essaies de nouveau de parcourir le dossier partagé. As-tu toujours une erreur ?

Ca fonctionne !!!!! Mais que le lecteur NAS.test... C'est un début...

Lien à poster
Partager sur d’autres sites

@lordatao

En l'occurrence modifier le fichier hosts n'est évidemment pas la solution, mais ça permet de vérifier que ton NAS est bien joignable en 192.168.1.36 en local et 10.8.0.1 en VPN.

Nettoie ton fichier hosts des deux entrées précédentes, connecte-toi au VPN et essaie de ping l'adresse IP locale du NAS 192.168.1.36

As-tu un délai d'attente de la demande dépassé ?

Lien à poster
Partager sur d’autres sites

Bonjour,

Chez moi j'aussi eu des problèmes d'acces aux lecteurs réseau de windows à travers le vpn. Il s'agissait principalement des lecteurs réseau que j'avais créé par la procedure windows avec attribution d'une lettre de lecteur.

J'ai finalement retiré ces lecteurs et les ai replacés par des entrées dans l'accès rapide. Pour la générer dans l'explorateur windows tu click droit sur le dossier partagé  du Nas et tu choisis "ajouter a l'acces rapide'".

Depuis plus de problème pour accéder au nas depuis windows via le vpn !

Thierry

Modifié par Thierry94
Lien à poster
Partager sur d’autres sites
Il y a 12 heures, .Shad. a dit :

@lordatao

En l'occurrence modifier le fichier hosts n'est évidemment pas la solution, mais ça permet de vérifier que ton NAS est bien joignable en 192.168.1.36 en local et 10.8.0.1 en VPN.

Nettoie ton fichier hosts des deux entrées précédentes, connecte-toi au VPN et essaie de ping l'adresse IP locale du NAS 192.168.1.36

As-tu un délai d'attente de la demande dépassé ?

@.Shad.

Voici la réponse du ping "délai d'attente dépassé"

1395933377_Capturedcran2020-11-07104443.png.fc1b27ce1c7c554841e0fdf4282fab94.png

Il y a 11 heures, Thierry94 a dit :

Bonjour,

Chez moi j'aussi eu des problèmes d'acces aux lecteurs réseau de windows à travers le vpn. Il s'agissait principalement des lecteurs réseau que j'avais créé par la procedure windows avec attribution d'une lettre de lecteur.

J'ai finalement retiré ces lecteurs et les ai replacés par des entrées dans l'accès rapide. Pour la générer dans l'explorateur windows tu click droit sur le dossier partagé  du Nas et tu choisis "ajouter a l'acces rapide'".

Depuis plus de problème pour accéder au nas depuis windows via le vpn !

Thierry

@Thierry94

Bonjour Thierry,

Merci pour l'astuce, mais cela n'a pas fonctionné chez moi...😖 dommage, cela aurait été bien pourtant.

@.Shad.

Bonjour Shad

Est-ce que je ne peux pas modifier le fichier host et le conserver si cela fonctionne ? Y'a t'il un danger à utiliser cette solution ?

Lien à poster
Partager sur d’autres sites

@lordatao

Très curieux que tu n'arrives pas à te connecter avec l'adresse locale. Tu devrais corriger ce que t'a dit @oracle7

Dans la freebox, limiter la fenêtre du DHCP à 192.168.1.2 à 192.168.1.35 et entrer 192.168.1.36 de ton NAS dans les baux statiques.

Modifié par Jeff777
Lien à poster
Partager sur d’autres sites

@Jeff777 @oracle7 @.Shad.

Je viens de faire les modifs suivantes :

Il y a 15 heures, oracle7 a dit :

Si tu définis une plage DHCP dans ton routeur allant de 192.168.1.2 à 50, tu ne peux pas alors définir l'@IP 192.168.1.36 pour ton NAS.

Ce dernier doit avoir une @IP fixée par un bail statique EN DEHORS de la plage d'attribution automatique du DHCP sinon tu risque qu'un périphérique se connectant se voit attribuer cette même @IP d'où conflit et c'est pas bon pour le réseau.

Dans ton fichier de config .ovpn l'instruction "dhcp-option DNS" doit être "dhcp-option DNS 10.8.0.1" (@IP du NAS en VPN) et non pas "dhcp-option DNS 192.168.1.254".

Sinon mis à part la bonne remarque de @Jeff777, cela me semble bon a priori.

EDIT : Oui il faut cocher la case "Activer l'en-tête "server" dans les réponses HTTP"

Modifs des baux dhcp de 2 à 35 en dynamique, case cochée dans DSM, modif du fichier de config openvpn, restauration du fichier host à l'origine, test ping. Résultat ping négatif et pas de connexion au réseau

 

Je n'ai plus accès en local à nas_yoyo mais à 192.168.1.36 (pas très gênant en soi).

Le ping était positif avant que je coche l'activation de passerelles multiples

937374700_Capturedcran2020-11-07115141.png.63a41f3f6f2c222bb5e1906e8c28fcee.png

Lien à poster
Partager sur d’autres sites
il y a une heure, lordatao a dit :

Le ping était positif avant que je coche l'activation de passerelles multiples

En étant connecté au VPN ?

@Jeff777

Normalement c'est effectivement pour rendre accessible le NAS depuis l'extérieur depuis son IP VPN et son IP publique normale. Je me suis dit qu'en extrapolant au local ça pourrait peut-être marcher. Visiblement non.

Dans ce cas-là il lui suffit de définir une zone DNS locale avec deux vues, une pour le VPN où il y aura un enregistrement A du NAS vers 10.8.0.1 et une pour le LAN, avec un enregistrement À du NAS 192.168.1.36

Il y a surement moyen de jouer avec les routes statiques mais je ne suis pas persuadé de leur persistance au fil des maj.

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

@lordatao

Bonjour,

As-tu tout bêtement rebooté ta box après ces modifs de DHCP ? Cela me paraît nécessaire pour qu'elles soient prises en compte.

Sinon il me paraissait plus simple de modifier l'@IP du NAS que de modifier la plage DHCP. Mais c'est juste une question de point de vue. Dans les deux cas, cela marche tout aussi bien.

Un autre point : dans "Panneau de configuration / Accès externe / Avancé" as-tu renseigné ton @IP fixe externe ainsi que les ports 5000 et 5001 ?

@.Shad.

Et si sur son PC il entre une route statique telle que :

C:\Windows\system32>route ADD 192.168.1.36/24 10.8.0.1 IF xx -p

en remplaçant xx par le bon n° d'interface. Cela ne le ferait pas aussi ?

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites

C'est du bricolage, le jour où il change de PC ou qu'il veut mapper des dossiers depuis un autre, il est bon pour refaire la route.

C'est bien plus propre de faire ça via une zone DNS locale avec les vues adéquates (ce qui est en quelque sorte l'aboutissement du tutoriel de Fenrir sur le serveur DNS partir locale).

Si quelqu'un utilise le paquet VPN serveur du NAS ou du RT, est-ce qu'il peut ping l'IP locale quand il est connecté au VPN ? Voir si c'est propre à l'infrastructure de @lordatao le fait que les IP soient exclusives d'accès ou si c'est le fonctionnement normal.

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

@.Shad.

Bonjour,

il y a 3 minutes, .Shad. a dit :

C'est du bricolage, le jour où il change de PC ou qu'il veut mapper des dossiers depuis un autre, il est bon pour refaire la route.

C'était juste une question. J'ai eu ma réponse qui correspond à ce que je m'attendais.

Sinon pour répondre à ta question : connecté avec le client OpenVPN sur mon smartphone 4G au Serveur VPN de mon RT, j'arrive à "pinguer" mes 2 NAS et mon PC (ainsi que tous mes périphériques) situés sur le réseau local derrière mon RT avec leur @IP locales en 192.168.x.x.

Cordialement

oracle7😉

 

Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.