This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

DHCP DNS Pi-hole


Messages recommandés

Bonjour,

Grace au super Tuto pour installer Pi-hole, Je l'utilise maintenant depuis quelques mois.

Mais j'aimerai aller un peu plus loin avec ma config:

Sur mon routeur Linksys je fait pointer le DNS vers le Pi-hole et donc dans l'interface de ce dernier, je vois bien mon routeur Linksys qui envoie TOUT le trafic.

J'aimerai maintenant pouvoir voir mes différents appareils dans Pi-hole. Pour cela, je voudrais que mon routeur envoie, via le DHCP, le DNS du P-H

(je peux le mettre manuellement dans un téléphone ou pc, mais c'est chiant de devoir chaque fois changer quand je me déplace)

Et c'est la que ça coince. Je ne trouve pas comment faire.

J'ai cherché sur le net sans trouver, peut-être que vous pouvez m'aider?

Merci

Lien à poster
Partager sur d’autres sites

Parce qu'actuellement ton serveur DNS c'est le routeur Linksys, et que tout passe par lui avant d'aller vers Pi-hole.
Tu confonds les DNS du routeur avec les DNS qu'envoie le routeur à ses clients (via le serveur DHCP du routeur).
Tu dois donc donner l'adresse IP du Pi-hole dans les paramètres du serveur DHCP de ton routeur.
Et je te conseille de laisser les DNS du routeur vers ceux qu'il acquiert soit par le DHCP de la box, soit tu peux mettre des DNS "respectueux de la vie privée" reconnus comme ceux de la FdN : 80.67.169.12 et 80.67.169.40

Une fois ceci fait, tu verras bien tous les périphériques, et plus le routeur (aucune bonne raison selon moi de filtrer les messages du routeur, ça peut juste mener à un dysfonctionnement de ce dernier).

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

Merci Shad

 

Mais justement, je ne vois pas ou je dois configurer le DNS du DHCP

voici a quoi ressemble mon interface du routeur.

original?v=1.0&px=-1

J'ai mis l'IP du Pi-hole dans ' Static DNS 1 ' mais les appareilles ne reçoivent pas cette ip

Lien à poster
Partager sur d’autres sites

Ce n'est pas normal, ça a l'air d'être le bon endroit.
Quel modèle le routeur ?

Est-ce que tu n'as pas un autre serveur DHCP sur le réseau ? Deux serveurs peuvent coexister, rien ne l'empêche, c'est à celui qui répondra le plus vite à la demande d'adressage d'un client (on évite clairement).

Sinon rien à voir, mais à ta place je réduirais le nombre maximum d'utilisateurs, de manière à ce que tes réservations puissent se faire hors plage DHCP.
Dans le cas présent, la plage couvre l'ensemble des adresses disponibles, ça peut mener à des problèmes (mais qui n'ont a priori pas de relation avec les ennuis que tu rencontres pour l'instant).

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

mon routeur est un Linksus velop MX5300.

Je suis sur de ne pas avoir un 2eme serveur DHCP.

Pour la plage des IP sous DHCP, je suis effectivement bien plus bas et mes IP dédier sont hors DHCP. L'image vient d'internet, ce n'est pas ma config 😉

 

Merci pour ton aide et tes analyses 🙂

 

Lien à poster
Partager sur d’autres sites

Pour moi il doit y avoir un problème d'environnement, car le réglage est forcément là.
Tu peux clarifier ton installation ? Je vois que tu es chez VOO, donc j'imagine que ton routeur Linksys est en cascade du modem.
Ou est-ce que tu utilises le mode bridge sur le modem ?
Tu as aussi un Airport Extreme qui est aussi un routeur en plus d'un point d'accès.

Un petit schéma pour identifier ton installation serait une plus-value.

En attendant, tu peux essayer de débrancher l'arrivée internet depuis le modem sur ton routeur, et ne laisser sur le routeur qu'un PC et le NAS en connexion filaire.
Tu vérifies si une fois isolé de tout le reste, ton PC et ton NAS reçoivent bien l'IP de Pi-hole en serveur DNS via le DHCP ou toujours pas.

Lien à poster
Partager sur d’autres sites

J'avais le même soucis quand j’étais chez Proximus avec le routeur en PPoE 😉

Ma config actuel (parce que j'ai déménagé et donc tout n'est pas connecté)

En câbler: Internet -> Modem Voo en mode Bridge (j'ai même du les appeler pour recevoir une IP publique) -> Routeur Linksys -> NAS

il n'y a rien d'autre, l'airport n'est pas encore connecté et même le pont Philippe Hue n'est pas connecté)

En wifi: GSM, Ordi, Prise.

 

Je suis donc dans une configuration la plus basique en se moment.

Le routeur est config en 10.0.1.x et tout mes appareils ont bien une IP du routeur.

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)
il y a 9 minutes, Jeff777 a dit :

Bonjour,

Je tente Tu ne serais pas en wifi directement sur la box ?

non, wifi de la box est désactivé 😉

il y a 10 minutes, .Shad. a dit :

Si tu tapes en SSH sur le NAS :



nslookup www.google.fr

Le serveur qui répond (les champs Server et Address) c'est bien l'IP de ton routeur ?

server: 10.0.1.5

Address: 10.0.1.5#53

c'est l'IP de mon nas

 

EDIT: je ne suis pas chez moi et j'ai fais le SSH via le VPN (peut-être que...)

Modifié par Geoff1330
Lien à poster
Partager sur d’autres sites

Ok, tu peux dire quelle méthode tu as suivi pour installer Pi-hole ? Il y en a plusieurs sur ce forum. Et celle du tutoriel n'est pas forcément la plus propre.
En plus de cette question, peux-tu faire des impressions d'écran :

- des DNS reçus par ton PC
- de ce que donne en SSH sur le NAS :

cat /etc/resolv.conf

- de la configuration de ton serveur DHCP (pas une image d'Internet cette fois, il n'y a rien comme info qui puisse être utilisé contre toi sur cet écran).

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

J'ai suivi le tuto

Avec le docker " pihole-pihole1"

 

N’étant pas chez moi, voici les info de ma camera Wifi:

foscam1.thumb.png.03afa270f6e0d8ca2df85cb5d5c1ed32.png

Geoff@TheBoss:~$ nslookup www.google.fr
Server:         10.0.1.5
Address:        10.0.1.5#53

Non-authoritative answer:
Name:   www.google.fr
Address: 172.217.168.227

Geoff@TheBoss:~$ cat /etc/resolv.conf
nameserver      10.0.1.5
domain  lan

linksys.thumb.png.0aaba77a85ca4fcd84b6dac9f6b35d2b.png

 

Je pense que tu as tout la 😉

Lien à poster
Partager sur d’autres sites

En tout cas ton NAS a bien pour serveur DNS lui-même, donc le serveur DHCP fonctionne a priori.
Et je ne suis pas certain que les champs grisés sur ta caméra correspondent forcément à ce qu'elle reçoit du DHCP.
C'est bien simple, donne comme DNS au routeur (pas dans le serveur DHCP) les serveurs FdN par exemple dont j'ai donné les IP plus haut, normalement ton pi-hole devrait se peupler de tes différents périphériques. Tu verras tout de suite si l'IP de la caméra y est reprise.
Parallèlement tu as peut-être un endroit sur ton routeur où tu peux voir tous les baux en cours. Pas forcément un critère absolu (le bail a pu être délivré mais elle ne l'utiliserait plus qu'il y serait encore si cela date d'il y a moins de 1440 minutes -> 1j).

Lien à poster
Partager sur d’autres sites

Je ne sais pas ou on peut mettre le DNS du routeur. le seul endroit que j'ai trouvé c'est au niveau DHCP.

J'ai trouvé ca sur le routeur:

 

Informations sur le routeur 	
Version du micrologiciel : 	1.1.9.200251
Numéro de série : 	*****
Heure du routeur actuelle : 	Mardi, 05 Janvier 2021 15:27:34 (GMT +01:00)
Heure du navigateur actuelle : 	Mardi, 05 Janvier 2021 15:27:38 (GMT +01:00)
Adresse MAC Internet : 	*****
Nom du serveur : 	Linksys03210
Nom d'hôte : 	Linksys03210
Nom de domaine : 	
 
Services Linksys Smart Wi-Fi 	
Etat : 	Connecté
 
Connexion Internet (IPv4) 	
Type de connexion : 	Configuration automatique - DHCP
Adresse Internet : 	109.*****
Masque de sous-réseau : 	255.255.255.0
Passerelle par défaut : 	109.88.51.1
DNS1 : 	109.88.203.3
DNS2 : 	62.197.111.140
DNS3 : 	
MTU : 	Auto
Durée de bail DHCP : 	480 minutes
 
Connexion Internet (IPv6) 	
Type de connexion : 	Déconnecté
Adresse Internet : 	
Passerelle par défaut : 	
DNS1 : 	
DNS2 : 	
DNS3 : 	
Durée de bail DHCP : 	 
 
Réseau local 	
Adresse MAC locale : 	C4:41:1E:98:1B:8E
Adresse IPv4: 	10.0.1.1
Masque de sous-réseau IPv4 : 	255.255.255.0
Lien IPv6 – Adresse locale : 	fe80:0000:0000:0000:c641:1eff:fe98:1b8e
Adresse du préfixe : 	
 
Serveur DHCP 	
Serveur DHCP : 	Activé
Adresse IP de début : 	10.0.1.10
Adresse IP de fin : 	10.0.1.109
Durée de bail du client : 	1440 minutes
DNS statique 1 : 	10.0.1.5
DNS statique 2 : 	
DNS statique 3 : 	
WINS : 	10.0.1.5
 
Réseau sans fil 2,4 GHz 	
Etat : 	Activé
Adresse MAC : 	C4:41:1E:98:1B:8F
Mode Wi-Fi : 	802.11mixed
Nom du réseau Wi-Fi : 	Home
Largeur du canal : 	Auto
Canal : 	Auto
Sécurité : 	WPA2 personnel
 
Réseau sans fil 5 GHz 	
Etat : 	Activé
Adresse MAC : 	C4:41:1E:98:1B:90
Mode Wi-Fi : 	802.11mixed
Nom du réseau Wi-Fi : 	Home
Largeur du canal : 	Auto
Canal : 	Auto
Sécurité : 	WPA2 personnel
 
Réseau sans fil 5 GHz 	
Etat : 	Activé
Adresse MAC : 	C4:41:1E:98:1B:91
Mode Wi-Fi : 	802.11mixed
Nom du réseau Wi-Fi : 	Home
Largeur du canal : 	Auto
Canal : 	Auto
Sécurité : 	WPA2 personnel
 
 
Ports 	
	10/100 Mbit/s 	1 Gbit/s
Internet 		X
	10/100 Mbit/s 	1 Gbit/s
1		
2		
3		
4		X

pi.thumb.png.a60a0290955a8b16d672ab8e60d61b7c.png

ici on voit que l'IP de la camera est la en faisant le test de mettre le DNS à la main. mais sinon, il y a aucun autre appareil.

DHCP.thumb.png.3a693119ccd9ba977108dc5111e80cf8.png

Lien à poster
Partager sur d’autres sites

Essaie de régler sur la première ou la dernière option, pas la deuxième (qui est le choix par défaut si je me souviens bien).

C'est dans Settings -> DNS dans Pi-hole

pihole-dns-listenning-2.png

Je ne m'explique pas sinon pourquoi ton routeur utilise les DNS du DHCP, ça n'a aucun sens.

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites
il y a 1 minute, .Shad. a dit :

Essaie de régler sur la première ou la dernière option, pas la deuxième (qui est le choix par défaut si je me souviens bien).

C'est dans Settings -> DNS dans Pi-hole

pihole-dns-listenning-2.png

il était sur le premier chez moi... Je l'ai mis sur le dernier. On va voir 🙂

 

En tout cas, c'est vraiment bizarre tout ça. merci de t’être penché sur le sujet 🙂

 

Lien à poster
Partager sur d’autres sites

Bonjour,

la dernière manipulation n'a rien donnée.

J'ai installé AdGuard et c'est le même problème. Donc, ça vient bien de mon routeur.

Maintenant, je ne sais pas si c'est mieux de garder AdGuard ou remettre Pi-Hole

Lien à poster
Partager sur d’autres sites

Tu peux toujours utiliser le DHCP du NAS à la place de celui du routeur, il est très complet.
Le problème a l'air de venir du routeur, mais c'est quand même très étrange, j'ai un peu regardé sur le net on ne voit pas vraiment de retour concernant un taux de défaillance de ce modèle.

Pour le choix d'Adguard ou Pi-hole, ils sont très similaires dans leurs fonctionnalités, c'est une question de goût.

Lien à poster
Partager sur d’autres sites

Je mets mon grain de sel:

As tu essayé de mettre l'adresse fixe du PI-Hole en dehors de la fourchette d'attribution d'adresse par le DHCP du routeur ?

Je dis ceci car il me semble curieux d'affecter un bail fixe dans cette fourchette tous les miens sont en dehors.

Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Jeff777 a dit :

Je mets mon grain de sel:

As tu essayé de mettre l'adresse fixe du PI-Hole en dehors de la fourchette d'attribution d'adresse par le DHCP du routeur ?

Je dis ceci car il me semble curieux d'affecter un bail fixe dans cette fourchette tous les miens sont en dehors.

mon DHCP commence à 10 et mon n'as est sur l'IP 5 😉

Lien à poster
Partager sur d’autres sites

Je te parlais de ceci :

Capture.JPG.c962036c5cfc735e5bda754acca1d61a.JPG

Le DNS1 c'est l'adresse du pi-hole je suppose et il est dans la fourchette 192.168.1.10  192.168.1.254. Mais peut-être ne peux tu pas attribuer d'IP statique en dehors de la fourchette.

Voilà ce que j'ai :

Capture2.JPG.535bf76a5c920631c81e53fdc77f54c5.JPG

Les DNS sont à l'extérieur de la fourchette comme d'ailleurs toutes les IP statiques

 

Lien à poster
Partager sur d’autres sites

C'est une bonne nouvelle pour la résolution du problème.
Et une mauvaise nouvelle pour toi.

C'est franchement honteux de la part de Linksys (Cisco), car en gros ils ont confondu les DNS envoyés par le serveur DHCP avec les DNS du routeur (dont l'IP est fixé et n'est pas soumis au serveur DHCP).
On parle de Cisco, qui fait passer des certifications réseaux. 😄 😄 😄 

Bon, pour revenir à ton souci, tu as 3 solutions :
- utiliser le serveur DHCP du NAS (je testerais ça dans un premier temps à ta place), mais ça implique un uptime très important de ton NAS.
- utiliser ta borne Airport Extreme comme routeur à la place du Linksys (et utiliser ce dernier en tant que point d'accès sans fil).
- changer de routeur.

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.