This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

toutnickel

Demande info sur https et certificat

Messages recommandés

Bonjour,

j'ai ce message quand j'accède au NAS aussi bien en local que par l’extérieur en https  : "Le certificat de sécurité de ce site web présente un problème."

mon port https est bien redirigé dans le routeur , la case dans "Réseau/paramètres DSM"  est coché "redirigé automatiquement ..... 

reste côté certificat peut être ??

une explication ?, une idée , une solution peut-être ??

merci de vos commentaires

a+

Modifié par toutnickel

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

je ne sais pas si je suis au bon endroit ..... pour ce post.

j'ai ce message quand j'accède au NAS aussi bien en local que par l’extérieur en https  : "Le certificat de sécurité de ce site web présente un problème."

mon port https est bien redirigé dans le routeur , la case dans "Réseau/paramètres DSM"  est coché "redirigé automatiquement ..... 

reste côté certificat peut être ??

une explication ?, une idée , une solution peut-être ??

merci de vos commentaires

a+

Modifié il y a 9 heures par toutnickel

Modifié par Mic13710
Sujet fusionné avec celui d'hier sur le même problème. Merci de ne pas multiplier les posts.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Je pense être dans le même cas que toi. Dans ta barre d'adresse url l'https doit être rouge comme moi.

En fait, d'après ce que j'ai pu lire sur internet, c'est du au fait qu'il faut faire une demande de signature de certificat CSR, mais ceci est payant.

Je ne sais pas si je dis vrai mais c'est ce que j'ai compris.

En espérant que cela puisse t'aider.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

non avant ma mise a jour en 6.02,  j'avais un certificat auto-signé et ça fonctionnait bien en https, mais je ne me rappelle plus de la manip et est-ce bien la bonne solution à utiliser ?

merci

a+

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour et merci pour la réponse

Super, c'est bien ce que je cherchais, d'après toi :

1 -  il vaut mieux créer un certificat "Let' Encryp" ou créer un certificat "Auto-signé" ?

2 - Comme nom de domaine, je passe par DDNS "synology.me" je mets donc comme nom de domaine "monnas.synology.me" 

3 - Comment ça se passe avec quick -onnect ?

Merci

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour pouvoir créer votre propre certificat auprès de let's encrypt ou autre, il faut avoir un nom de domaine. Synology.me ne peut pas être utilisé.

Vous pouvez obtenir un nom de domaine très facilement, par exemple chez OVH (moins de 10€/an).

Sinon, il ne vous reste que la solution du certificat autosigné qu'il faut ensuite porter vers les clients. Si vous n'avez que des utilisateurs connus, ce n'est pas un problème. Si vous avez des utilisateurs anonymes (site web par exemple), ce n'est pas une bonne solution et il est préférable de passer par le nom de domaine.

Je n'utilise pas quickconnect (trop lent et surtout sécurité douteuse). Quickconnect n'est qu'un service de connexion. Le certificat s'applique uniquement entre les deux points terminaux.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,
Je n'ai pas mon NAS sous la main ... mais j'ai un certificat Let's Encrypt et je n'ai pas d'autre nom de domaine que celui de synology.


(Rédigé sous Tapatalk)

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est surprenant qu'un organisme de certification autorise l'utilisation de noms de domaines tiers. Ceci dit, pourquoi pas. Perso, j'ai un nom de domaine aussi je n'ai pas eu à utiliser une adresse synology.me pour mes certificats. Je suis tout de même dubitatif qu'on puisse certifier un domaine dont on n'est pas le propriétaire.

A l'époque où j'utilisais les certificats de StartSSL, il fallait non seulement un nom de domaine perso mais aussi une adresse email (webmaster, postmaster etc..) sur le domaine sans quoi je ne pouvais pas obtenir de certificat.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

j'ai créer un certificat  let's encrypt  avec monnas.synology.me

il a été pris en compte sans problème, j'ai ensuite coché la case rediriger vers https .....

et de l’extérieur en accédant par http : j'ai une belle erreur 502 !

ou en ajoutant le port 5000 il est bien redirigé vers 5001 mais avec message d'erreur 
le certificat de sécurité de ce site Web présente un problème.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

oui 

j'ai aussi testé en auto signé,

mais est ce que je remplie bien tous les champs, j'avoue que je ne sais pas trop

en nom de domaine :  monnas.synology.me

courrier electronique : mon adresse mail

autres nom de l'objet : rien mis ou 2eme adresse mail 

Modifié par toutnickel

Partager ce message


Lien à poster
Partager sur d’autres sites

Autre nom de l'objet se rapporte au SAN, c'est à dire les autres noms de domaine rattachés au certificat.

Si vous avez un domaine toto.fr, les autres noms peuvent être bibi.toto.fr, titi.toto.fr etc...

Vous laissez la case vide. De toute manière, s'il y a une erreur, vous ne pourrez pas obtenir de certificat.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

ton certificat let's encrypt ne sera jamais valide si tu le fait avec xxxx.synology.me,

pour cause synology.me ne t'appartiens pas et donc aucune autorité de certification ne confirmera sa légitimité,

synology à probablement un certificat wilcard dont ton sous domaine n'y est pas présent, logique !

Dans le cas de l'auto-signé pareil, pour les autorités de certification il n'existe pas vu que auto-signé,

sauf si tu passe par une demande de certification de celui-ci.

Cependant, si c'est juste faire reconnaitre ton certificat uniquement pour ton propre usage,

sous firefox fait reconnaitre le certificat serveur dans son magasin de certificats

sous google chrome ou chromium pareil.

sauf que pour google chrome qui se base sur les parametres d'internet explorer,

tu dois aussi inserer ton certificat dans le magasin de certificats de windows,

vu que chrome va verifier aussi a cet endroit.

pour microsoft edge , aucune idée je ne l'utilise pas donc à verifier !

Cordialement

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, toutnickel a dit :

j'ai bien un nom de domaine, mais déjà utilisé pour mon site web chez un hébergeur

Vous pouvez toujours créer un nom de domaine pour votre réseau. Par exemple toto.mondomaine que vous dirigez sur votre adresse IP publique (si elle est fixe) ou votre ddns.

Vous utilisez ensuite cette adresse pour créer votre certificat. C'est toujours mieux que de passer par synology.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, jjwil a dit :

Bonjour,

ton certificat let's encrypt ne sera jamais valide si tu le fait avec xxxx.synology.me,

pour cause synology.me ne t'appartiens pas et donc aucune autorité de certification ne confirmera sa légitimité,

Cordialement

Et pourtant, je ne dispose que d'un nom de domaine générique en myds.me, et j'ai bien obtenu un certificat valide de la part de Let's Encrypt.

Modifié par StéphanH

Partager ce message


Lien à poster
Partager sur d’autres sites

pour le certificat, oui moi aussi je l'ai obtenu, mais pour accéder en https de l’extérieur, ca ne fonctionne pas !

est ce que chez toi ou de l'extérieur tu accède en https ?

 

Modifié par Lucien77
Inutile de citer le post précédent

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 16/03/2017 à 08:52, Mic13710 a dit :

C'est surprenant qu'un organisme de certification autorise l'utilisation de noms de domaines tiers. Ceci dit, pourquoi pas. Perso, j'ai un nom de domaine aussi je n'ai pas eu à utiliser une adresse synology.me pour mes certificats. Je suis tout de même dubitatif qu'on puisse certifier un domaine dont on n'est pas le propriétaire.

Il y a 19 heures, jjwil a dit :

ton certificat let's encrypt ne sera jamais valide si tu le fait avec xxxx.synology.me,

pour cause synology.me ne t'appartiens pas et donc aucune autorité de certification ne confirmera sa légitimité,

C'est un certificat DV (domain validation), la seule chose qui est testée c'est le nom de domaine (toto.truc.chose) => en fonction du type de test effectué par l’émetteur du certificat, un DynDNS peut très bien marcher (dans le cas de LE, ils font juste une requête sur le port tcp 80, donc c'est faisable si le quota pour la zone n'est pas atteint).

Les seuls certificats qui valident réellement l'organisation sont les certificats OV et EV.

nb : un dyndns est un nom de domaine comme les autres, la seule et unique différence technique c'est qu'on n'a pas la main sur toute la zone, mais seulement sur une poignée d'enregistrements A

---

Pour en revenir à la question, dans la liste des certificats sur nas, supprime celui installé par défaut et ne laisse que ton certificat "monnas.synology.me"

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, StéphanH a dit :

Je crois Fenrir que DSM n'autorise pas la suppression du certificat autosigné présent par défaut.

Si, en tout cas en DSM 5.0, 5.2 et 6.0 ça ne posait aucun problème du moment qu'il y en avait un autre (chez moi il n'y a qu'un seul certificat depuis des années, mon wildcard)

Et au pire, il faut juste changer les assignations du certificat en cliquant sur "Configurer" après avoir sélectionné le certificat.

Modifié par Fenrir

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok. vous avez surement raison. 

J'étais tombé sur un message d'erreur en voulant supprimer le certificat auto-signé, mais peut être n'avais-je pas encore déclaré celui de Let's Encrypt comme étant le certificat par défaut... je ne suis plus sûr ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

pour info
le certificat "synology.com"  auto-signé était je pense mon ancien certificat version DSM 5.xx- xxx

j'ai été dans configuré et j'ai juste modifié une entrée dans la liste des services,
le service nommé "par défaut"  avait le certificat "synology.com" en fait tous les services ont la même chose "synology.com"
j'ai modifié le certificat de ce service nommé "par défaut" avec le certificat "synology.com"
et j'ai  sélectionné dans la colonne certificat, mon certificat "monnas.synology.me"

En Interne
et en tapant https://monnas.synology.me:5001 ça fonctionne, 
j'ai coché la case dans "réseau" puis "parametre DSM" redirigé automatiquement http vers https .. et ca fonctionne aussi.
 

En externe
je testerai demain de chez un copain

par contre j'ai une question: voir copie d'écran
tous les services on le certificat "synology.com" comme j'ai modifié le service "par défaut" est-ce que cela n'aura pas d'impact ?

dois-je le supprimé mon ancien certificat autosigné, revu et modifié avec la mise à jour ?

 

certificat3.jpg.e8f0ca5b02583f975b70ec2370e6b6dd.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant