This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

nico1375

Installation De Tiny Tiny Rss (Tt-Rss) Sur Un Ds1511+

Messages recommandés

Bonjour

Vu que google reader va fermer et que je ne vis pas sans les news, j'ai décidé d'installer tiny tiny rss sur mon syno.

Pour le moment cela ne fonctionne pas.

Voici ce que j'ai fait :

J'ai dézippé l'archive de tt-rss dans /volume1/web.

J'ai donc --> /volume1/web/ttrss et à l'intérieur tous les fichiers de l'archive.

Ouverture d'un port sur mon routeur --> ça c'est bon.

Creation d'un virtualhost via le dsm (services web --> hote virtuel avec comme infos :

-nom du repertoire : ttrss

-nom d'hote : monnomdhote.com

-protocole : HTTP

-port : 7004

Fichier de conf apache : /usr/syno/apache/conf/httpd.conf-user

J'ai fait des modifs...

J'ai ajouté :

LoadModule proxy_module modules/mod_proxy.so

LoadModule proxy_connect_module modules/mod_proxy_connect.so

LoadModule proxy_http_module modules/mod_proxy_http.so

J'ai décommenté :

# Virtual hosts

Include conf/extra/httpd-vhosts.conf

A la fin du fichier j'ai le bloc :

<VirtualHost *:80>

Include /usr/syno/etc/sites-enabled-user/*.conf

</VirtualHost>

Evidemment dans /usr/syno/etc/sites-enabled-user j'ai des fichiers de conf pour photostation et audiostation mais pas ttrss.

J'ai laissé : ServerName *:80 --> dois-je remplacer par ServerName monnomdhote.com:80 ?

J'ai également créé le fichier /usr/syno/apache/conf/extra/httpd-vhosts.conf qui contient :

Listen 7004

NameVirtualHost *:7004

<VirtualHost *:7004>

DocumentRoot /var/www/ttrss

ServerName monnomdhote.com/ttrss

<Directory /var/www/ttrss/>

Options FollowSymLinks MultiViews

AllowOverride All

Order allow,deny

allow from all

</Directory>

ErrorLog /var/log/apache2/ttrss_error.log

CustomLog /var/log/apache2/ttrss_access.log combined

</VirtualHost>

Bien sûr j'ai redémarré apache plusieurs fois entre chaque essai via

/usr/syno/etc.defaults/rc.d/S97apache-sys.sh restart

Qu'est-ce qui me manque? Quand je tape dans mon navigateur monnomdhote.com:7004 ou monnomdhote.com/ttrss je n'y arrive pas, comme si il n'y avait pas de site.

Merci

Modifié par nico1375

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

Vu que google reader va fermer et que je ne vis pas sans les news, j'ai décidé d'installer tiny tiny rss sur mon syno.

Pour le moment cela ne fonctionne pas.

Voici ce que j'ai fait :

J'ai dézippé l'archive de tt-rss dans /volume1/web.

J'ai donc --> /volume1/web/ttrss et à l'intérieur tous les fichiers de l'archive.

Ouverture d'un port sur mon routeur --> ça c'est bon.

Creation d'un virtualhost via le dsm (services web --> hote virtuel avec comme infos :

-nom du repertoire : ttrss

-nom d'hote : monnomdhote.com

-protocole : HTTP

-port : 7004

Fichier de conf apache : /usr/syno/apache/conf/httpd.conf-user

J'ai fait des modifs...

J'ai ajouté :

LoadModule proxy_module modules/mod_proxy.so

LoadModule proxy_connect_module modules/mod_proxy_connect.so

LoadModule proxy_http_module modules/mod_proxy_http.so

J'ai décommenté :

# Virtual hosts

Include conf/extra/httpd-vhosts.conf

A la fin du fichier j'ai le bloc :

<VirtualHost *:80>

Include /usr/syno/etc/sites-enabled-user/*.conf

</VirtualHost>

Evidemment dans /usr/syno/etc/sites-enabled-user j'ai des fichiers de conf pour photostation et audiostation mais pas ttrss.

J'ai laissé : ServerName *:80 --> dois-je remplacer par ServerName monnomdhote.com:80 ?

J'ai également créé le fichier /usr/syno/apache/conf/extra/httpd-vhosts.conf qui contient :

Listen 7004

NameVirtualHost *:7004

<VirtualHost *:7004>

DocumentRoot /var/www/ttrss

ServerName monnomdhote.com/ttrss

<Directory /var/www/ttrss/>

Options FollowSymLinks MultiViews

AllowOverride All

Order allow,deny

allow from all

</Directory>

ErrorLog /var/log/apache2/ttrss_error.log

CustomLog /var/log/apache2/ttrss_access.log combined

</VirtualHost>

Bien sûr j'ai redémarré apache plusieurs fois entre chaque essai via

/usr/syno/etc.defaults/rc.d/S97apache-sys.sh restart

Qu'est-ce qui me manque? Quand je tape dans mon navigateur monnomdhote.com:7004 ou monnomdhote.com/ttrss je n'y arrive pas, comme si il n'y avait pas de site.

Merci

Perso, pour mon reverse proxy, j'avais gerer ca dans /usr/local/etc fichier reverse-proxy.conf et rajouter un include dans /usr/syno/apache/conf/httpd.conf-user (Include /usr/local/etc/reverse-proxy.conf en bas du fichier avec une ligne vide pour finir le document) + dans /etc.default idem.

Partager ce message


Lien à poster
Partager sur d’autres sites

Jette un œil au reverse proxy sur ce site, tout est détaillé concernant les virtual hosts

Y a plein de doc sur le reverse proxy. Tu peux etre plus precis stp?

--> laisse tomber je viens de voir le tuto de coolraoul :)

Modifié par nico1375

Partager ce message


Lien à poster
Partager sur d’autres sites

Par contre je suis emmerdé, photo station ne se lance plus. Je pense que j'ai merdé quelque part la conf d'apache...

Y a un moyen de revenir a la configuration d'origine pour apache?

Sinon audio et video station fonctionnent, de meme que la petite tribu sabnzbd, sickbeard, etc...

Modifié par nico1375

Partager ce message


Lien à poster
Partager sur d’autres sites

Par contre je suis emmerdé, photo station ne se lance plus. Je pense que j'ai merdé quelque part la conf d'apache...

Y a un moyen de revenir a la configuration d'origine pour apache?

Sinon audio et video station fonctionnent, de meme que la petite tribu sabnzbd, sickbeard, etc...

En supprimant ta modif et si tu as pas toucher à ETC.DEFAULTS si je dit pas de bétise quand tu redémarre sans te recharge la config par défaut?

Modifié par djinn13800

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est fait ça ne fonctionne toujours pas... le syno assistant le voit sur le LAN mais je ne peux pas me connecter. faut faire quoi? reinstaller tout le DSM? y a moyen de recuperer tous les parametres via telnet ou ssh?

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est fait ça ne fonctionne toujours pas... le syno assistant le voit sur le LAN mais je ne peux pas me connecter. faut faire quoi? reinstaller tout le DSM? y a moyen de recuperer tous les parametres via telnet ou ssh?

Avant d'en arriver là, y'a bien quelqu'un qui doit avoir le fichier original à te transmettre :)

(Je suis encore en DSM 4.0, donc çà sera pas moi :()

Modifié par bud77

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis intéressé aussi pour installer TT-Rss. Par contre je n'ai pas compris l'intérêt de tout ce que tu as fait. Pourrais-tu expliquer ? Pourquoi les Virtual Hosts ?

Moi il m'a demandé de désactiver "open_basedir", j'ai donc posé un .htaccess dans le répertoire de tt-rss contenant "php_admin_value open_basedir none", mais le syno me dit ensuite que ma page est introuvable... (d'autres outils web utilisant open_basedir, je ne peux le désactiver dans la config de php...)

Quelqu'un arrive à avancer sur l'installation ?


Modifié par klorydryk

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Ca y est j'ai fini par tout faire fonctionner en local

Pour open_basedir:

dans ../include/sanity_check.php commenter les lignes 88, 89, 90.

Pour l'actualisation des feeds:

A ajouter a contrab:

*/15	*	*	*	*	root	cd /volume1/web/rsstiny/ && /usr/bin/php /volume1/web/rsstiny/update.php -feeds >/dev/null 2>&1 > /volume1/log.log 2>&1

> /volume1/log.log 2>&1 peut-être supprimé c'était juste en test car je me suis trouvé avec une erreur:

Please don't run this script as root

Résolue en commentant les lignes 19, 20, 21 dans ../include/sanity_check.php

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour ma part je suis bloqué ici:

root@fserv> /bin/su nobody -s /bin/sh -c "cd /volume1/web/ttrss && php update.php"
PHP Fatal error:  Call to undefined function mb_internal_encoding() in /volume1/web/ttrss/include/functions.php on line 19
Fatal error: Call to undefined function mb_internal_encoding() in /volume1/web/ttrss/include/functions.php on line 19 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, j'avance: seul le compte "root" à acces à "/usr/syno/etc/php/extension.ini" (pourquoi donc?)

root@fserv> ls -ld /usr/syno/etc/php/extension.ini
-rw------- 1 root root 649 2012-04-18 19:48 /usr/syno/etc/php/extension.ini

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Partage d'expérience.

Après l'annonce de Google j'ai comme beaucoup de personnes cherché des alternatives.

Quel ne fut pas ma surprise quand j'ai aprît que nos "petits" (ou grands:-) pour certains) serveurs pouvais gérer "des" agrégateur RSS.

J'ai installé Leed, très simple (garantie en 1 heure, je suis vraiment pas expert) avec le tuto de "Vladrow".

Je sais pas trop encore ce que ça veux dire en espace mémoire occupé pour le moment............

L'interface est très simple et propre (c'est ce qu'on demande non?).

Sur les tablettes ou Smartphones il faut consulter avec le navigateur en HTML pour le moment, avec l'arrêt de "google reader" je parie que des "lecteurs RSS" vont apparaître pour ce type d'appli.

Bref si vous êtes un inconditionnel des RSS je vous conseille de tester.

Pour info je ne suit que 19 fil RSS, j'imagine que les gens qui en suivent beaucoup plus pourraient trouver la gestion des fil trop "simple" sur Leed.

A essayer.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement