This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Kawamashi

[Tuto] Reverse Proxy

Messages recommandés

Je me rappelle avoir lu de Fenrir dans son tuto sur la sécurité qu'activer le HSTS est une mauvaise idée.
De souvenir, ça indiquait à ton navigateur d'aller directement sur la page HTTPS.
J'ai bien conscience que ce n'est pas la nature de ton problème ici, mais tu devrais peut-être essayer avec un autre navigateur voir si tu obtiens le même résultat.
De plus il y a une option dans DSM permettant de rediriger les requêtes HTTP vers HTTPS, est-ce que d'une manière ou d'une autre ça n'interfère pas dans ton cas ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui shadowking a raison concernant le HSTS, il faut décocher. 

il y a 21 minutes, shadowking a dit :

option dans DSM permettant de rediriger les requêtes HTTP vers HTTPS

ça c'est sûr il ne faut pas l'utiliser..

Pour le .htaccess  oui tu peux t'en passer.  Le http (ou l'adresse sans rien devant) ne fonctionnera pas et il faudra systématiquement mettre le  https. 

Maintenant pourquoi le reverse proxy ne fonctionne pas ? Il devrait. Essaie de remplacer 192.168.0.10 par localhost. Le port 7000 est bien déclaré comme port http de FileStation ?

Sinon je ne vois pas. Vous êtes au moins 3 en ce moment sur ce forum à avoir des pb avec un domaine OVH. Une épidémie 🤢

Partager ce message


Lien à poster
Partager sur d’autres sites

Je bloque à l'étape de la configuration du domaine chez le registar ! Impossible de créer le CNAME comme dans ton tuto

Chez moi, j'ai le message d'erreur La structure du champ Target pour une entrée de type CNAME est invalide. si la cible est *.monnomdedomaine.ch

Ou alors Il n'est pas autorisé de faire une entrée de type CNAME directement à la racine de la zone. si la cible est monnomdedomaine.ch

Je ne sais pas comment l'écrire ! Merci pour vôtre aide !

 

Modifié par Jules Perrelet

Partager ce message


Lien à poster
Partager sur d’autres sites

Si IP fixe, Il faut un enregistrement A qui pointe vers votre IP publique. Si IP dynamique, il faut activer le DDNS soit chez votre Registar (le plus simple s'il propose ce service), soit chez un provider de service dynhost. Il faut aussi activer et synchroniser le DDNS sur le NAS. Cet enregistrement A ou DDNS se fait sur le ndd (pas sur *.ndd), ou du moins sur le domaine que vous avez choisi pour votre projet (ça peut très bien être toto.ndd).

Une fois validé, vous pouvez créer votre enregistrement CNAME wildcard : *.ndd (ou *.toto.ndd)

Si ça ne fonctionne pas, il est possible que le wildcard ne soit pas autorisé. Quel est votre registar ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'y suis finalement parvenu, la où je bloque, c'est dans la configuration des ports du routeur. J'ai un D-Link dir809, dont la config ne ressemble pas à ce que j'ai pu trouver sur le net. Pensez-vous que la configuration telle que sur la capture d'écran ci-dessous est correcte ?

 

Capture d’écran 2019-05-26 à 17.27.49.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne connais pas ce routeur, mais il semblerait que vous ne soyez pas sur la bonne page.

Selon ce site : https://portforward.com/d-link/dir-809/ celle que vous utilisez concerne les plages de port et non pas les ports individuels. Il faut aussi valider vos entrées (check box à gauche).

Je cite :

 

This router has two different sections that allow you to forward ports. One section allows you to forward a range of ports, and the other allows you to forward a single port. To forward a range of ports, click Port Forwarding. To forward a single port, click Virtual Server.

Forwarding a Port Range

Put a checkmark in the Enable checkbox.

Put a name for this forward in the Name box so that you can remember why you set this forward up. The name does not matter so pick something that has meaning to you.

Enter the IP address of the device that you want to forward ports to into the IP Address box. This can be either the IP address of your computer or the IP address of another device on your network.

If you are forwarding a range of ports, enter the lowest number of that range into the left hand Public Port and Private Port boxes. Then enter the highest number of that range into the right hand Public Port and Private Port boxes.

If you are forwarding a single port, enter that port number into both of the Public Port and both of the Private Port boxes.

From the Traffic Type dropdown box choose Any.

Forwarding a Single Port

Make sure that the Enable checkbox is checked.

Create a name for this forward and put it in the Name box. The name is only used as a reminder and has no effect on the port forward.

Enter the IP address to forward these ports to into the IP Address box. If you are forwarding ports so you can run a program on a device other than your computer then you can enter your device's IP address into that box.

Enter the same port number to be forwarded into the Public Port and the Private Port boxes.

From the Traffic Type dropdown box choose Any.

When you are finished be sure to click the SAVE SETTINGS button at the top of the page.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

192.168.0.104 est je suppose l'adresse fixe de ton NAS. Je ne connais pas le routeur TP link mais ne faut-il pas que les cases à gauche soit cochées avant de sauvegarder la config   pour que la règle soit effective ?

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Citation

Selon ce site : https://portforward.com/d-link/dir-809/ celle que vous utilisez concerne les plages de port et non pas les ports individuels. Il faut aussi valider vos entrées (check box à gauche).

Ca me parait bon moi mais j'ai pas son routeur donc je peux pas confirmer.

Je  cîte :

Citation

This takes you to the page you see above. Select the option in the left sidebar labeled Port Forwarding.

 

Port%20Forwarding.jpg

You are now on the correct page to make a port forward entry.

Step 4

Here are the ports to forward for Xbox Live:

TCP Ports: 3074
UDP Ports: 3074

If you are looking for the ports for a different application you can find it by either:

Citation

Je ne connais pas le routeur TP link mais ne faut-il pas que les cases à gauche soit cochées avant de sauvegarder la config   pour que la règle soit effective ?

En effet, pas fait gaffe à ça mais il faut qu'elles soient activées sinon les ports ne pourront pas s'ouvrir.

Modifié par Zeus

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, Zeus a dit :

Ca me parait bon moi mais j'ai pas son routeur donc je peux pas confirmer.

Moi non plus, cependant, le lien que je donne ainsi que la citation sont assez clairs : ce routeur fait la différence entre plages de ports et simple port. Et il faut bien entendu valider les entrées pour qu'elles soient prises en compte.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 21/05/2019 à 22:01, shadowking a dit :

Je me rappelle avoir lu de Fenrir dans son tuto sur la sécurité qu'activer le HSTS est une mauvaise idée.
De souvenir, ça indiquait à ton navigateur d'aller directement sur la page HTTPS.
J'ai bien conscience que ce n'est pas la nature de ton problème ici, mais tu devrais peut-être essayer avec un autre navigateur voir si tu obtiens le même résultat.
De plus il y a une option dans DSM permettant de rediriger les requêtes HTTP vers HTTPS, est-ce que d'une manière ou d'une autre ça n'interfère pas dans ton cas ? 

bonjour shadowking,

bien vu, c'est bien cette option de redirection qui pose problème : je l'ai désactivée, et maintenant toutes mes requêtes fontionnent correctement !

merci à tous de votre aide, et à la prochaine !

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci à tous pour vos réponses. J'ai paramétré mon serveur D-Link selon vos recommandations, et ça donne ça

769532517_Capturedecran2019-05-27a22_31_51.thumb.png.db0a285aa5472e7c1ca37a06dfdb9368.png

Du côté du registar, ça donne ça :

341543549_Capturedecran2019-05-27a22_33_52.thumb.png.96dbd4ef80bf76ee9b31567753bc2c35.png

Et les règles de reverse-proxy donne ça (j'ai mis que les paramètres pour file station pour le moment)

1142841672_Capturedecran2019-05-27a22_37_30.thumb.png.752d6b7767f86ccda180bb12ba8d5678.png

Pour le moment, je ne parviens pas à me connecter à monnomdedomaine.ch ni à fichiers.monnomdedomaine.ch. Pensez-vous que ça pourrait avoir un lien avec le fait que j'ai une adresse IP fixe, alors que dans la config de mon routeur, il y a plutôt "IP dynamic" dans "internet connection type" ? Merci encore pour votre aide !

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, Zeus a dit :

Es-tu sûr d'avoir une IP fixe ?

Ton domaine redirige sur quoi exactement là ?

 

J'ai l'impression, c'est du moins ce que me dit mon-ip.com (et elle n'a pas changé depuis une semaine bientôt). Quand je lance mon domaine, j'ai une erreur ERR_EMPTY_RESPONSE de la part de google. 

Partager ce message


Lien à poster
Partager sur d’autres sites

mon-ip.com dit n'importe quoi pour info 😉

De mon côté, il dit ip-dynamique alors que je suis en IP fixe...

Et je sais que tu es chez Swisscom et en faisant quelques recherches, j'ai vu des sujets récents sur le forum de ce dernier ou les résidents ne pouvaient pas avoir d'IP fixe et que pour les professionnels, c'était une option payante.

Renseigne toi auprès de ton opérateur 😉

Si tu es comme je le pense en dynamique alors tu devrais passer par un service DDNS. Je ne sais pas si Infomaniak le fait !

Partager ce message


Lien à poster
Partager sur d’autres sites

Est-ce que cette IP est full stack, c'est à dire qu'elle peut utiliser tous les ports ?

il y a 8 minutes, Zeus a dit :

Si tu es comme je le pense en dynamique alors tu devrais passer par un service DDNS.

C'est vrai. Cependant, si l'enregistrement A pointe sur l'IP active (ce qui semble être le cas), ça devrait fonctionner.

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors j'ai appelé mon fournisseur d'accès, Swisscom : effectivement, pas d'IP fixe pour les particuliers. 

Et j'ai contacté InfoManiak : pas de service de DDNS

Du coup, ma question est : faut-il transférer son nom de domaine sur une entreprise qui offre le DDNS, ou bien faut-il rester chez InfoManiak et trouver un service qui fasse le DDNS ? 

Le site libellules propose un tuto sur comment se faire un DDNS (https://www.libellules.ch/dns_dynamique.php). C'est gratuit, et à la fin il y a un listing d'autres offres similaires (gratuites également). Est-ce fiable ou bien faut-il investir dans un service payant ?

Modifié par Jules Perrelet

Partager ce message


Lien à poster
Partager sur d’autres sites

Il me semble que lorsque j'étais chez Numéricable (pas d'adresse fixe), j'avais utilisé le DDNS de synology pour avoir une adresse du style xxx.synology.me qui pointe vers mon adresse externe et j'avais enregistré chez mon fournisseur de domaine (bookmyname) un enregistrement CNAME qui pointait vers mon adresse en www.synology.me, et ça fonctionnait.

Modifié par dd5992

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 15 minutes, dd5992 a dit :

Il me semble que lorsque j'étais chez Numéricable (pas d'adresse fixe), j'avais utilisé le DDNS de synology pour avoir une adresse du style xxx.synology.me qui pointe vers mon adresse externe et j'avais enregistré chez mon fournisseur de domaine (bookmyname) un enregistrement CNAME qui pointait vers mon adresse en www.synology.me, et ça fonctionnait.

1686369131_Capturedecran2019-05-28a13_09_12.thumb.png.aea9a0fec2751008961ca4aa86b6613d.png

J'ai donc créé un DDNS avec Synology, et créé un enregistrement CNAME qui pointe vers ce dernier. J'espère avoir fait juste 😄

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est ça!

Il faut attendre que la propagation ait lieu. Tu peux tester avec nslookup pour voir si tu récupères bien ton adresse externe actuelle.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, dd5992 a dit :

C'est ça!

Il faut attendre que la propagation ait lieu. Tu peux tester avec nslookup pour voir si tu récupères bien ton adresse externe actuelle.

Désolé de vous emmerder avec ça, mais ça ne fonctionne toujours pas chez moi 😞 

811441286_Capturedecran2019-05-28a16_19_54.png.1280d404e288b68770e52efd65b2df6d.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

La propagation tu peux la tester avec cette adresse :

https://www.whatsmydns.net/

Le nslookup je le fais avec l'adresse locale du NAS en 192.168.x.x

Je viens de faire avec localhost et pour moi ça ne fonctionne pas non plus !

D'ailleurs il te dit qu'il ne fait pas autorité.

Modifié par Jeff777

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement