This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

alan.dub

VPN Server sous iOS 13 et ipv6

Messages recommandés

Bonjour,

Depuis la mise à jour d’iOS 13, orange a basculé nos IP 4G de ipv4 à ipv6.

D’après les dernières info que j’ai pu trouver sur le web et ici même, ce passage en ipv6 aurait la fâcheuse tendance à bloquer le connexion VPN au VPN Server.

En effet, impossible depuis de me connecter en L2TP... alors que ça fonctionnait très bien sous iOS 12.

J’ai bien tenté l’OpenVPN sur le NAS avec l’app OpenVPN Connect sur iOS mais rien n’y fait 😞 

Pire, impossible de me connecter, comme si mon identifiant et mot de passe était erroné alors qu’aucune information de connexion sur le NAS n’est indiquée (via le journal).

Pour info, j’ai des options ipv6 sur la Freebox et sur le NAS de désactivées, dois-je les activer ?

Je demande avant parce que... j’aimerais éviter de tout bloquer comme un couillon (mail server and co) ^^ 

 

Bref, si vous avez quelques astuces, je suis à votre écoute 😞
 

INFO SUR IPV6 :

https://www.supinfo.com/articles/single/3939-creer-son-propre-serveur-vpn-avec-nas-synology

Modifié par alan.dub

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

iOs 13.1.1 et c'est pareil: plus de VPN.

Avec openvpn je peux me connecter mais c'est tout, 

je n'ai pas accès aux applications ni au LAN.

En 4G le journal de connexion de VPN server détecte l'iPhone avec une ip V4...

En L2tp/Ipsec ça ne connecte pas du tout.

(je suis chez Orange également et chez Free qui a forcé l'ipv6 sur les box dernièrement)

J'ai pensé tout passer en ipv6 mais je ne suis pas prêt (pb de compréhension).

Modifié par pluton212+

Partager ce message


Lien à poster
Partager sur d’autres sites

Mais alors qui bloque qui dans l’histoire ?

Par exemple sur mon iPhone en 4g (donc en IPv6), pas de problème pour me connecter au VPN de NordVPN.

Est-ce à Synology de mettre à jour son VPN Server, ou Apple son iOS ?

Je suis un peu perdu moi 😅

D’ailleurs pour la petite histoire si je connecte d’abords mon iPhone (toujours en 4g), à NordVPN (sur un serveur au Luxembourg), puis au VPN du NAS, là ça fonctionne.

Cool... par contre ce qui m’inquiète encore plus c’est que le pare-feu de mon NAS est paramètré pour n’autoriser que le IP venant de la France sur les port du VPN Server (L2TP)... c’est con 😅 

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as des biens non déclarés aux impôts... !!!
on y va tout droit avec les dernières annonces concernant

les réseaux sociaux et les surveillances de Bercy... 🙂

Heureusement que nous sommes dans une démocratie à toutes épreuves 🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

Je veux bien payer des milliard d'impôts moi... mais l'état ne veut pas "me le permettre" 😅

Quand aux réseaux sociaux... c'est bien un "truc" qui m'insupporte 🤬

Modifié par alan.dub

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Pour moi c'est un problème dans iOS13 que devra corriger Apple (encore un, cet OS ayant été sorti précipitamment et non finalisé).

Quelque soit le mot de passe qu'on entre, de toutes façons le message d'erreur est toujours le même et il n'y a aucune trace de tentative de connexion dans le journal VPN Server, donc la connexion L2TP ne sort même pas de l'iPhone je pense, le protocole est cassé en l'état. Je n'ai pas non plus réussi à me connecter en L2TP à un firewall d'entreprise alors que j'y arrivais sous iOS12.

NordVPN ne fonctionnait pas le soir de la sortie d'iOS 13, il a été patché le lendemain et le mode de connexion est passé en IKEv2 qui à priori est fonctionnel.

Modifié par kasimodem

Partager ce message


Lien à poster
Partager sur d’autres sites

Est-ce que l’adresse configurée dans le client VPN est une adresse IPv6 ? (ou un nom de domaine disposant d’une résolution IPv6)

Est-ce que le NAS dispose d’une adresse IPv6 publique ? (en plus de son IPv6 locale fe80::/10)

Est-ce qu’on voit bien les paquets ISAKMP (500/udp) parvenir jusqu’au NAS en utilisant la commande tcpdump sur ce dernier ?

Il y aura probablement d’autres points à vérifier, mais ce sont les premières questions qui me viennent à l’esprit.

Partager ce message


Lien à poster
Partager sur d’autres sites

et la réponse du support

 

After checking on our database, the Synology VPN Server just accepts IPv6 using OpenVPN, it's not possible to use ipv6 using the other protocols:

image.png.e905a99c528310df58556dee2ff0694f.png

I'm sorry for the inconveniences, please do not hesitate to come back if there is anything else I can help you with.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je veux bien mais même en openVPN ça ne veut pas :

J’ai bien tenté l’OpenVPN sur le NAS avec l’app OpenVPN Connect sur iOS mais rien n’y fait 😞 

Pire, impossible de me connecter, comme si mon identifiant ou mot de passe était erroné alors qu’aucune information de connexion sur le NAS n’est indiquée (via le journal).

Et le port 1194 (de mémoire) et bien ouvert sur le NAS et redirigé depuis la box. 

Modifié par alan.dub

Partager ce message


Lien à poster
Partager sur d’autres sites

en IPv4, ton client iOS attaquait l'adresse IPv4 publique de la Box, qui routait le port VPN sur l'adresse privée de ton NAS.

En IPv6, ce n'est plus cela !!! ton client VPN doit directement pointer vers l'adresse IPv6 publique de ton NAS !

Partager ce message


Lien à poster
Partager sur d’autres sites

Donc... je dois aussi :

activer l'IPV6 sur le NAS (IP fixe LAN) et la FreeBOX (IP fixe WAN) ?

- ajouter l'IPV6 de la FreeBOX (fixe publique) chez OVH à l'entrée A ?

- ajouter l'IPV6 du NAS sur mon DNS Server ?

Capture-d-cran-2019-10-04-16-39-48.png Capture-d-cran-2019-10-04-16-39-24.png Capture-d-cran-2019-10-04-16-43-21.png

C'est bien ça ?

Je demande au cas où...

Modifié par alan.dub

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne connais pas la FreeBox, et pas non plus les DNS hors le DDNS de Synology

Mais oui, il faut qu'IPv6 soit activé sur le NAS, et que la case IPv6 soit cochée sur VPN Server / OpenVPN. à partir de là, même sans DNS, si tu rentres dans ton client VPN l' [IPv6] de ton NAS (entre crochets, c'est important), il devrait se passer des choses ...

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai donc :

- Activé l'IPV6 sur le NAS (mode AUTO).

- activé l'openVPN.

- ouvert le port 1194 sur le NAS.

- redirigé le port 1194 vers le NAS depuis la FreeBOX.

Par contre je n'arrive pas à activer l'IPV6 de l'openVPN.

Je peux cocher l'option (ça je sais encore le faire ^^), mais impossible de saisir le préfixe (à 64 sur l'IPV6 du LAN1 du NAS).

 

J'suis bloqué ^^

Partager ce message


Lien à poster
Partager sur d’autres sites

je ne vois pas l'intérêt de rediriger le 1194 depuis la freebox. mais bon, ce n'est pas grave.

J'avoue que je ne sais pas du tout ce qu'il faut saisir dans cette zone ...

et la doc n'évoque même pas l'existence de cette zone ...

Serait-ce le préfixe dont le NAS va se servir pour attribuer des v6 locales aux clients qui se connectent ?

Dans ce cas, je ne sais pas ce que préconise OpenVPN. Un  peu de lecture ? https://community.openvpn.net/openvpn/wiki/IPv6

Modifié par StéphanH

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour les ports... je ne sais pas du tout si c'est la même histoire entre IPV4 et IPV6 (je n'ai pas encore eu le temps de me documenter sur le sujet).

Dans le doute, je fais ce que m'indique DSM à l'activation de l'openVPN.

On va dire que l'IPV6 est arrivé un peu comme un cheveux sur la soupe suite à la MAJ d'iOS.

Pour le préfixe, je suis obligé d'en mettre un, dès que je coche l'option, le champ du préfixe devient modification (blanc) sans pour autant pouvoir indiquer quoique ce soit dedans ^^

Capture-d-cran-2019-10-04-19-19-48.png

Si je clique sur OK sans rien indiquer, DSM ne veut pas.

Obligé de désactiver l'option IPV6... c'est couillon ^^

Modifié par alan.dub

Partager ce message


Lien à poster
Partager sur d’autres sites

Directement vpn plus, d’ailleurs je peux te dire qu’à la connection (j’ai les alertes mail), c’est une ipv4 qui est indiquée, et encore heureux, sinon bien des sites web et des personnes serait inaccessible sans réversibilité.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement