This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

OpenVPN tests débits et optimisation


Messages recommandés

Posté(e) (modifié)

Bonjour,

J'aimerai vos avis et retours d'expérience sur l'utilisation d'un vpn client entre le nas, et un serveur vpn dans le cloud (offre dédié, serveur dédié, etc...)

ma config :

DS220J - openvpn client - connexion Free fibre - box mini 4k

VM Cloud Azure A1v2 (Xeon E5-2673 v4 @ 2.30GHz - AES-NI CPU Crypto: Yes (inactive) - 2Go RAM): serveur PFsense - openvpn serveur - lien 1Gbit/s en dl/up

Un speedtest depuis la connexion Free fibrée, me donne ping = 5ms, dl = 800Mbit/s , up = 600MBits/s

config OpenVPN: no hardware crypto, lzo compression = no

 

résultat des tests de débits entre le Nas et la VM Azure:

avec la connexion VPN:

signal-2021-06-08-152727.thumb.jpg.f35d47e147e84e40a3eb5c694067c859.jpg

 

sans le VPN:

signal-2021-06-08-152847.thumb.jpg.2047a417f43fae444984fc81d54c69ca.jpg

 

La différence est quand même énorme 😞

au niveau des ressources, CPU et Ram ne sont pas saturé sur le Nas et la VM.

coté VM Azure: CPU à 50% max

coté NAS: CPU à 20% max

j'ai testé avec un autre port d'openvpn que celui par défaut(1194), en udp et tcp, avec iperf parallelisé jusqu'à 4 connexions simultanées

 

Avez vous de meilleurs résultats de débits à travers un VPN (quel qu'il soit) ?

Que pourrais je optimiser ?

 

Merci de vos réponses

Modifié par bagou91
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Quel processeur pour ta VM Azure ? OpenVPN est mono-coeur, donc c'est la fréquence du CPU qui va jouer et pas le nombre de cœurs à disposition.

Quel est l'utilisation processeur d'ailleurs de pfSense lors d'un test iperf ? Tu peux voir ça sur la page d'accueil de pfSense dans un des widgets.

Avoir un rapport 3 à 4 sur le débit ne serait pas trop étonnant pour une connexion fibrée. 10 c'est quand même beaucoup, à moins qu'ils aient mis une chèvre à la place du proc. 😄

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

Vérifie aussi dans le widget qui reprend les stats de ton matériel que le jeu d'instructions AES-NI est bien disponible. Sinon c'est le CPU qui endosse tout sur son dos, et il peut très vite arriver à saturation.

Lien à poster
Partager sur d’autres sites

j'utilise une VM Azure A1 v2:

Intel(R) Xeon(R) CPU E5-2673 v4 @ 2.30GHz - AES-NI CPU Crypto: Yes (inactive)

2Go RAM

 

Lors des tests iperf, le cpu ne monte pas plus haut qu'à 50%

J'ai testé avec un autre port d'openvpn que celui par défaut (1194), en udp et en tcp, et iperf parallélisé jusqu'à 4 connexions simultanées.

A chaque fois, vitesse max en dl/up : ~38Mbit/s

Lien à poster
Partager sur d’autres sites
il y a 7 minutes, bagou91 a dit :

Lors des tests iperf, le cpu ne monte pas plus haut qu'à 50%

Bonjour,

Le CPU du NAS ou du VPS?

Lien à poster
Partager sur d’autres sites

Du coup si tu avais déjà testé sans le chiffrement matériel, active l'option comme sur mon impression d'écran.

J'ai vérifié le proc de ta VM est suffisamment puissant pour avoir un débit tout de même correct.

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Étrange, tu devrais peut-être fouiller un peu les forums de Netgate, l'entreprise qui développe pfSense.
Il y a pas mal de sujets qui traitent des débits envisageables via OpenVPN.

Tu as combien de cœurs disponibles sur ta VM ?

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

oui je fouille déjà les forums Netgate et autre résultats google...

pour les coeurs CPU, ce n'est pas très clair au niveau d'Azure: A1v2 = 1vCPU

toujours est-il qu'en observant les statuts des process avec le menu Diagnostic -> System Activity (équivalent à la commande Top), je suis loin de saturer le CPU et OpenVPN ne monte pas à plus de 20% de charge.

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)
Il y a 4 heures, bagou91 a dit :

pour les coeurs CPU, ce n'est pas très clair au niveau d'Azure: A1v2 = 1vCPU

Bonjour,

Donc un cœur.

Mais vCPU ça peut être 1, 2, 4 vCPU par Thread physique. (Donc au mieux un Thread du xeon)

Modifié par maxou56
Lien à poster
Partager sur d’autres sites

Bonjour, @bagou91

Il me semble que d’après tes tests de débit, le débit en VPN est faible mais tu as aussi de nombreux "retr" , ça peut être la connexion tcp  qui n'est n'est pas "propre".

As tu vérifié les réglages de la  "MTU" du client openvpn ? peut être à régler à 1400 ??

 

 

 

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Oui j'ai joué avec le mtu, fragment, mss mais ça n'améliore pas davantage les débits. En amélioration, j'ai un peu moins de retry.

Cela joue peut être auss: le client openvpn est en version 2.3.17, et coté serveur en version 2.5.1

J'ai vu que certaines options n'étaient pas supporté sur la 2.3 par rapport à la 2.5.

Dès que je peux, je vais faire des tests avec un PC client openvpn à coté du NAS...

Modifié par bagou91
Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.