This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Diaoul

Umurmur Spk 1.0

Messages recommandés

Bonjour tout le monde,

Voici mes SPK pour intégrer un serveur Mumble sur votre Syno !

SPK 1.0 avec uMurmur 0.2.9

What's in ?

  • umurmur-0.2.9
  • libconfig-1.4.8
  • polarssl-1.1.1

Comment faire ?

  • Repérez votre architecture en fonction de votre modèle (cf Architectures)
  • Téléchargez le SPK correspondant (cf Téléchargement)
  • Dans DSM connecté en admin :

    • Menu > Gestion des paquets > Installation
    • Sélectionnez le SPK téléchargé
    • Suivant > Appliquer > Ok

    [*]Il faut maintenant configurer votre serveur uMurmur, pour cela vous pouvez :

    • Passer par l'excellent Config File Editor et y ajouter le fichier de configuration de uMurmur pour l'éditer :
      "/usr/local/umurmur/etc/umurmur.conf, umurmur.conf"
    • Connectez-vous en SSH sur le Syno et éditez le fichier /usr/local/umurmur/etc/umurmur.conf à l'aide de nano ou vi.

Changelog :

  • 1.0 :

    • Icônes pour DSM
    • Possibilité de générer de nouveaux certificats en SSH simplement avec /usr/local/umurmur/bin/gencert.sh
    • Privilèges du serveur uMurmur réduits pour plus de sécurité
    • Génération des certificats SSL à l'installation du SPK pour plus de sécurité
    • Mise à niveau de PolarSSL en 0.14.3
    • Meilleure gestion de l'arrêt du SPK

    [*]0.4 : Compatibilité DSM 3.1. Mise à niveau de libconfig et PolarSSL.

    [*]0.3 : Mise à niveau de uMurmur en version 0.2.6

    [*]0.2 : Pour tout le monde ! Plus de problèmes d'architecture incorrecte à l'installation du paquet.

    [*]Première version (builds 11, 14, 15, 16, 17, 18)

Donateurs :

  • Xenok
  • Pilami

Merci de me faire vos retours afin d'améliorer ce SPK !

Pour compiler vous même umurmur, utilisez spksrc.

Enjoy smile.gif

Vous aimez ce SPK ? Offrez-moi une bière !

btn_donateCC_LG.gif

Modifié par Diaoul

Partager ce message


Lien à poster
Partager sur d’autres sites

HO HO !

Ca c'est du cadeau pour la nouvelle annee !! Merci beaucoup, je vais tester ça apres avoir fait un backup complet, je balancerais toutes mes impressions, problemes et autres.

Encore merci et bonne annee !

Partager ce message


Lien à poster
Partager sur d’autres sites

saalut

le 88f628x ne marche pas sur ds210j

j'ai un message lors de l'installation

Your architecture is not supported by this package, sorry.Architecture : 88f6281Synology info : synology_88f6281_210j

bonne soir

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon et bien pas la peine que je l'essaye, j'ai aussi un DS409.

C'est un tort.

Plus il y a de tests, moins il y a d'

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est un tort.

Plus il y a de tests, moins il y a d'énigme pour résoudre les problèmes :)

Oui, j'ai dit une connerie je m'en suis rendu compte ^^

Roulement de tambour !

Et : "Your architecture is not supported by this package, sorry.Architecture : 88f6281Synology info : synology_88f6281_409"

DS409

DSM 3.0-1354

Modifié par Pilami

Partager ce message


Lien à poster
Partager sur d’autres sites

Normal, je fais un check de l'architecture à l'installation. Le souci est commun aux PPC aussi donc pas la peine d'essayer sur autre chose que mon Syno :

Source du problème : 88f6281 != 88f628x

Je corrigerai ça demain, il faut que le dernier caractère, si c'est un "x" soit remplacé par un wildcard...

	# Check if the architecture is supported

	case $arch in

		%SPK_ARCH%)

		true

		;;

	*)

		echo -n "Your architecture is not supported by this package, sorry."

		echo -n "Architecture  : $arch"

		echo -n "Synology info : $synoinfo"

		exit 1

		;;

	esac

Toutes les sources sont ici pour les avanturiers :

https://github.com/Diaoul/syno-packager/

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour tout le monde,

Voici mes SPK pour intégrer un serveur Mumble sur votre Syno !

Merci de me faire vos retours afin d'améliorer ce SPK !

Mon fork de Syno-Packager est ici : https://github.com/D...l/syno-packager et je suis en train de voir avec sarav pour merger tout ça

Et bien pour ma part, le SPK s'instal bien... il se lance... mais impossible d'avoir accès à l'interface: l'icone qui se trouve dans le menu, ouvre une nouvelle fenêtre sur l'adresse http://<adresse ip du Syno>:5000/webman/3rdparty/umurmur/index.cgi mais rien n'apparait.

De plus, l'URL n'apparait pas dans le "Package Management"

Ma config:

  • DS 209 II+

ScreenShot079.jpg

http://thierrybenet.dyndns.org/temp/ScreenShot079.jpg

Par contre, je ne connais pas trop ce genre de programme: quelqu'un a une URL en français expliquant l'utilisation & configuration de ce programme... Merci à vous.

Thierry

Partager ce message


Lien à poster
Partager sur d’autres sites

Soit ton navigateur ne le supporte pas, soit tu n'as pas Mumble d'installé. Avec Firefox sur Windows 7 et Mumble installé ça marche chez moi.

En effet ça manque un peu de doc sur l'utilisation :/ Je ferai ça quand j'aurai le temps

Partager ce message


Lien à poster
Partager sur d’autres sites

Soit ton navigateur ne le supporte pas, soit tu n'as pas Mumble d'installé. Avec Firefox sur Windows 7 et Mumble installé ça marche chez moi.

En effet ça manque un peu de doc sur l'utilisation :/ Je ferai ça quand j'aurai le temps

OK, ca fonctionne chez moi aussi... Firefox + Mumble + Win7...

Mumble s'est connecté et semble OK pour fonctionner (NB: bon, n'ayant pas de micro, je vais quand même pas loin B):lol:)

On va donc dire ou supposer que sur un DS 209 II+, tout est fonctionnel...;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon j'ai jamais trop cherché mais ça sera peut-être le moment de m'y mettre !

Parce que remplacer les "x" par des "?" ok, mais où est ce que tes scripts piochent la variable %SPK_ARCH% ?

Dans le arch-target.map ? Je me réponds tout seul je pense, c'est dans le makefile ^^ Edit : Et faut voir même à modifier les "x" dans les deux fichiers si je ne me trompe pas !

Par contre pour compiler j'imagine que c'est gnu/linux uniquement ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci Diaoul, cela fonctionne parfaitement sur mon 110+. Installation "plug & play" en une minute et c'est parfaitement fonctionnel. Test

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.