This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Fenrir

[TUTO] VPN Server

Messages recommandés

Bonjour, j'ai une question à propos de

Le 13/08/2016 à 17:13, Fenrir a dit :

nb : il ne s'agit pas ici de "masquer" votre adresse IP pour effectuer des opérations illicites ou de manière anonyme, l'adresse IP qui sera visible depuis Internet sera celle de votre NAS (ou de votre box)

Est il possible de se servir du VPN pour simplement chiffré les échanges pour éviter que l'on voit lors que l'on se connecte à un wifi public. Que pour des activités légales et que l'on voit l'IP de "chez moi" m'importe peu ?

Modifié par bugs denis

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu peux te connecter à ton NAS en VPN depuis un réseau wifi public oui.
Le trafic sera chiffré entre ton appareil et le NAS.
Il est quand même possible de savoir que depuis l'ip de la box de ce wifi public, tu as initié une connexion vers l'ip de ta box.
Après il n'y a rien d'illégal à ça ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous, 

J'ai configuré avec succès OpenVpn sur mon DS218+. j'ai bien accès à l'ensemble de mes équipements via un explorateur web. 😀

Par ailleurs, j'aurais voulu utiliser SMB pour avoir accès aux fichiers présent sur mon NAS, mais là, ça coince... 😥 (le but étant de partager des fichiers à distance pour une petite entreprise.) 

Une idée d'où ça peut venir ?

D'avance merci pour vos réponses. 

Bien à vous, 

Walred

Modifié par Walred

Partager ce message


Lien à poster
Partager sur d’autres sites

Pourquoi vouloir compliquer les choses ? Avec le VPN, vous êtes connecté au réseau de votre entreprise. Et donc, vous pouvez accéder aux dossiers de votre NAS exactement comme vous le faite de votre bureau, via des lecteurs réseau je suppose.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ben c'est ça le soucis... 😥

Quand je suis sur mon réseau, je tape \\***** dans mon explorateur de fichiers et je tombe bien sur les fichiers de mon NAS.

Par contre, quand je passe à travers mon VPN, j'ai ce message d'erreur

Image

J'avoue ne pas comprendre... 🙄

 

Modifié par Walred
inutile de répéter le message précédent si ça n'apporte rien de plus à la compréhension

Partager ce message


Lien à poster
Partager sur d’autres sites

Normal ... tu fais une requête netbios.
Tu dois utiliser un FQDN (Full Qualified Domain Name) en tapant "\\degleg.TonDomaine.Extension\" pour faire une requête DNS.

Si tu veux en savoir plus, tu peux Googler "Netbios", "WINS", "DNS"

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah d'accord... 

Par contre j'ai essayé en tapant le FQDN, mais ça me renvoie le même problème... 😞 

Merci tout de même 🙂 

Modifié par Mic13710
inutile de répéter le message précédent si ça n'apporte rien de plus à la compréhension

Partager ce message


Lien à poster
Partager sur d’autres sites

Le serveur DNS oui, sinon ça ne fonctionnera pas.
Quand tu es en interne (hors VPN donc) cela fonctionne?
Si tu l'as déjà paramétré c'est peut-être un problème de vues, si ça ne l'est pas alors il faut le faire.
Dans les deux cas tu peux aller voir le tuto de Fenrir qui explique tout pas à pas.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour ce qui est du serveur DNS, je ne l'ai pas encore configuré. En effet, j'ai repris à zéro une configuration saine... 😀

Quand je suis en interne, donc hors VPN, ça fonctionne impeccable ! Dès que je tape \\***** , j'ai accès à mes fichiers... 

Modifié par Walred
inutile de répéter le message précédent si ça n'apporte rien de plus à la compréhension

Partager ce message


Lien à poster
Partager sur d’autres sites

Forcément puisque tu fais du netbios, c'est ce que j'ai expliqué plus haut.
Pour faire simple, oublie le netbios sinon tu vas multiplier les problèmes.

Une configuration correcte (encore plus pour du VPN) passe par un serveur DNS configuré correctement. 🙂
Si tu repars d'un NAS à neuf je te conseillerais les tutos dans cet ordre:
[TUTO] Sécuriser les accès à son nas - Tutoriels - NAS-Forum
[TUTO] DNS Server - Tutoriels - NAS-Forum

Et puis seulement la configuration du VPN.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah ah ! D'accord ! Merci Spi. 🙂

J'avais commencé comme ça la première fois, mais j'ai sans doute du me planter. 

Je vais recommencer le tout de zéro ! 🙂

Je vous reviendrai si ça ne fonctionne pas ! 😄 

Merci déjà !

Modifié par Mic13710
inutile de répéter le message précédent si ça n'apporte rien de plus à la compréhension

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon ! J'ai bien mis en place mon serveur DNS. 

Il est bien fonctionnel. 😀

Après je me suis arrêté à ce qui m'intéressai, à savoir :

  • Cache DNS local
  • Zone DNS locale 
  • Vue DNS locale

Mais ça ne fonctionne toujours pas ! 😤

Une idée maintenant ?

PS: toute la partie sécurité du NAS, c'est la première chose que j'ai mis en place... 

Modifié par Walred

Partager ce message


Lien à poster
Partager sur d’autres sites

J’ai lu deux-trois trucs sur le net où on expliquait que le Firewall de Windows pouvait bloquer le tout... 

J'ai bien désactivé le tout, mais malheureusement, ça n’a rien changé ! Je bloque là... 😐

PS : j’ai essayé avec mon MacBook, mais même problème... 🤔

Modifié par Walred

Partager ce message


Lien à poster
Partager sur d’autres sites

DSL les gens, je ne suis pas repassé par ici depuis trop longtemps, donc trop de questions pour y répondre ou pour savoir ce qui a déjà été traité.

Pour les questions de résolution DNS, c'est généralement du au fait que le client (votre pc, smartphone, ...) n’accepte pas d'utiliser les DNS fournis par le serveur VPN ou que le serveur VPN ne fourni pas de DNS ou que vous n'avez pas autorisé le serveur DNS depuis le VPN

Partager ce message


Lien à poster
Partager sur d’autres sites

Si je peux me permettre un petit UP ! 😀

J'ai relancé l'installation complète dans le bon sens :

  1. Tuto sécu
  2. Tuto DNS
  3. Tuto VPN (OpenVpn)

Mais j'ai toujours le même blocage pour l'accès aux fichiers à travers le NAS alors que ça fonctionne impeccable en local ! 😥

Merci pour vos réponses.

Partager ce message


Lien à poster
Partager sur d’autres sites

Un grand bravo et un grand merci !

Ce sont des membres du forum qui m'ont aiguillé sur ce tuto juste parfait.

J'étais venu dans l'idée de le faire en deux/deux ... mais c'est tellement bien expliqué que je vais garder le projet sous le coude et m'y pencher quand j'aurai le temps de bien faire (bien comprendre) - et comme c'est bien expliqué.

Super travail Fenrir ! 

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 05/11/2018 à 14:54, Spi a dit :

Hello,
Tu utilises bien un chemin qui ressemble à \\NomDuServer.MonDomaine.xxx\partage ?

Donne nous le chemin complet et l'erreur que tu reçois.

Bonjour Spi, 

Merci pour cette réponse. 

J'ai entré dans la barre de recherche de mon explorateur de fichiers les adresses suivantes :

\\*****

\\*****.******.****\

\\*****.******.****\home

Mais rien ne se passe ! 😞 

J'ai à chaque fois ce message d'erreur

Par contre si je vais dans mon explorateur internet, je sais bien joindre mon NAS via SonAdresseIpLocale:5000... 😕

 

Modifié par Walred

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

Mais wtf le domaine... J'ai été vérifier sur DNS Belgium et tu as bien enregistré comme nom de domaine ndd
L'avantage d'utiliser le DNS c'est de se faciliter la vie, j'avoue ne pas comprendre pourquoi tu n'as pas acheté le domaine "degleg.be" et créé une redirection sur "nas.degleg.be" par exemple.
Ca serait quand même beaucoup plus pratique/simple... Enfin soit, si tu veux te compliquer la vie...

Etape suivante, je fais un nslookup sur "ndd" et il n'existe pas.
Donc:

- Si le domaine n'existe pas, ton serveur VPN ne fonctionnera jamais
- J'en déduis que la redirection chez ton fournisseur n'est pas configurée correctement
- J'en suppose que ton serveur DNS en interne ne l'est pas non plus...

Bon, je pense que tu as manqué des étapes ou que tu ne comprends pas le tuto DNS.
Je t'invite à le suivre une fois de plus, point par point, vérifier tout et tester tout.
Ensuite si tu as encore une erreur, poste des screenshot de toute ta config DNS sur le tuto (du DNS) sinon c'est difficile de t'aider.

En tout cas sur ton pc tu peux lancer deux commandes dans une invite de commande:
"ipconfig /all" Il y a une ligne DNS, elle doit afficher l'ip privée de ton NAS
"nslookup ndd" pareil

Si on était certain qu'au moins ça est configuré correctement ce serais pas mal... 🙂

Modifié par Spi
Suppression des noms de domaine réel

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement