This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Fenrir

[TUTO] VPN Server

Messages recommandés

Hello Fenrir, merci pour ton tuto ! Et une fois n'est pas coutume tout a bien fonctionné 😆

Une info : J'ai installé le client OpenVPN sur ios 11, ça se paramètre et ca fonctionne sans aucun pb.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

J'ai un NAS en réseau local avec 2PC,et j'aimerai pourvoir me connecter avec mon PC portable (w10) avec RDP sur un des deux PC (W7).

Je voulais savoir si on pouvait coupler ce système avec le bureau à distance de window ? (avant de faire n'importe quoi).

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

J'ai actuellement un problème de connection avec mon NAS en L2TP

J'ai exactement suivi le tutorial lors de la configuration du VPN en L2TP avec mon ancien NAS, ça fonctionnait à merveille

Maintenant, je viens de changer de NAS pour migrer d'un DS114 vers un DS718+, pas moyen de faire fonctionner le VPN en L2TP

J'ai remarqué que dans le journal de connection du NAS, je vois bien le service se lancer, par contre, mes clients me remontent un authentification failed...

Là, je sèche...

Modifié par Dimebag Darrell

Partager ce message


Lien à poster
Partager sur d’autres sites

Tout a été vérifié à plusieurs reprises, voire même une désinstallation du serveur VPN et réinstallation

La cléf partagée a même été simplifiée, genre un petit 12345 !!

Tjs bloqué !

Pour le serveur VPN, j'imagine qu'il est dans un dossier bien particulier,  je suppose qu'il pourrait y avoir des fichiers résiduels quand on le désinstalle ?

Modifié par Dimebag Darrell

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, remdam a dit :

Y a t-il une technique particulière, pour les néophytes comme moi, de savoir si tout est bien actif (un éventuel test ?)
Je vois bien la connexion établi dans mon interface réseau mais ça ne se limite qu'à ça.

Mon idée étant tout simplement de relier mon NAS 1 à mon 2 (site distant) pour qu'il fasse des sauvegardes de manières chiffré

Bonjour, 

tu donnes la réponse toi même ...
Tu connectes ton NAS 1 au NAS 2 en VPN. Tu vérifies que le client se déclare connecté, et que le serveur voit le client.
Puis, tu lances une sauvegarde via ce tunnel (inutile de la chiffrer). Tu verras ainsi s'il se passe quelque chose ...

Modifié par StéphanH

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai enfin réussi à créer mon VPN (en OpenVPN) entre mes 3 NAS et cela semble fonctionner parfaitement puisque lorsque je lance les sauvegardes, je vois les volumes d'échanges de données de la connexion VPN s'affoler 🙂

Par contre, je ne sais pas si cela est normal mais sur les deux NAS qui se connectent au serveur VPN, ils ont une passerelle différente ?!

L'un a une IP 10.8.0.10 (sur passerelle 10.8.0.9) et l'autre 10.8.0.6 sur passerelle 10.8.0.5).
C'est normal ? Ils ne devrait pas tous avoir la même passerelle, soit le NAS sur lequel il y a le serveur VPN ?

En parallèle de ça, n'est-il pas possible de définir une IP fixe au sein du VPN pour chaque NAS ?
Pour qu'en cas de déconnection/reconnection au VPN, je ne sois pas obligé de reparamétrer tous mes logiciels de sauvegarde.

Merci et bravo pour ce tutoriel bien détaillé 🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, 

svp j'ai une petite question si vous pouvez m'aider, j'utilise le VPN Server sur mon syno, j'ai 3machines qui sont distant qui se connecte sur mon syno mais chaque fois que ces machines se connecte au syno il recoivent une adresse IP par ordre de connexion, j'aimerai bien par exemple la machine A recoit toujours l'adresse X.X.X.1 et la machine B X.X.X.2 et la machine C X.X.X.3 

est ce que c'est possible, si oui comment faire svp ?

Merci d'avance !

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 30/05/2018 à 14:49, Anassdabaj a dit :

Bonjour, 

svp j'ai une petite question si vous pouvez m'aider, j'utilise le VPN Server sur mon syno, j'ai 3machines qui sont distant qui se connecte sur mon syno mais chaque fois que ces machines se connecte au syno il recoivent une adresse IP par ordre de connexion, j'aimerai bien par exemple la machine A recoit toujours l'adresse X.X.X.1 et la machine B X.X.X.2 et la machine C X.X.X.3 

est ce que c'est possible, si oui comment faire svp ?

Merci d'avance !

Bonjour,

Je suis aussi dans la même recherche de connexion au VPN server du syno en gardant des adresses IP fixes pour des connexions RDP sur PC. Ou est-il possible de le faire avec les noms NETBIOS pour éviter de rechercher les IP suivant l'ordre de connexion ? J'ai essayer avec un nom NETBIOS mais cela ne fonctionne pas. Le VPN ne les transmets pas. Y'a-t-il une méthode à suivre ?

Merci d'avance.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour être plus clair :

  • J'ai sur un réseau local : 1 NAS avec VPNserver L2TP/IPsec, PC1 Win7 pro, PC2 Win7 pro
  • Pour accès en RDP par VPN aux PC1 et PC2, je peux m'y connecter si je connais les adresses IP des PC1 (10.X.X.1) et PC2 (10.X.X.2)
  • Mais suivant l'ordre de connexion des PC au VPN, les IP peuvent changer, PC1 (10.X.X.2) et PC2 (10.X.X.1) ou autres si plusieurs connexions au VPN
  • Comment puis-je me connecter avec le noms des PCs sans avoir à connaitre leurs adresses IP du réseau VPN ?
  • @Fenrir dit qu'il faut jouer du SSH à chaque update du paquet : comment jouer du SSH ? de quel paquet (VPNserver ou DSM) ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai un soucis d'authentification via LT2P/IPSec que je n'arrive pas à résoudre :

Ci-dessous les étapes jusqu'au message d'erreur :

- Redirection des ports UDP 500 et 4500 de la Freebox V6 (192.168.1.1) vers DiskStation (192.168.1.2) :

IMG01.png.8cfeab9d2d7948d8c37f9cb1c87953ec.png

- Configuration du par-feu pour autoriser les ports UDP 500 et 4500 depuis la France ... et le réseau local (192.168.1.X) pour les test

- Configuration du protocole L2TP/IPSec dans VPN Server :

IMG02.png.60b4377dc4a7fda12a2940e1087c09d4.png

- Configuration du VPN sur iOS, OS X ou Windows. 

Utilisation de plusieurs utilisateurs différents (admin ou autres) en local ou depuis l'extérieur via le nom de domaine.

La clé pré-partagée est bien identique.

IMG03.thumb.jpg.8ee11c5e8db76b321c510f81f066f871.jpg

Dans tous les cas le message d'erreur est le même : Echec d'authentification

Dans les logs je trouve le message suivant :

image.png.4cd7135afcc9098f906ce6a4e4a501d6.png

Merci pour votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement