This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Deadbone

Problème scripts shell depuis MAJ 6.2.1-23824 [Résolu]

Messages recommandés

Bonjour,

J'ai fait la mise à jour de mon DS713+ sans problème apparent hier. Sauf que ce matin, je m'aperçois que mes scripts shell lancés la nuit sortent tous en erreur (je reçois un mail en cas d'erreur) 

Exemple

8<--------------------------------------------------------------------

Cher utilisateur,

Le planificateur de tâches à terminé une tâche planifiée.

Tâche : script_RSYNC_SCRIPTS_PHP.sh
Heure de début : Sun, 14 Oct 2018 07:20:02 GMT
Heure d’arrêt : Sun, 14 Oct 2018 07:20:02 GMT
État actuel : 139 (Interrompu)
Sortie standard/erreur :
sh: line 1: 26158 Segmentation fault      (core dumped) /volume1/download/SCRIPTS/script_RSYNC_SCRIPTS_PHP.sh


Sincères salutations,

-------------------------------------------------------------------->8

Je me trouve un peu démuni face à cette erreur.

En l'occurrence, le script indiqué "fait juste un copier coller", rien de bien compliqué.

Comment pourrais-je tenter de mieux comprendre l'origine du problème ?

ps : IPKG est installé depuis des années sans soucis sur mon NAS

Merci d'avance pour des pistes éventuelles

Cordialement

 

 

 

 

 

 

Modifié par Deadbone

Partager ce message


Lien à poster
Partager sur d’autres sites

bon, a priori c'est IPKG qui pose souci... j'avais commencé tous les scripts par #!/opt/bin/bash... si je remplace sur un script simple par #!/bin/sh le script fonctionne comme un charme (j'avais du faire utiliser le bash pour un besoin bien spécifique il y a quelques années, je ne m'en souviens plus ...)

Ceci dit, je ne comprends pas l'erreur en elle-même (même si l'origine ou tout du moins une solution de contournement est trouvée)

Modifié par Deadbone

Partager ce message


Lien à poster
Partager sur d’autres sites

/opt/bin/bash crash avec le nouveau firmware.

Tu peux essayer avec un autre script qui appelle ce shell et qui fait un simple echo. Il devrait se crasher pareil.

Ipkg c'est le gestionnaire de paquets. Pas certain que le dépôt soit à jour pour un 713.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement