This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Bien programmer les vérifications SMART des disques sur le NAS


Messages recommandés

@oracle7

Ce que tu écris est 100%  vrai, j'aurais dû t'écouter, c'est juste que sur un autre fil consacré à l'installation 

@Kramlech m'a écrit

Citation

De toute manière, quelque soit la solution que tu emploies, le DSM sera installé sur tous les disques...

Donc, pour moi, tu peux simplement installer les autres disques sans reformater le premier ....

et

@Mic13710 

Citation

Pourquoi effacer le volume 1 s'il correspond à votre besoin (btrfs ou ext4) ? L'augmentation de volume va simplement augmenter l'espace de stockage du volume existant. Il n'est donc d'aucune utilité de le supprimer après l'avoir créé.

Du coup je me suis dit qu'en effet ils avaient sans doute raison et j'ai procédé comme cela.

Mais je ne me doutais pas que cela allait prendre genre 6 jours pour augmenter le volume 😕 et que je n'allais pas pouvoir arrêter le process en cours..

Cotp

Modifié par cotp
Lien à poster
Partager sur d’autres sites

@cotp

Bonjour,

Les recommandations formulées par @Kramlech et @Mic13710 répondaient simplement à ta question et ils avaient tous les deux raison et leurs solutions et avis étaient bonnes. Ne vas surtout pas croire le contraire.

Pour ma part, la solution que je t'avais initialement proposée, te faisait certes faire quelques manipulations en plus (dont le formatage), mais avec l'avantage de se trouver dans les mêmes conditions que si on partait avec des disques neufs (contrôlés) et un NAS Vierge. C'est tout, pas plus ... Mais attention, dans tous les cas tu aurais eu droit au contrôle de parité et à sa "lenteur" mais sûrement pas aussi long que maintenant.

Cordialement

oracle7😉

 

Lien à poster
Partager sur d’autres sites

@oracle7

Merci pour tes précisions. On dit qu'on apprend parfois avec l'expérience. En tout cas cette fois ci c'est mon cas, j'espère que ce thread pourra servir à d'autres qui tomberont dessus.

Je vous remercie tous ici @Kramlech @Mic13710 @maxou56 @MilesTEG1 et les autres pour leur précieux conseils qui me font avancer.

Maintenant je peux dire que grâce à vous je "sais" "(presque) contrôler un disque via Putty et un NAS. 😉

Et puis bon j'apprends la patience ce qui n'est pas rien ahaha

Cotp 

PS: 44% 😉 ce matin

 

Il y a 11 heures, oracle7 a dit :

Mais attention, dans tous les cas tu aurais eu droit au contrôle de parité et à sa "lenteur" mais sûrement pas aussi long que maintenant.

Bon du coup hein, je crois que l'option "attendre" est aujourd'hui la meilleure 🙂

Lien à poster
Partager sur d’autres sites

L'attente est effectivement le lot de toute construction de groupe. Plus il y a de disques, plus ils sont gros, et plus cette attente est longue. Mais je suis tout de même dubitatif sur le temps et surtout le nombre de passes que fait le NAS pour cette construction. Normalement, il n'y a qu'un contrôle si les disques sont bons. Je me demande si vous n'auriez pas un souci avec l'un d'entre eux, voire plusieurs. Si le test badblocks vérifie bien le disque en profondeur, il n'est pas sans conséquence car il le fait durement travailler. Il est donc possible qu'il y en ait un qui n'en soit pas sorti indemne.

Si vous voulez repartir de zéro, vous pouvez arrêter le processus en éteignant le NAS. Vous sortez les disques, vous les formatez et vous les remontez tous dans le NAS pour refaire une installation complète de DSM et la construction d'un nouveau groupe. A mon avis, ça ne changera pas grand chose, mais qui ne tente rien...

Lien à poster
Partager sur d’autres sites
il y a 20 minutes, Mic13710 a dit :

Si le test badblocks vérifie bien le disque en profondeur, il n'est pas sans conséquence car il le fait durement travailler. Il est donc possible qu'il y en ait un qui n'en soit pas sorti indemne.

Merci @Mic13710 pour ta réponse rapide. Du coup alors est-ce que le bénéfice risque en vaut la peine à ton avis ou un autre type de test serait suffisant après un achat ?

Sur 4 disques achetés 2 ont passé le test, 1 ne s'est même pas allumé (donc retourné) et 1 a annoncé 129 secteurs defectueux et je l'ai renvoyé.

J'en ai commandé 2 autres (qui sont à l'intérieur désormais) et que j'ai aussi testé en badblocks et ont passé le test avec succès.

Maintenant est-ce qu'un SMART test étendu aurait détécté  les secteurs defecteux je ne pourrais pas le dire puisque je en l'ai pas fait sur ce disque.

il y a 23 minutes, Mic13710 a dit :

Si vous voulez repartir de zéro, vous pouvez arrêter le processus en éteignant le NAS. Vous sortez les disques, vous les formatez et vous les remontez tous dans le NAS pour refaire une installation complète de DSM et la construction d'un nouveau groupe. A mon avis, ça ne changera pas grand chose, mais qui ne tente rien...

 Moi je veux bien mais je ne sais pas comment arreter le NAS proprement (le bouton avant ne veut pas répondre meme en le laissant longtemps appuyé) et pas possible non plus depuis l'interface.

Il faudrait arreter le service mais je ne sais pas lequel. J'en suis à 44% si jamais à 100% ra recommence encore à vérifier j'arreterai ... (par la prise ??)

Cotp

Lien à poster
Partager sur d’autres sites

Personnellement, je ne fais pas de test badblocks. Trop long, trop contraignant. Juste une écriture de zéro qui stesse beaucoup moins le disque. C'est à mon sens largement suffisant.

J'avais écrit un petit tuto pour ça : 

Si vous ne pouvez pas arrêter le NAS, vous pouvez en dernier recourt tout simplement débrancher la prise.

Lien à poster
Partager sur d’autres sites
Citation

 

Pour lancer la préparation, vous rentrez et validez les commandes suivantes l'une après l'autre.


dd if=/dev/zero of=/dev/sdb bs=1M &     (préparation du disque 2)
dd if=/dev/zero of=/dev/sdc bs=1M &     (préparation du disque 3) 
dd if=/dev/zero of=/dev/sdd bs=1M &     (préparation du disque 4) 
etc..... 

Ces commandes vont tester chaque secteur en y faisant une écriture de zéros. Les disques seront vérifiés simultanément.

Bien mettre le "&" à la fin de chaque ligne ce qui permet de lancer l'opération en mode batch

Vous en aurez pour de très nombreuses heures (entre 10 et 15, voire plus avec des 6To).

Pour chaque disque, vous devriez recevoir le message suivant en fin de test :


dd: /dev/sdx: No space left on device (x pour la lettre du disque)

 

@Mic13710 Si ça ne t'embête pas juste pour que je comprenne est-ce que tu pourrais m'expliquer pourquoi c'est mieux (ou moins stressant) d'écrire des 0 que de tester les secteurs défectueux ? 

Et en cas de disque avec des secteurs défecteux (comme j'ai eu le cas) quel serait alors le message d'erreur ? Quelque chose comme "n'ai pas réussi à écrire à tel endroit "  ?

 

Le 29/09/2020 à 10:13, Mic13710 a dit :

Si vous ne pouvez pas arrêter le NAS, vous pouvez en dernier recourt tout simplement débrancher la prise.

Je suis à 52% je le ferai si ça recommence à 0% la prochaine fois. Il n'y a pas de service que je puisse arrêter dans le Gestionnaire de Taches ?

Edit: 62%  ce soir avant de dormir... (10% en 9h... wow) si ça continue ce rythme j'aurai la réponse dans 36h... 

87% ce midi... suspense...

Modifié par cotp
Lien à poster
Partager sur d’autres sites
Citation

System successfully expanded [Storage Pool 1] with disk [Drive 2, Drive 3, Drive 4].

😇

@Mic13710 @oracle7 

Du coup ben j'ai monté mes 2 volumes via Synology Assitant et j'ai commencé mes copies de fichiers

patience et longueur de temps font mieux que force ni que rage 😉

Cotp

Modifié par cotp
Lien à poster
Partager sur d’autres sites

@oracle7

Merci pour ces sages paroles...

Sinon quand je copie 1 fichier de 1Go ça m'affiche 4 min, ça te parait dans les temps ? Est-ce que je peux essayer d'améliorer ce temps à ton avis sans y perdre trop de temps 🙂 ahaha

Je sais j'ai utilisé 3 fois le mot temps dans la phrase ci dessus

Cotp

Modifié par cotp
Lien à poster
Partager sur d’autres sites

@cotp

Bonjour,

A titre d'exemple quand je transfert du PC vers le NAS un film d'1 Go j'ai un taux de transfert moyen qui oscille entre 100 et 120 Mo/s et cela prend environ 5 à 6 sec (avec pas d'autre charge sur le réseau).

image.png.bfd79d8280dc8df92adccdcd3cdaa885.png

Je te laisses en tirer les conclusions.

Cordialement

oracle7😉

 

Lien à poster
Partager sur d’autres sites
il y a une heure, oracle7 a dit :

Je te laisses en tirer les conclusions.

Oh j'aurais bien aimer une piste mon cher Sherlock !

Côté configuration voici ce que j'ai fait:

J'ai mappé les 2 NAS avec Synology Assistant depuis mon PC (2 lettres différentes).

Ensuite via mon logiciel de comparaison de dossier (Beyond Compare pour ne pas le citer), j'ai copié le fichier directement (pas déplacé).

Du coup j'en déduis que ce n'est pas le bon système. Mais alors qu'est-ce que j'ai fais de pas bien ?

Le PC est dans une pièce.

Les 2 NAS dans une autre pièces.

Ils sont connecté sur un Gigaswitch

Le net est lui connecté en CPL c'est à dire qu'il arrive dans une pièce puis arrive dans la pièce des NAS via une prise CPL et dans mon bureau où est placé le PC via une autre prise CPL...

Cotp

Modifié par cotp
Lien à poster
Partager sur d’autres sites

Si je comprend bien, tu fais une copie d'un NAS à l'autre, en passant par deux disque réseaux (un pour chaque NAS) monté dans ton PC, qui est relié en CPL à ton réseau ?

Si c'est cela, voici ce qu'il se passe : Chaque octet part du premier NAS, va sur le PC, repart du PC pour arriver sur le deuxième NAS. C'est donc la liaison réseau du PC qui fait goulot d'étranglement :

  • Chaque octet transféré passe deux fois sur le réseau
  • Le CPL n'est pas aussi performant qu'une liaison ethernet simple, loin de là !!! Chez moi, une liaison CPL était plus lente qu'un wifi 11g .... Ca dépend que la qualité du réseau électrique

Ce que je te conseille, c'est de monter directement le répertoire partage du NAS 1 dans le NAS 2 :

image.png.97211aed54b013ded33be407715f46c4.png

Et je pense que tes transferts seront grandement améliorés (je prédis que ce sera plus de deux fois plus rapide)!

 

Lien à poster
Partager sur d’autres sites

@cotp

Bonjour,

Tu as là un exemple typique de la différence entre un réseau filaire Ethernet de bout en bout et un réseau hétérogène (si je puis dire) mélangeant Filaire Ethernet et CPL.

Autant j'aurais compris la chute de débit entre ton PC et les NAS à cause des CPL qui doivent très largement bridé ton réseau à mon avis. Autant c'est d'autant plus bizarre pour tes NAS qui eux si j'ai bien compris sont connectés en filaire Ethernet à un même switch. Donc si tu utilises des lecteurs réseaux montés depuis le PC alors là, c'est sûr ce sont tes CPL qui te brident le débit du réseau dans sa globalité.

Du coup et si tu essayait via File Station de faire le transfert direct entre NAS ?

Ahhreeee 😩 . @Kramlech m'a encore grillé ! j'écris pas assez vite 🤪

Au final, je ne peux que t'inviter à réfléchir sérieusement à tirer des câbles Ethernet dans ton logement pour monter un réseau digne de ce nom et de bannir tes CPL.

C'est que j'ai fait personnellement, pas sans mal certes, mais maintenant c'est le jour et la nuit et surtout depuis que j'ai fait cela, plus de problèmes de stabilité du réseau induits par les CPL et pourtant c'était du haut gamme.

Cordialement

oracle😉

 

Lien à poster
Partager sur d’autres sites

Merci à tous les deux pour votre réponse. @oracle7 @Kramlech

1) alors concernant le montage en NFS :

 

Citation

Ce que je te conseille, c'est de monter directement le répertoire partage du NAS 1 dans le NAS 2 :

J'ai essayé mais ça me met "Veuillez vous assurer que le serveur distant est accessible via NFS".

Je suis donc allé l'activer sur NAS 1 mais je continue à avoir l'erreur... je creuse... je l'ai activé sur NAS2 mais j'ai toujours l'erreur.

Je dois aussi choisir entre protocole UDP ou TCP

C'est marqué par ailleurs si je veux activer le service NFS v4.1 mais il faut renseigner un domaine et je ne sais pas quoi renseigner.

Edit: J'ai réussi à le connecter via CIFS !!

2) Pour les CPL vs réseau filaire:

Je vais regarder aussi ce que je peux faire du coté des fils éthernet. Le problème c'est que les distances sont grandes car mon bureau est près de la cave et le modem à l'entrée mais bon je ne vais pas rentrer dans les détails  🙂 .

3) Comme j'ai le  ***  bordé de nouille en ce moment voici ce que m'affiche le 415+ une petite lumière orange et: (bizarre pour une fois que ça ne bippe pas)

du coup faut que j'éteigne le 415+ , que je commande un nouveau disque, que je reconstruise le volume et que je recopie les données.

Car si je continue à copier vers le 420+ j'ai peur qu'avec ma chance un 2e disque ne lâche sur le 415 et là c'est la cata... !

Bref qui parlait de patience et de sagesse tout à l'heure ?? 🙂

La bonne nouvelle c'est que ça me laisse le temps de préparer une installation filaire ahaha.

Du coup il faudrait que je fasse partir un cable éthernet du modem jusqu'au switch et du switch jusqu'au NAS c'est ça ?? 

Pas grave si le cable fait genre entre 30 et 60m par exemple ?? (pas encore mesuré) , c'est ma femme qui va etre contente déjà que je l'embête avec les cables HDMI lol 🙂

Cotp

 

degrade volume.JPG

 

4) Sinon voici le dernier test SMART du disque 3 (maintenant il m'indique "SAIN" je me demande si je pourrais tenter une reconstruction sans le changer en attendant.. en meme temps je n'ai pas envie de prendre trop de risque donc je vais attendre d'en recevoir un.

Maintenant ce type de disque peut encore servir à faire du backup individuel  ou pas ?? Comment je peux savoir si il est bon pour la casse ?

 

Bonne nuit à tous 😉

 

415+disque3_1.JPG

Modifié par cotp
Lien à poster
Partager sur d’autres sites

 

Il y a 3 heures, oracle7 a dit :

A titre d'exemple quand je transfert du PC vers le NAS un film d'1 Go j'ai un taux de transfert moyen qui oscille entre 100 et 120 Mo/s et cela prend environ 5 à 6 sec (avec pas d'autre charge sur le réseau).

Alors une fois monté le volume du 415+ dans le 420+, j'ai essayé de faire un copié collé dans DSM via File Station, ça me donne un taux à 8Mb sec ... normal ou pas ?? Donc 20 minutes pour 10Go de données.

Je pourrais essayer Rsync aussi mais pas sur si ça va changer qq chose.

C'est possible sinon de les relier directement entre eux ??

Bon en attendant vos réponses je vais l'éteindre hein 🙂

Cotp

Modifié par cotp
Lien à poster
Partager sur d’autres sites

Le NAS est capable de lire des disques externes en NTFS. Ca ira plus vite qu'à travers les méandres de votre réseau.

image.png.265d00d00566bf24eb8e484fc186aae9.png

Il y a 14 heures, cotp a dit :

Pas grave si le cable fait genre entre 30 et 60m par exemple ??

C'est ok en Gb jusqu'à 100m avec du cat5e.

Mais là vos dernières demandes sont complètement hors sujet. Je vous invite à ouvrir un nouveau sujet pour qu'on puisse s'y retrouver.

Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.