This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Tonton Glenn

Wake On Lan

Messages recommandés

Le 15/01/2017 à 17:01, Christ88 a dit :

Bonjour Michel,

Je ne puis t'Expliquer...

J'ai essayé ave un autre ordi, et le WOL fonctionne ! Bizarre...

Mais chose certaine, le ping ne fonctionne pas. Dans tous les cas il me répond que l'ordi est hors ligne.

Christian

Attention pa fois il faut aussi l'activer dans Windows, sur ma nouvelle machine avec une carte réseau Intel cela ne marcher pas alors que j'avais le dernier driver du site gigabytes, mais en faite j'ai mis le driver officiel de Intel et là j'ai pu l'activer dans le gestionnaire de périf. Car lors de l'arrêt de windows c'est lui qui doit laisser la carte en veille si pas actif il la coupe totalement. Sur certain PC l'activation simple du bios suffit.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Est-il possible de demander au synology d'activer une machine grâce à ton Wake on Lan automatiquement, avec une tache et un script?

Merci de ta réponse 

Patrick

Modifié par Lucien77
Citation inutile

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Non, mais il me semble avoir vu trainer un script qui fait cela, fais une recherche google.

Cordialement.

Michel.

 

PS: regarde là par exemple

http://stackoverflow.com/questions/31588035/bash-one-line-command-to-send-wake-on-lan-magic-packet-without-specific-tool

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui avec DSM 6 il est possible de programmer un script via le planificateur de tache du DSM

Donc nouvelle tache puis script défini par l'utilisateur ensuite renseigner les horaires si nécessaire

ou mettre le script au démarrage du NAS

Dans l'onglet paramètre de tache saisir

synonet --wake XX:XX:XX:XX:XX:XX eth0

remplacer les XX par l'adresse Mac de la machine à réveiller

Plutôt simple

Je me sert de ceci pour réveiller un serveur en même temps que mon NAS  qui lui utilise différents horaires

http://bootstick.ch/?p=5

Modifié par Lucien77
Citation inutile

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 20 heures, jmrodger a dit :

synonet --wake XX:XX:XX:XX:XX:XX eth0

remplacer les XX par l'adresse Mac de la machine à réveiller

Pour une raison qui m'échappe, "synonet --wake" a cessé de fonctionner chez moi et d'autres. Solution: réutiliser ce vieux script Perl qui fait l'affaire comme j'en ai parlé ici:

https://forum.synology.com/enu/viewtopic.php?f=90&t=116493&p=475318#p474953

Partager ce message


Lien à poster
Partager sur d’autres sites

Youhou ! Ce script pourrait bien me sauver la vie, merci pour tout ça !

Hélas, j'ai le syndrome page blanche, malgré la désactivation des options de sécurité. J'arrive sur une page me déclarant : "désolé, la page que vous recherchez est introuvable".

Si quelqu'un passe par ici avec de l'info, ça m'intéresse !

Edit : Oups, je viens de voir la solution de catimini, qui règle mon problème. Merci !

Synology DiskStation - WakeonLan error.jpg

Modifié par JohnMcChavs

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 12/03/2017 à 11:41, CoolRaoul a dit :

Pour une raison qui m'échappe, "synonet --wake" a cessé de fonctionner chez moi et d'autres.

Je viens de tester et effectivement cette commande n'envoie que des paquets WoL mal-formés. En tout cas tcpdump ne reconnaît même pas le protocole de transport (udp) :

16:59:12.104120 08:42:ff:ff:ff:ff > ff:ff:ff:ff:ff:ff, Unknown Ethertype (0xffff), length 110:
..2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ..

On voit bien l'adresse MAC répétée 16 fois, mais l'en-tête du paquet est erronée.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, PiwiLAbruti a dit :

Je viens de tester et effectivement cette commande n'envoie que des paquets WoL mal-formés

Normalement faudrait ouvrir un ticket de support chez Syno. Mais mes deux dernières expériences m'ont franchement découragé. Je laisse ça aux plus patients que moi :neutral: (d'autant plus que, la commande n'étant pas documenté et donc pas officiellement supportée, ça leur serait encore plus facile de botter en touche)

Modifié par CoolRaoul

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 14/01/2017 à 18:57, Christ88 a dit :

Bonjour,

J'ai suivi les étapes, mais j'obtiens un erreur lors du démarrage de ton application sur le NAS.

Voir les captures.

Merci

1.PNG

2.PNG

1) Pour ceux qui cherche la version modifiée, direction ci-dessous. Gros merci à Catimimi pour son super taf !

2) Piqûre de rappel pour ceux qui ne s'en sortent pas avec le Wol ou Wowan : A) Activer l'option dans le bios B) Installer les pilotes OFFICIEL  de la carte (pilote Intel pour carte Intel, etc), et pas les drivers par défaut de Windows. C'est parfois capital (souvent avec les cartes Intel, par exemple). C) Si besoin de faire du WoWan, commencer par du Wol  D) Si toujours problème, utiliser le vérificateur de réception de magic paquet qu'on trouve sur le site de Depicus (a exécuter sur la machine qu'on veut WoL lorsqu'elle est allumée). Voilou !

 

Modifié par Supermatos.com

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 19 heures, Supermatos.com a dit :

1) Pour ceux qui cherche la version modifiée, direction ci-dessous. Gros merci à Catimimi pour son super taf !

 

 

Bonjour,

Merci, les sources sont à disposition pour ceux qui veulent cross-compiler pour d'autres architectures.

Je les ai fournies à Tonton Glenn qui devait les mettre sur Github, mais je n'ai plus aucune nouvelle de sa part.

De même mes sources pour owncloud 9 sur DSM6 sont disponibles.

Cordialement.

Michel.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

j'ai installé le paquet "Wake On LAN" de Tonton Glenn, qui fonctionnait parfaitement sur un ancien Syno en DSM 5 mais je n'arrive pas à le faire fonctionner sur le DSM 6 fraichement installé et sur lequel je suis encore novice.

Les symptômes : Comme Christ88 plus haut, une belle page Synology qui dit "Désolé, la page que vous recherchez est introuvable."

Hormis l'installation de Web Station (sans paramétrage spécifique) et de Perl,  y aurait-il d'autres choses à faire pour ce paquet "Wake On LAN" ?

Ma config : DS 716+II avec DSM 6.1.1-15101 Update 3

Merci d'avance pour vos réponses,

Bien cordialement, Stéphane

Modifié par Steph78630

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

IL faut lire les autres posts de ce fil avant de se plaindre.

Le paquet de Tonton Glenn ne fonctionne plus sous DSM6.

j'ai posté dans la zone de téléchargements un paquet qui fonctionne pour les architectures intel donc pour le DS716+II.

Cordialement.

Michel.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le ‎27‎/‎05‎/‎2017 à 12:22, catimimi a dit :

Bonjour,

IL faut lire les autres posts de ce fil avant de se plaindre.

Le paquet de Tonton Glenn ne fonctionne plus sous DSM6.

j'ai posté dans la zone de téléchargements un paquet qui fonctionne pour les architectures intel donc pour le DS716+II.

Cordialement.

Michel.

Bonjour Michel,

rassurez-vous je ne me plaignais pas, je demandais juste un peu d'aide pour l'installation de ce paquet, et je vous remercie de votre sympathique réponse.

Je pense avoir lu tous les commentaires précédents de ce post, mais pour une raison que j'ignore le lien de téléchargement dans le post du 8 janvier m'envoyait vers un seul fichier et en y retournant désormais j'accède bien à 4 fichiers, dont le "wakeonlan-x86_64-20170108.spk".

Je confirme que cette nouvelle version de paquet est fonctionnelle sur ma config (DS716+II), merci Michel !

Cordialement, Stéphane

Modifié par Steph78630

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 27/05/2017 à 12:22, catimimi a dit :

Bonjour,

IL faut lire les autres posts de ce fil avant de se plaindre.

Le paquet de Tonton Glenn ne fonctionne plus sous DSM6.

j'ai posté dans la zone de téléchargements un paquet qui fonctionne pour les architectures intel donc pour le DS716+II.

Cordialement.

Michel.

 

Hello,

Mon NAS est relié à un routeur/firewall, et il y a aussi un switch sur le chemin avant d'arriver au pc. Ce qui n'était pas le cas avant. Du coup j'aimerais savoir si le paquet est toujours fonctionnel chez vous depuis les récentes mises à jour ou si je dois commencer à débuguer tout ça?

Merci d'avance :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bravo et merci pour ce paquet !

Un truc top serait de pouvoir récupérer la liste des adresses mac fixées dans le serveur DHCP pour réveiller la machine désirée d'un seul clic (à la manière de Pfsense)
Sur le papier ce ne parait pas compliqué, après en développement...

Cordialement, Sébastien

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

Je suis actuellement en train de tenter de débug ce paquet... Petit récapitulatif:

Dernière config fonctionnelle:

Niv1) Routeur Netgear WNR 3500Lv2

Niv2) NAS + PC1

 

Config actuelle:

Niv1) Routeur Ubiquity ERX

Niv2) Switch TPlink TL-SG108 + NAS

Niv3) PC1 et PC2 (le 2 est nouveau) -> Branchés sur le switch évidemment

 

Il est a noter que je ne suis pas certain que c'est le changement de matériel qui est en cause (bien que probable) parce-que je ne me servais pas souvent de ce paquet. C'est donc peut-être un hasard.

Du coup, j'ai testé de réveiller les 2 par WOL, évidemment cela ne marche pas. Mes deux PC sont branchés sur un onduleur qui coupe les périphériques quand le master est éteint (pc2) pour info. Peu probable que ça vienne de là puisque cela fonctionnait avant avec mon pc1 quand il était master, sans compter que si j'essaie de réveiller pc1 quand pc 2 est allumé cela ne fonctionne pas non plus (et c'est certain que la carte réseau est allumée vu qu'il y a la led).

Et en faisant une capture de paquet depuis le pc 2 je vois qu'il y a bien un trafic WOL qui vient du NAS:

59d7dbc2cc6d2_2017-10-0621_38_07-_Ethernet.thumb.png.770bb0cb2633f8ed8765e32ae2a648b2.png

Par contre... La MAC est inconnue au bataillon! :D

Ce n'est celle d'aucun des deux PC, ni de l'ERX...

Il y a aussi une requête ARP de mon Ubiquity vers ce que je pense être le switch pour connaître l'ip de ma tour (bail DHCP fixé dans le Syno).

59d7dd4a5beb0_2017-10-0621_41_44-_Ethernet.thumb.png.0467421c047c21200afe975f30c9d3f8.png

Je pensais également que les magic paquet se faisaient sur le port 9, ici ils arrivent sur le 12287.

59d7e6a8389fd_2017-10-0622_23_59-_Ethernet.thumb.png.7661b6c35fe883bfe95392222cb0361a.png

Est-ce que quelqu'un aurait une petite idée? :)

 

Modifié par Spi

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je viens d'installer la version 2.1 de wake on lan et cela fonctionne très bien. Par contre le dossier wake dans le repertoire web ne c'est pas créer et donc je ne sais pas comment acceder à la page internet me permettant de lancer le wol depuis mon site.

Merci d'avance de votre aide.

Slts,

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour, 

 

est-ce qu'il serait possible d'éditer le premier post et de mettre un lien qui pointe vers les bons fichiers ? Car c'est un peu le chemin de piste pour arriver vers les bons fichiers, qui sont nommés "ne fonctionnent pas correctement" dans le centre de téléchargement..

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 14/7/2007 à 14:20, Tonton Glenn a dit :

 

Bonjour,

Merci pour ce paquet mais il ne semble pas fonctionner chez moi

"Désolé, la page que vous recherchez est introuvable."

J'ai la dernière version de DSM et l'ai bien desactivé l'option de sécurité "

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour,

Pour ma part le paquet s'est installé sur le syno  ,j'ai bien saisi les adresse MAC de  chacun mais je n'arrive pas réveillé mes deux pc qui sont sur mon réseau.

comment être sur que le paquet arrive bien au pc ?

 

002.jpg

Modifié par stf4

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

si ça peut servir à quelqu'un, petite précision dans ma configuration fonctionnelle :

Je dois exécuter 2 ordres de réveil consécutifs pour la même machine, le 1er n'aboutissant pas.

Sinon, mon installation du paquet date un peu désormais, mais il m'a fallut modifier plusieurs choses à l'affichage pour que cela corresponde à mon besoin, notamment :

> Le message "Paquet magique envoyé à..." qui affiche aussi le nom de la machine plutôt que seulement son @ MAC

> Les boutons "Ajouter" et "Supprimer" qui sont positionnés [isolés] à droite de la fenêtre pour éviter les erreurs de manip des utilisateurs

Cdt, Stéphane

WakeOnLAN_Syno.jpg.44846e3a6bacd7697b983f148e9fcc18.jpg

Modifié par Steph78630

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, stf4 a dit :

bonjour,

Pour ma part le paquet s'est installé sur le syno  ,j'ai bien saisi les adresse MAC de  chacun mais je n'arrive pas réveillé mes deux pc qui sont sur mon réseau.

comment être sur que le paquet arrive bien au pc ?

Bonjour @stf4,

déjà effectivement je ferais mes tests avec Syno et PC sur le même LAN pour me dédouaner des pbs d'ouverture de ports / autorisations des routeurs,

ensuite je vérifierais que les options WOL sont bien présentes et activées dans le bios des PC à réveiller (idem pilotes Intel sous Windows),

et pour terminer j'utiliserais un outil WOL tierce, histoire d'isoler l'installation / paramétrage du paquet sur le Syno...

> Sous Windows, il y a par ex. WakeOnLan de Dipisoft, en testant PC1 vers PC2 ou PC2 vers> PC1 :

https://www.dipisoft.com/articles.php?lng=fr&pg=90&mnuid=2211&tconfig=0

Cordialement, Stéphane

Modifié par Steph78630

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement