This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

concombremasque75

MariaDB incompatible avec Joomla 3.x

Messages recommandés

Bonjour,

 

J'ai hier soir procédé à la migration de mon site Joomla 2.5 vers la version 3.x

Malheureusement, depuis cette migration, Joomla m'indique que ma version de BDD est trop ancienne et que Joomla refuse pour des raisons de sécurité de prendre en compte cette version.

Mon site web est donc tombé.

J'aimerais donc savoir si il y avait une possibilité de migrer ma BDD en 5.3 vers une version en 5.6 ?

Mon NAS est un DS110j.

Merci par avance si toutefois vous aviez une piste pour régler ce problème.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ton modèle n'étant plus supporté, ça risque d'être compliqué. Si tu arrives à installer une debian en chroot ça devrait encore être possible. Sinon fais un rollback.

ps : je trouves anormal que joomla ne test pas la compatibilité AVANT de faire l'upgrade

<hs>ton modèle commence à dater et n'a plus de mise à jour de sécurité, si c'est uniquement pour un usage interne, pas accessible depuis Internet ok, mais sinon il va falloir changer de modèle car tu t'exposes à tes attaque (et par rebond, tu exposes tout Internet)</hs>

Partager ce message


Lien à poster
Partager sur d’autres sites

Quelle version de DSM utilises-tu ? (DSM 5.2-5967 je suppose)

Une mise à jour de MariaDB doit être présente dans le Centre de paquets puisque Synology propose la version 5.5 sur la page de téléchargement de ton modèle.

Au pire, installe ce paquet manuellement.

 

@Fenrir : Le DS110j, et plus globalement DSM 5.2, bénéficie toujours des mises à jour de sécurité :

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, PiwiLAbruti a dit :

 

@Fenrir : Le DS110j, et plus globalement DSM 5.2, bénéficie toujours des mises à jour de sécurité :

C'est une mise à jour exceptionnelle (comme pour XP), la liste des failles non patchées sur mon DS710+ s'allonge de jour en jour depuis juillet de l'année dernière.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le ‎02‎/‎06‎/‎2017 à 12:46, PiwiLAbruti a dit :

Quelle version de DSM utilises-tu ? (DSM 5.2-5967 je suppose)

Une mise à jour de MariaDB doit être présente dans le Centre de paquets puisque Synology propose la version 5.5 sur la page de téléchargement de ton modèle.

Au pire, installe ce paquet manuellement.

 

@Fenrir : Le DS110j, et plus globalement DSM 5.2, bénéficie toujours des mises à jour de sécurité :

Bonjour,

 

Merci pour vos informations précieuses.

J'utilise effectivement cette dernière version de DSM pour mon 110j. Je ne comptais pas en changer puisque celui-ci tourne toujours aussi bien depuis ses début et j n'ai d'ailleurs aucune utilité de monter en gamme.

Par contre je ne suis pas expert en migration de version de MariaDB, si toutefois vous aviez un lien de d'un tuto pour effectuer cette migration.

 

Merci en tout cas pour votre réponse.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, PiwiLAbruti a dit :

Il suffit d'installer le paquet pour bénéficier de la version 5.5.

Bonjour,

 

J'ai procédé à la migration mais voici le message du NAS en retour : Failed to update package [MariaDB]

Vous auriez une idée de la provenance du problème ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 07/06/2017 à 09:06, PiwiLAbruti a dit :

Arrête le paquet MariaDB et ses dépendances, et retente la mise à jour.

Malheureusement sous joomla je rencontre le problème suivant :

Erreur

We have detected that your server is using PHP 5.5.33 which is obsolete and no longer receives official security updates by its developers. The Joomla! Project recommends upgrading your site to PHP 5.6 or later which will receive security updates at least until 31/12/18. Please ask your host to make PHP 5.6 or a later version the default version for your site. If your host is already PHP 5.6 ready please enable PHP 5.6 on your site's root and 'administrator' directories – typically you can do this yourself through a tool in your hosting control panel, but it's best to ask your host if you are unsure.
Une erreur s'est produite
 
Cela indique que la base de donnée est trop ancienne.
 
Comment faire dans ces cas là avec MariaDB ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce qui est curieux c'est que Joomla 3.x indique PHP 5.3.10 et MySQL 5.1 comme version minimum => ce message n'est qu'un avertissement et devrait pouvoir être désactivé

Sauf les les dev de Joomla n'ont pas mis à jour la doc !!

Tu peux tenter de désactiver ou de gruger le test de la version de php (je suis sur que c'est facile à trouver dans le code).

Il est aussi possible que le problème soit généré par un plugin.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, Fenrir a dit :

Ce qui est curieux c'est que Joomla 3.x indique PHP 5.3.10 et MySQL 5.1 comme version minimum => ce message n'est qu'un avertissement et devrait pouvoir être désactivé

Sauf les les dev de Joomla n'ont pas mis à jour la doc !!

Tu peux tenter de désactiver ou de gruger le test de la version de php (je suis sur que c'est facile à trouver dans le code).

Il est aussi possible que le problème soit généré par un plugin.

Merci beaucoup pour ta nouvelle piste.

Effectivement, ce n'est qu'un message sans incidence, mais mon site affiche une belle page blanche sans autre message d'erreur.

Je m'adresse au forum Joomla pour plus de détails sur la provenance de ce problème.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, concombremasque75 a dit :

il semble d'après les experts que cela provienne du NAS en lui même.

Et ces experts n'ont pas pu t'en dire plus ?

:mrgreen::mrgreen: (Cela ressemble fort à une tentative de cacher un classique  "je ne sais pas") :mrgreen::mrgreen:

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Lelolo a dit :

Le message d'erreur que tu décris fait référence à une version trop ancienne de PHP, pas de MariaDB.
As-tu essayé de faire la mise à jour de PHP ?

Bonjour,

 

Non, je n'ai pas tenté de mettre à jour la version de PHP, car tout simplement je ne connais pas la technique.

Du coup, à mon grand désarroi, je suis revenu à mon ancienne version de Joomla !

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 24/06/2017 à 10:44, Einsteinium a dit :

J'espère que tu n'ouvres pas ton site sur le net... sinon ton joomla va servir de porte d'entrée avec les failles de ce cas...

Bonjour,

 

Mon site est bien ouvert sur le net et opérationnel.

Pourriez-vous me donner l'astuce pour migrer ma version de PHP ?

Le 24/06/2017 à 11:44, PiwiLAbruti a dit :

En restreignant l'accès aux IP françaises dans le pare-feu du NAS, ça limite déjà énormément la surface d'exposition.

Bonjour,

 

Un petit tuto pour faire cela ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, concombremasque75 a dit :

Un petit tuto pour faire cela ?

Nul besoin d'un tuto, la documentation officielle suffit amplement (à condition de la lire) :

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement