This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Configuration Portainer


Messages recommandés

il y a 10 minutes, shadowking a dit :

A quel niveau as-tu cette erreur ? dans les logs du container à son démarrage ?

Oui.

il y a 12 minutes, shadowking a dit :

Parce que même s'il y avait un problème avec le docker.sock, tu auras juste un souci pour sélectionner un endpoint dans Portainer, ça ne t'empêcherait pas d'accéder à la page, de te logger, et de te balader dans les menus...

Exact.

il y a 12 minutes, shadowking a dit :

J'imagine que tu as vérifié que le port 9000 est accessible sur ton réseau local ?

Donc je sais pas pourquoi.

Lien à poster
Partager sur d’autres sites
  • Réponses 59
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Bonjour, Il n'y a rien à faire de particulier pour installer Portainer. Il se charge tout seul normalement via le daemon (si je me trompe pas) de prendre en compte les autres containers installés

2ème screen, ce n'est pas remote, mais local qu'il faut choisir.

Posted Images

il y a 47 minutes, shadowking a dit :

EDIT : Tu n'as pas une interférence entre ton volume portainer_data et les volumes que tu montes dans le service ? Essaie de commenter la définition du volume, ça devrait marcher si ton port 9000 est accessible avec ce que tu as écrit là.

J'ai decommenter :

 

volumes:
      - /volume1/docker/portainer/data:/data
      - /volume1/docker/docker.sock:/var/run/docker.sock:ro

J'arrive à me connecter sur sur l'interface mais dans les logs j'ai toujours ceci :

2019/08/01 13:23:43 background schedule error (endpoint snapshot). Unable to create snapshot (endpoint=MON-NAS, URL=tcp://portainer.ndd.com:9000) (err=Error response from daemon: 404 page not found)

Ceci sur toutes les adresses que je test .

Lien à poster
Partager sur d’autres sites

Ok pour s'assurer que le problème ne vient pas du/des volume(s), je te conseillerais de ne pas mettre de volume pour /data, il ira créer ça par lui-même dans un dossier obscur.

Tu montes par contre le docker.sock via /var/run/docker.sock:/var/run/docker.sock

Pour le reste tu ne touches pas.

Lien à poster
Partager sur d’autres sites
il y a 12 minutes, shadowking a dit :

Tu montes par contre le docker.sock via /var/run/docker.sock:/var/run/docker.sock

 

J'ai tester avec :

/var/run/docker.sock:/var/run/docker.sock

et

/volume1/docker/docker.sock:/var/run/docker.sock (j'ai cree un ln -s /var/run/docker.sock /volume1/docker/docker.sock)

On est d'accord que pour Endpoint URL qu'il faut mettre "localhost:9000" ?

Modifié par Superthx
Lien à poster
Partager sur d’autres sites

Tu peux faire un screen de la première proposition que tu as après avoir eu changer ton mot de passe ? Le fameux écran que tu as avec Endpoint URL ?

Je crois que j'ai compris.

Modifié par shadowking
Lien à poster
Partager sur d’autres sites

Voila les screens pour le compose suivant:

version: '2'

services:
  portainer:
    image: portainer/portainer
    container_name: portainer
    network_mode: bridge
    ports:
      - "9000:9000"
    volumes:
      - /volume1/docker/portainer/data:/data
      - /var/run/docker.sock:/var/run/docker.sock

    #environment:
        #- TZ=Europe/Madrid

volumes:
  portainer_data:

Au lancement :

1129307878_Sanstitre-2.thumb.jpg.0252974784536ab653b021b38da9552f.jpg

Configuration

1612525144_Sanstitre-4.thumb.jpg.4be0f28899751e443d0cbfe206d7230d.jpg

Erreur :

1397778426_Sanstitre-6.thumb.jpg.7ee96b459f79c7d18e4ad197decf82a6.jpg

Resultat

1036619089_Sanstitre-5.thumb.jpg.3418782e2861710dbf8cde7fba852e1b.jpg

Si tu veux plus dis moi.

Sans titre-3.jpg

Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.