This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Configuration Script envoie de mail


Messages recommandés

Bonjour à vous,

Je ne sais pas si c'est au bon endroit mais j'ai pas trouvé mieux 😅

Alors j'ai due changer mes disques et depuis mes scripts pour notifier par mail de la modification d'un dossier ne marche plus donc j'ai du louper un truc dans la nouvelle configuration mais quoi ???

Alors j'ai un DS218play sous DSM 7.1-42661 Update 2, j'ai installer Synology Mail Server et y ai configuré le smtp de google.

Pour le script je le mets en PJ mais avant il marchait donc je pense pas que cela viennent de lui.

et pour le planificateur de tâche j'ai mis root, toute les x min comme avant et puis le scrpit à l'intérieur comme avant.

et le résultat des mails du Synology :

----

Le planificateur de tâches a terminé une tâche planifiée.

Tâche : Notification ajout fichier XXX
Heure de début : Wed, 22 Jun 2022 20:50:01 GMT
Heure d'arrêt : Wed, 22 Jun 2022 20:50:01 GMT
État actuel : 1 (Interrompu)
Sortie/erreur standard :


De NAS

---

Donc cela m'aide pas car il n'y a pas l'erreur.
 
Et dans maillog j'ai cette erreur mais normalement mais credential sont ok : "SASL authentication failed; server smtp.gmail.com[XXXXXXXXX] said: 535-5.7.8 Username and Password not accepted."
 
Si vous avez besoin de plus d'info ou si j'ai posté au mauvais endroit n'hésitez pas 😉
 
En vous remerciant d'avance.

script mail.txt

Modifié par PPORCH3
Lien vers le commentaire
Partager sur d’autres sites

Il y a 2 heures, .Shad. a dit :

Est-ce que ton compte Google accepte bien les applications "moins" sécurisées comme ils appellent ça ?

Je viens de regarder et apparemment ce n'est plus "gérable" : "Google ne prendra plus en charge l'utilisation d'applications ou d'appareils tiers qui vous demandent uniquement votre nom d'utilisateur et votre mot de passe pour vous connecter à votre compte Google."

Donc si c'est ça qui bloque je suis mal barré...

il y a 15 minutes, PiwiLAbruti a dit :

Il ne manquerait pas le shebang #!/bin/sh en début de script ?

Il était comme ça avant mais je test quand même 😉

EDIT: Non cela ne change rien j'ai le même mail "vide"

Modifié par PPORCH3
Lien vers le commentaire
Partager sur d’autres sites

Tu as probablement moyen d'utiliser le serveur SMTP de ton FAI non ?

Je pense que c'est ça, car si c'était un problème d'accessibilité tu n'aurais pas de refus des credentials.

Sinon un domaine .ovh, c'est 3€ par an (1€ la première) et tu as ton propre domaine et un serveur SMTP à disposition.

Modifié par .Shad.
Lien vers le commentaire
Partager sur d’autres sites

à l’instant, .Shad. a dit :

Tu as probablement moyen d'utiliser le serveur SMTP de ton FAI non ?

Oui Orange dois surement le faire mais j'aurais aimé savoir pourquoi après la réinstallation de mon NAS et ayant suivi (théoriquement) la même procédure cela ne marche plus.
Et faut avouer que je préférerai continuer avec ce mail google.

Lien vers le commentaire
Partager sur d’autres sites

Je ne vois pas ce que Synology pourrait y faire. C'est un script utilisateur, eux n'ont rien à voir là-dedans.
Le fait de changer de disque n'a selon moi aucune incidence, surtout si tu n'as pas changé de version de DSM.

  1. Tu vérifies que les variables de ton script sont toujours correctes.
  2. Tu mets les données SMTP d'Orange, et tu vérifies si cette fois le mail part et arrive au destinataire.
Lien vers le commentaire
Partager sur d’autres sites

Je rebondis sur les remarques de @PiwiLAbruti, perso j'utilise :

#!/bin/bash

sur mes scripts pour DSM.

Et surtout tu peux utiliser la fonction set qui permet de personnaliser l'exécution du script, notamment :

set -euv

voir l'aide via SSH pour ce que font e, u et v :

help set

Je te conseille au minimum v pour voir où l'erreur se produit dans le script en exécution directe, ça donnerait donc :

#!/bin/bash
set -euv

en début de script.

Modifié par .Shad.
Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, .Shad. a dit :

Je rebondis sur les remarques de @PiwiLAbruti, perso j'utilise :

#!/bin/bash

sur mes scripts pour DSM.

Et surtout tu peux utiliser la fonction set qui permet de personnaliser l'exécution du script, notamment :

set -euv

voir l'aide via SSH pour ce que font e, u et v :

help set

Je te conseille au minimum v pour voir où l'erreur se produit dans le script en exécution directe, ça donnerait donc :

#!/bin/bash
set -euv

en début de script.

 

il y a une heure, PiwiLAbruti a dit :

Essaye d'exécuter le script depuis SSH, tu auras peut-être plus de détails sur l'erreur.

Merci à vous deux je test ça ce soir si je peux ou ce week-end 😉

Lien vers le commentaire
Partager sur d’autres sites

Il y a 6 heures, PPORCH3 a dit :

Je viens de regarder et apparemment ce n'est plus "gérable" : "Google ne prendra plus en charge l'utilisation d'applications ou d'appareils tiers qui vous demandent uniquement votre nom d'utilisateur et votre mot de passe pour vous connecter à votre compte Google."

J'ai eu le même souci  il y a quelques temps avec gmail pour envoyer des mails avec des scripts php.
La solution est d'activer la validation en deux etapes sur le compte google concerné et de définir un mot de passe d'application qui autorise ton NAS à acceder à l'application Gmail de ton compte google.
Ensuite tu remplaces 'nom d'utilisateur' et 'mot de passe' par 'nom d'utilisateur' 'mot de passe des applications' dans ta config DSM (panneau de configuration - Notification- Email)
https://support.google.com/accounts/thread/166498954/mot-de-passe-des-applications?hl=fr
https://myaccount.google.com/apppasswords
https://kb.synology.com/fr-fr/DSM/tutorial/How_to_use_Gmail_SMTP_server_to_send_emails_for_DSM
image.png.d46b157868bb19dbc8ae694fcf6f4220.png

Modifié par cadkey
Lien vers le commentaire
Partager sur d’autres sites

Merci @cadkey mais je suis perdu au niveau de cette étape j'ai mon mdp "spécial" mais je vois pas ou/comment mettre ce mdp, merci d'avance.

Citation

Ensuite tu remplaces 'nom d'utilisateur' et 'mot de passe' par 'nom d'utilisateur' 'mot de passe des applications' dans ta config DSM (panneau de configuration - Notification- Email)
 

image.png.8516e4b1f10918327a493346c5ba5396.png

Lien vers le commentaire
Partager sur d’autres sites

Merci de ton retour @cadkey je viens de modifier avec SMTP mais pareil je reçoit le même mail "d'erreur"...

Le problème doit venir de mon script du coup va falloir que je regarde en SSH ce week-end en espérant avoir plus d'informations sur l'erreur.

Je croise les doigts pour trouver une solutions.

Lien vers le commentaire
Partager sur d’autres sites

Salut, @.Shad. & @PiwiLAbruti je vient de tester en ssh en collant dans un .sh le script et j'ai l'erreur suivante :

 

bash-4.4# bash test.sh
: invalid option set: -
set: usage: set [-abefhkmnptuvxBCHP] [-o option-name] [--] [arg ...]
test.sh: line 114: syntax error near unexpected token `fi'
test.sh: line 114: `fi'

 

J'essaie de revérifier le script mais sans grande conviction...

Lien vers le commentaire
Partager sur d’autres sites

il y a 20 minutes, PPORCH3 a dit :

Salut, @.Shad. & @PiwiLAbruti je vient de tester en ssh en collant dans un .sh le script et j'ai l'erreur suivante :

 

bash-4.4# bash test.sh
: invalid option set: -
set: usage: set [-abefhkmnptuvxBCHP] [-o option-name] [--] [arg ...]
test.sh: line 114: syntax error near unexpected token `fi'
test.sh: line 114: `fi'

 

J'essaie de revérifier le script mais sans grande conviction...

Tu as mis quoi au début de ton script ?

Lien vers le commentaire
Partager sur d’autres sites

il y a 50 minutes, .Shad. a dit :

Tu as mis quoi au début de ton script ?

J'ai mis #!/bin/bash et après le set -euv.

Mais je viens de passé 2-3h avec le script et le SSH et avec la fonction -x : bash -x test2.sh et plusieurs recherche, j'ai trouvé que le problème venait (je suppose) des commandes avec synology mail server car maintenant que je suis revenu à l'envoie de mails via les commandes php le script refonctionne (+ encodage UNIX de notepad++).

Car à la base (y a longtemps) j'avais cette erreur (de mémoire) avec l'envoie en php et j'avais du trouver une solutions qui été Syno mail server.

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.