This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Einsteinium

Plex via docker, avec ou sans transcodage matériel

Messages recommandés

A qui appartient le PUID/PGUID ? Il faut que l'utilisateur appartienne au group "video"

 

Si par exemple l'utilisateur s'appel "plex", je te conseil de faire

Citation

chown -R plex:video /dev

Afin que /dev appartienne a l'utilisateur plex du group video

Modifié par EVOTk

Partager ce message


Lien à poster
Partager sur d’autres sites

je te conseil de remettre ton utilisateur special docker puis de faire la commande de permission :

 

Si par exemple ton utilisateur s'appel docker :

Citation

chown -R docker:video /dev

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah oui.. la commande a fait son effet ! On peut le voir sur le résultat de la commande en tapant

Citation

ls -lah /dev/dri


Du coup, mon "PlexDocker" a deux "PGID" maintenant ; il fait parti de "users" et "video". J'ai modifié les PGID/PUID, mais en PGID j'ai mis seulement l'ID du groupe "video".
C'est juste ? Ou il faut mettre les 2 groupes, séparés d'une virgule, genre "100,1000" ?

Edit : Même après suppression/réimportation du docker, c'est pareil.. 😞 

Modifié par CihanCK

Partager ce message


Lien à poster
Partager sur d’autres sites

Je crois ne pas avoir compris ta question.. !

Lorsque j'ai installé Docker sur le NAS, il a créé un user tout seul qui se nomme "docker".  Mais pour mon conteneur "Plex", j'utilise un nouvel utilisateur que j'ai nommé "PlexDocker"..
Donc si je comprends bien ta question, est-ce que le dossier "docker" qui contient toutes les configs et tout appartient à "PlexDocker" ?      ... je dirai... non ? 😅 

Euh.. sur cette ligne, on est d'accord que

Citation

uid=1040(PlexDocker) gid=100(users) groups=100(users),65540(video)

PUID = 1040
PGID = 100 
 
?

(dans "gid" je devrais pas avoir aussi le group "video" ?)

Modifié par CihanCK

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Dans ta config tu utilise /docker/PlexDocker

Le Dossier "PlexDocker" appartient bien a l'utilisateur "PlexDocker" ?

Le PGID tu doit utiliser 65540 ( video )

Partager ce message


Lien à poster
Partager sur d’autres sites

D'accord, merci.

Non, je ne crois pas car quand je lance cette commande, CK étant mon login sur le NAS ! :

Citation

ls -l /volume1/docker/PlexDocker/

J'obtiens :

Citation

drwxrwxrwx+ 1 CK     users           30 Oct  9 18:21 PlexDocker


Du coup j'ai lancé un petit

Citation

sudo chown -R PlexDocker /volume1/docker/PlexDocker/

sudo chmod -R 755 /volume1/docker/PlexDocker/

 

 

 

EDIT

:cool:  ÇA FONCTIONNE !! MERCI !!!!! ♥️:cool:

Modifié par CihanCK

Partager ce message


Lien à poster
Partager sur d’autres sites

 

Du coup, de temps en temps j'ai ça dans les logs

Citation

Critical: libusb_init failed
et, lorsque je lance une conversion
failed to open /data/jenkins/conan_build/290854758/conan/.conan/data/libva/2.4.0.1/plex/stable/package/9e07aef203e7a776d49230f7e190457a5658b628/lib/dri/hybrid_drv_video.so                                                                                                                                      Not using hybrid_drv_video.so 

La conversion se fait quand même, le "(hw)" est présent, c'est pas grave ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour sa

Citation

Critical: libusb_init failed

Rien de grave

Pour 

Citation

failed to open /data/jenkins/conan_build/290854758/conan/.conan/data/libva/2.4.0.1/plex/stable/package/9e07aef203e7a776d49230f7e190457a5658b628/lib/dri/hybrid_drv_video.so                                                                                                                                      Not using hybrid_drv_video.s

J'ai trouver un psot qui date de 6j avec on dirait le meme soucis ! la réponse de plex est d'attendre la prochaine MAJ ... https://forums.plex.tv/t/hw-transcoding-not-working-failed-to-wrapper-hybrid-drv-video-so/442588

Tu est sous quelle version ? ( Parametres > General )

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis actuellement sous la Version 1.18.0.1913 !

Ah oui, je vois ça.. merci 🙂

 

Dernière question, et  j'ai terminé avec mon dérangement 😁:

J'utilise le reverse-proxy DSM afin de faire : "plex.domaine.com" >> redirigé sur >> https://192.168.1.201:32400
Mais la redirection ne se fait pas, j'ai lu quelques réponses sur ce sujet, mais je n'y arrive pas 😕
J'utilise macvlan en ovs_eth0.. une idée ? 🤔

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors la, je ne pourrai t'aider. J'utilise https://plex.tv/web pour me co a distance. Vu que tu as le plex pass ( tu ne sera donc pas brider en vitesse de connexion ), et donc je te conseil aussi cette solution. Cela a l'avantage de fournir un connexion sécurisé entre ton serveur plex et le navigateur sans prise de tête 😄 

De plus l'interface Web de plex.tv/web est plus en avance que celle en "local", donc tu as accès plus vite au nouveautés, ...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, EVOTk a dit :

je te conseil de remettre ton utilisateur special docker puis de faire la commande de permission :

 

Si par exemple ton utilisateur s'appel docker :

 

🤔 Tu sais que c’est inutile ? Sachant que le script que l’on met au démarrage donne ses droits ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Va savoir pourquoi, j'ai dû passer par la moi aussi et j'ai cherché un moment. 

Peut être que je fait un truc pas correct dans la mise en place du script en tout cas quand je chmod moi même /dri je transcode en hw, avant non 🤔

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

Concernant les sous-titres,

J'ai remarqué après plusieurs mois d'utilisation, que les sous-titres n'étaient pas toujours bien calés pendant les films, ou encore aucun sous-titre durant certaines parties de dialogues.

Avez vous remarqué les mêmes problèmes ?

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

J'ai installé PLEX sur mon Syno hier. Là je suis en train de lire ce tuto. J'ai un peu de mal à comprendre l'intérêt de passer par Docker. Hormis d'isoler PLEX de DSM. Mais pourquoi vouloir l'isoler ? Je vois que c'est plus de configuration pour... quoi ? Quel intérêt ? Et je dis plus de conf mais aussi plus de ressource consommer (puisqu'on a docker en plus).

Voilà, je ne comprends pas ! Si quelqu'un peu m'expliquer l'intérêt histoire de voir si je me prends la tête à passer sous docker.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Passer sous docker permet une réinstallation facile en cas de soucis ! Imagine, plantage de DSM, réinstallation avec pertes de la config, si tu as sauvegarder ta config plex docker, la réinstallation te prend 1 min.

Les MAJ de plex se font automatique quand tu redémarre le conteneur.

La consommation de ressources est maîtrisé ( tu peux limiter l'utilisation cpu, la mémoire .. )

Les ressources utilisées par docker sont négligeable.

Si tu change un dossier partagé de volume, cela n'a aucun impact sur Plex

...

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Je fait appel de nouveau à votre aide.

je resume mon installation de plex:

NAS ds918+ / Plex en docker / partage avec la famille à distance.

 

Le problème depuis quelques jours en l'accès distant est long, et lecture saccadée peu importe film SD ou HD.

J'ai été un peu farfouiller dans les réglages plex pour essayer de trouver une solution mais sans résultats...

Et puis, je me suis aperçu que dans acces distant il est indiqué "Non disponible en dehors de votre réseau local"

Pourtant j'ai bien l'accès à distance sauf que c'est lent... alors je suis perdu pour le coup car je pense que le problème viens de là.

 

merci d'avance pour vos retours

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Si Plex te dit Non accessible depuis l'extérieur, c'est que le connexion se fait de façon indirect ( au travers des serveurs plex ) , c'est pour cela que c'est lent !

Vérifie tes ouvertures de port !

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 12 minutes, EVOTk a dit :

Salut,

Si Plex te dit Non accessible depuis l'extérieur, c'est que le connexion se fait de façon indirect ( au travers des serveurs plex ) , c'est pour cela que c'est lent !

Vérifie tes ouvertures de port !

Alors n'ayant pas une adresse full stack

J'ai fait une redirection port 8080 vers 32400.

Qui fonctionnais bien jusque la.

Ouvert dans le parfeu Synology également

Modifié par totoleouf

Partager ce message


Lien à poster
Partager sur d’autres sites

Le mieux c'est de dire a plex le port que tu veut utiliser.

Dans les parametres du serveur je te conseil d'indiquer 8080 et dans ta box, de rediriger 8080 vers le NAS, et d'ouvrir 8080

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, EVOTk a dit :

Le mieux c'est de dire a plex le port que tu veut utiliser.

Dans les parametres du serveur je te conseil d'indiquer 8080 et dans ta box, de rediriger 8080 vers le NAS, et d'ouvrir 8080

Tu veux dire d'indiquer dans docker que je veux utiliser le 8080 à la place du 32400?

Si oui, quand j'arrête le conteneur plex, puis modifier je ne peux plus modifier jai un message disant qu'il utilise le reseau docker host

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Non non directement dans Plex !

Paramètres > Accès à distance

s9f2nEf.png

Tu clique sur Spécifier un port public manuellement, et tu choisis un port dans ta plage qui ta était attribué.

Modifié par EVOTk

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 17 minutes, EVOTk a dit :

Salut,

Non non directement dans Plex !

Paramètres > Accès à distance

s9f2nEf.png

Tu clique sur Spécifier un port public manuellement, et tu choisis un port dans ta plage qui ta était attribué.

C'était déjà fait, j'ai deja le port 8080 mis en manuel dans Plex...

 

Autre bizarrerie, 

Quand j'utilise un navigateur pour plex, dans l'onglet de mon plex il est écrit connecté "à distance"

Mais quand je prend l'application PLEX installer sur le même ordi, il me dit connecté "à proximité"...

20191027_003020.jpg

Modifié par totoleouf

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement