This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Accès SMB depuis mon Mac


tompus

Messages recommandés

Bonjour,

ça fait depuis plus de 7 ans que j'ai des serveurs Synology et j'en suis très content...  contrairement aux PC sous Windows...

J'ai donc décidé récemment de m'acheter un Mac...  c'est un MacBook air de 2015, sous OS 10.13.6 (HighSierra).

Il a l'air facile à utiliser, malheureusement, je n'arrive pas à accéder à mon synology depuis mon Mac...

Ca fonctionne très bien depuis mon PC-Windows 10, depuis mes iPhone Xr, mais sur mon Mac, il apparaît dans le Finder (sous réseau "DiskStation-Tom"), mais quand je clique dessus, il m'écrit "Connexion en cours..." au lieu de me demander mes identifiants !   Puis, au final, il me fait "Echec de connexion".

J'arrive à me connecter en HTTP/HTTPS, mais je souhaite utiliser les services SMB pour plus de facilités.

Je précise que sur le Synology (DS116), les services de fichiers SMB sont bien activés.

 

Merci pour vos aides.

Lien vers le commentaire
Partager sur d’autres sites

Bonjour.

Je dirais que par défaut, le Mac essaie de se connecter au NAS avec le nom de session du Mac.

Si tu veux ouvrir une session SMB sur un autre user, il fait utiliser la « connexion au serveur » et indiquer le user du compte Synology à utiliser.


Rédigé avec Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

@StéphanH  Merci... mais...

 

Il y a 16 heures, StéphanH a dit :

Je dirais que par défaut, le Mac essaie de se connecter au NAS avec le nom de session du Mac.

C'est exactement ce que je me suis dis aussi...

Alors j'ai créer un utilisateur sur le NAS avec le même nom et mot de passe qu'un autre utilisateur sur le Mac...   Le problème était identique.

Il y a 16 heures, StéphanH a dit :

Si tu veux ouvrir une session SMB sur un autre user, il fait utiliser la « connexion au serveur » et indiquer le user du compte Synology à utiliser.

Evidemment !

Sauf que non...   quand je fais "connexion au serveur", j'indique l'adresse (smb://serveur  ou  smb://192.168.1.100) et là, pareille...  au lieu de me demander le login, le Mac essaye de se connecter, puis fini par me faire "échec de connexion".   Pourtant, le nom du serveur apparaît correctement automatiquement, sous "Partagé(s)",mais la petite fenêtre de login n'apparait jamais...   🙄

Je n'y comprends rien...

Modifié par tompus
Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, StéphanH a dit :

N’y aurait-il pas un pré feu actif sur le LAN ?

Pas que je sache...

J'accès à mon NAS sans aucun problème depuis mon PC , mes iPhone , mes TV et mes autres appareils...

Lien vers le commentaire
Partager sur d’autres sites

il y a 3 minutes, StéphanH a dit :

Depuis ton iPhone, en SMB, cela fonctionne donc ?

Je me suis mal exprimé...

Sur iPhone, j'utilise l'application dédiée...  Je ne sais pas si c'est en SMB ou pas.

Par contre, sur mon PC-Win10, c'est bien du SMB et ça fonctionne sans problème. 

Lien vers le commentaire
Partager sur d’autres sites

il y a 1 minute, alan.dub a dit :

Si tu passes par l’app « Fichiers », ce ne peut être que du smb. 
 

Si tu passes par l’app « DS File », ce ne peut être que du http/https. 

Alors les deux fonctionnent...

Le SMB et le HTTPS.

Lien vers le commentaire
Partager sur d’autres sites

Le 17/11/2021 à 15:02, tompus a dit :

Ca fonctionne très bien depuis mon PC-Windows 10, depuis mes iPhone Xr, mais sur mon Mac, il apparaît dans le Finder (sous réseau "DiskStation-Tom")

DiskStation-Tom n'est pas ce que tu devrais voir comme nom dans le Finder. C'est le modèle de ton NAS qui devrait apparaître, en l'occurence DS116 sauf exception. Et puis le point dans le nom ne peut être qu'une source d'ennuis.

 

Il y a 5 heures, tompus a dit :

Sauf que non...   quand je fais "connexion au serveur", j'indique l'adresse (smb://serveur  ou  smb://192.168.1.100) et là, pareille...  au lieu de me demander le login, le Mac essaye de se connecter, puis fini par me faire "échec de connexion".

Il n'est pas normal que l'on ne te demande pas d'abord d'entrer un nom d'utilisateur et un mot de passe pour ensuite tenter une connexion. Ça coince quelque part.

Qu'est-ce que ça donne quand, après commande + K (Se connecter au serveur), tu tapes smb://user@192.168.1.100/ ? user étant le nom d'un compte qui existe sur le NAS.

Le nom d'utilisateur ou le mot de passe comportent-ils des caractères non ASCII (caractères accentués et autres) ? Si c'est la cas, ça peut poser problème. Par exemple on n'accède pas à la lettre ` de la même façon sur un Mac ou un iPhone. Merci qui ? Merci Apple 🙂

Lien vers le commentaire
Partager sur d’autres sites

il y a 21 minutes, CyberFr a dit :

Le nom d'utilisateur ou le mot de passe comportent-ils des caractères non ASCII (caractères accentués et autres) ? Si c'est la cas, ça peut poser problème. Par exemple on n'accède pas à la lettre ` de la même façon sur un Mac ou un iPhone. Merci qui ? Merci Apple 🙂

Sur mac, les accents ne posent pas de soucis particuliers. J'ai un utilisateur avec un accent, et ça fonctionne bien... enfin de souvenir 😛
Ha bah en fait je viens de vérifier avec un utilisateur test pour lequel j'ai mis un accent, et depuis la connexion VPN (via la 4G), je n'arrive pas à le connecter (j'ai du aussi vérifier que le l'application SMB était en permission autorisée avant) lorsque le nom est testéé, mais j'y arrive avec test.
Donc tu as bel et bien raison... Il ne faut pas d'accents dans le nom d'utilisateur, sinon c'est la merde pour le SMB...
Par contre, via Drive ou Filestation, pas de soucis... chercher l'erreur...

Lien vers le commentaire
Partager sur d’autres sites

Il y a 23 heures, CyberFr a dit :

DiskStation-Tom n'est pas ce que tu devrais voir comme nom dans le Finder.

Ben au fait, c'est automatique...

Il y a 23 heures, CyberFr a dit :

Et puis le point dans le nom ne peut être qu'une source d'ennuis.

Je n'ai pas de point, dans le nom du serveur...  tu parle du tiret ("-") ?

Il y a 23 heures, CyberFr a dit :

Il n'est pas normal que l'on ne te demande pas d'abord d'entrer un nom d'utilisateur et un mot de passe pour ensuite tenter une connexion. Ça coince quelque part.

En effet !    Je m'en rends bien compte....   c'est pour cela que je suis ici...  pour savoir où ça coince...

Il y a 23 heures, CyberFr a dit :

Qu'est-ce que ça donne quand, après commande + K (Se connecter au serveur), tu tapes smb://user@192.168.1.100/ ? user étant le nom d'un compte qui existe sur le NAS.

Je n'ai pas encore fait le test comme ça...  J'ai essayé l'adresse IP sur le protocole SMB, mais sans le nom d'utilisateur...   J'essaye ce soir, mais je n'y crois pas trop...

Il y a 23 heures, CyberFr a dit :

Le nom d'utilisateur ou le mot de passe comportent-ils des caractères non ASCII (caractères accentués et autres) ? Si c'est la cas, ça peut poser problème. Par exemple on n'accède pas à la lettre ` de la même façon sur un Mac ou un iPhone. Merci qui ? Merci Apple 🙂

J'ai effectivement des caractères spéciaux, dans mon mot de passe...  mais le problème actuellement n'est pas là, vu qu'il ne me demande même pas le mot de passe pour l'instant.

Il y a 23 heures, MilesTEG1 a dit :

Donc tu as bel et bien raison... Il ne faut pas d'accents dans le nom d'utilisateur, sinon c'est la merde pour le SMB...

De manière générale, les accents ne sont pas bien, sur n'importe quel système informatique...   il y a toujours la merde avec les accents !

Lien vers le commentaire
Partager sur d’autres sites

Bonjour @tompus,

Il y a 2 heures, tompus a dit :

Ben au fait, c'est automatique...

DiskStation-Tom en effet ne comporte pas de point comme je l'ai pensé par erreur. D'où sort ce nom ? Ce n'est pas le nom d'un modèle de NAS, tu as dû le consigner quelque part dans les réglages de DSM. Il serait intéressant de savoir où.

Je te conseille de supprimer les accents dans les noms d'utilisateurs ou les mots de passe. De toute façon, il faudra le faire un jour ou l'autre. Autant le faire maintenant. Ce sera un problème de moins.

Peux-tu nous mettre une copie d'écran de tes réglages SMB ?

Lien vers le commentaire
Partager sur d’autres sites

il y a 11 minutes, alan.dub a dit :

Peut être voir s’il n’y a pas d’enregistrement sur la connexion SMB dans le trousseau de clés ?

Peut-être mais dans ce cas le nom d'utilisateur apparaît avant la connexion de même que le mot de passe sous forme de petits ronds noirs. Il faut confirmer et donc clicker sur OK avant que la connexion ne soit effective.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 1 heure, CyberFr a dit :

Peut-être mais dans ce cas le nom d'utilisateur apparaît avant la connexion de même que le mot de passe sous forme de petits ronds noirs. Il faut confirmer et donc clicker sur OK avant que la connexion ne soit effective.

Bonsoir,

Si les identifiants sont sauvegardés dans le trousseau d'accès, la connexion ce fait directement sans l'apparition de la fenêtre.

Et via Finder > Aller > Se connecter au serveur > smb://IPduNAS, on arrive directement sur une fenêtre pour choisir un dossier partagé sans passer par la fenêtre de connexion.

Il y a 2 heures, alan.dub a dit :

Si oui, les supprimer, redémarrer le mac et lancer une nouvelle connexion. 

Ou relancer le Finder. (Alt/Option + clique droit sur l'icone Finder > Relancer)

Modifié par maxou56
Lien vers le commentaire
Partager sur d’autres sites

Bonjour @maxou56,

Il y a 12 heures, maxou56 a dit :

Si les identifiants sont sauvegardés dans le trousseau d'accès, la connexion ce fait directement sans l'apparition de la fenêtre.

Chez moi la fenêtre apparaît. Sans doute parce que plusieurs utilisateurs sont mémorisés dans le trousseau d'accès et pour le coup on me demande d'en choisir un.

Voilà ce qui expliquerait les problèmes de @tompus et le fait qu'on ne lui demande rien avant la connexion. Il faudrait qu'il fasse le ménage dans son trousseau d'accès et qu'il supprime l'utilisateur de SMB. Et surtout qu'il ne mémorise pas l'identifiant et le mot de passe de cet utilisateur dans le trousseau afin de garder la main jusqu'à ce que ses problèmes soient résolus.

Il y a 12 heures, maxou56 a dit :

Et via Finder > Aller > Se connecter au serveur > smb://IPduNAS, on arrive directement sur une fenêtre pour choisir un dossier partagé sans passer par la fenêtre de connexion.

Chez moi la fenêtre apparaît. Sans doute pour les mêmes raisons qu'expliqué précédemment.

Lien vers le commentaire
Partager sur d’autres sites

Merci pour vos réponses …

au fait, c’est un MacBook que je viens d’acheter en occas’…. Il a été remis à zéro et je n’ai jamais indiqué d’utilisateur ou de mot de passe. Donc il n’y a rien dans le trousseau (j’ai verifié).

merci encore pour toutes vos suggestions , et désolé de ne pas pouvoir répondre plus vite….  Je cherche encore la solution à mon problème. 

Lien vers le commentaire
Partager sur d’autres sites

il y a 3 minutes, tompus a dit :

Il a été remis à zéro

Bonsoir,

C'est à dire, formatage complet (en sélectionnant la racine) du disque dur, SSD (en démarrant sur le mode recovery ou depuis un clé USB d'installation, puis réinstallation de macOS?

Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, maxou56 a dit :

Bonsoir,

C'est à dire, formatage complet (en sélectionnant la racine) du disque dur, SSD (en démarrant sur le mode recovery ou depuis un clé USB d'installation, puis réinstallation de macOS?

Je ne sais pas….  Je n’y connais pas grand chose….  Est-ce que ça peut être important ?

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.